OPD Parser doesn't show OPD

Discussion in 'AnyDVD HD (UHD only)' started by happyguy82, Oct 29, 2019.

  1. happyguy82

    happyguy82 Well-Known Member

    Hi all,

    I'm trying to get the OPD for my disc The Wizard of Oz (1939) but when I select the log file, nothing is displayed on the console screen. When I try the same with other discs e.g. The Last Jedi, I can see the OPD displayed. Am I missing a step?

    Thanks in advance.
     
  2. Pete

    Pete Forum Admin Staff Member

    I'm sorry, I don't understand at all what you're asking.
    Best might be to formulate your actual problem and attach the log file here.
     
  3. happyguy82

    happyguy82 Well-Known Member

    I am trying to get the OPD value for my disc using the AnyDVD OPD Parser software. The name of the 4K Blu-Ray Disc is The Wizard of Oz.

    However the window is blank, i.e. it doesn't show me the OPD value.

    I have attached the logfile here. Could you please try opening this with the OPD Parser software?

    Thanks.
     

    Attached Files:

  4. SamuriHL

    SamuriHL Moderator

    This is the tool I wrote. Lemme take a look at your log.
     
  5. SamuriHL

    SamuriHL Moderator

    Something weird is going on with AnyDVD for you on this one. The log doesn't contain the OPD information which is why the OPD Parser is showing blank. I should probably change the logic of the parser to make it clear that the OPD information isn't there.

    However, your disc is failing on bus encryption. Are you SURE that's the UHD and not the blu-ray?
     
  6. James

    James Redfox Development Team Staff Member

    It looks like an unfriendly drive to me. But ASUS BW-16D1HT 3.02 is supposed to be friendly..?

    EDIT: I am very sure, this is the UHD.
     
  7. SamuriHL

    SamuriHL Moderator

    I was just making sure on the disc type. And yes, that SHOULD be friendly so I don't fully understand the error on bus encryption?! Very confused.
     
  8. James

    James Redfox Development Team Staff Member

    Never heard of your tool. Until now. :)
     
  9. SamuriHL

    SamuriHL Moderator

    Just thinking out loud here @happyguy82 can you post a log from any other UHD? Like one that you say works?
     
  10. SamuriHL

    SamuriHL Moderator

    Ah, yea, they wanted a way to keep track of different versions of each UHD disc so I threw it together. :)
     
  11. James

    James Redfox Development Team Staff Member

    Good idea.
     
    whatever_gong82 and SamuriHL like this.
  12. happyguy82

    happyguy82 Well-Known Member

    Yes my drive is UHD Friendly, it's the LG BH16NS55. I have flashed the Asus firmware onto it.

    I can play all the other UHD discs that I own with no problems using this drive.

    Here's a log that works.
     

    Attached Files:

    Last edited: Oct 29, 2019
  13. happyguy82

    happyguy82 Well-Known Member

    Thanks in advance. I've attached one for you in the post above. Here's another one :)
     

    Attached Files:

  14. happyguy82

    happyguy82 Well-Known Member

    And just to confirm, yes this is a brand new UHD disc for the 1939 Wizard of Oz that was just released. It's failing on bus encryption because AnyDVD doesn't support it yet.
     
  15. SamuriHL

    SamuriHL Moderator

    No it's different than that. I have this disc and I'm able to get a full log for it with my ASUS 3.10MK drive. Something else is going on here, other than just a disc that isn't yet supported. At the moment, even if the key was in the OPD, your drive would not decrypt the disc. And that's problematic.
     
  16. SamuriHL

    SamuriHL Moderator

    Sorry, @happyguy82, I hate to be a pain in the ass, but, could you post one of those disc's logs with 8.4.0.0, please? I don't think it'll matter but I'm trying to rule out possibilities here.
     
  17. happyguy82

    happyguy82 Well-Known Member

    Sure here's The Last Jedi with 8.4.0.0

    And please don't hesitate to ask for anything, I'm more than happy to help.

    P.S. I have another drive with is the same LG BH16NS55 but with the original firmware that I could try if this disc can't be decrypted in the future. Btw with my current drive (the ones used above) I can see the file and folder structure of the disc but it takes a long time to initialise it, which is a problem I don't get with my other discs.
     

    Attached Files:

  18. SamuriHL

    SamuriHL Moderator

    That's very interesting. No issue with 8.4.0.0 on that disc. I'm starting to suspect a bad disc in the case of Wizard of Oz but hopefully @James has more ideas here because I don't know what else to try.
     
  19. happyguy82

    happyguy82 Well-Known Member

    Hmmm unfortunately I don't know how unsupported discs are meant to behave, thus I am unable to tell whether the disc itself is faulty. I can read the file structure though.

    I could try with the other LG drive later tonight and let you know.
     
  20. SamuriHL

    SamuriHL Moderator

    It wouldn't hurt. The relevant part of your log is this:

    Code:
     12.41s: MKB version 72
     12.41s: MKB type 48141003
     12.41s: driveSupportsBusEncryption 1
     12.44s: discRequiresBusEncryption 1
     12.44s: SendKey failed, sense 5:6f:1
     12.44s: Failed to send host key (bus encryption)
    
    vs from my log:

    Code:
     33.16s: MKB version 72
     33.16s: MKB type 48141003
     33.16s: driveSupportsBusEncryption 1
     33.20s: discRequiresBusEncryption 1
    busKey: ...
    
    On mine the bus key was sent correctly and all was well (other than the disc not being supported). So yea, I'd try with your other drive and post another log for us to take a look at.