Failed to send host key (bus encryption) (only with some disks)

Discussion in 'AnyDVD HD (UHD only)' started by Blazkowicz, Nov 16, 2020.

  1. Blazkowicz

    Blazkowicz Well-Known Member

    When I insert Fantastic Beasts 2 UHD into my external drive, I get this error:

    Failed to send host key (bus encryption)

    When I insert a different UHD into the same drive (I never had the problem with any other UHDs I own), it works fine (also shows "Disc wants bus encryption!" in log).

    I attached a log of both UHDs. The problematic UHD works in another drive.

    MakeMKV and any other software (which can remove UHD copy protection) were not active during the Windows session I tested.

    So I wonder why it fails for this specific UHD.
     
  2. whirlpool

    whirlpool Well-Known Member

    Maybe it’s not yet supported.......
    Note: UHD support for a title is not release-based and can happen at any time as it just involves adding a key to the OPD.

    So check often!”
     
  3. Blazkowicz

    Blazkowicz Well-Known Member

    It would display this error then (which displays for the other working drive):

    Cannot process request at this moment, please try again later!
    ERROR processing Blu-ray disc!
     
  4. whirlpool

    whirlpool Well-Known Member

    Doesn’t that message also indicate that UHD is not yet supported ?
     
  5. Blazkowicz

    Blazkowicz Well-Known Member

    This message is the one it is referred to (as mentioned in my previous post on main drive I get the initial error, on other the not_supported one and try later).
     
  6. whirlpool

    whirlpool Well-Known Member

    I have seen both of the errors you mention, in the case of an unsupported UHD movie.
     
  7. James

    James Redfox Development Team Staff Member

    I suggest to remove the deuhd.sys driver. It is broken. It can interfere, even if DeUHD is off.
    The good news: DeUHD doesn't need the driver. It can "rip" fine without it.
     
  8. James

    James Redfox Development Team Staff Member

    Hmm, no, you shouldn't.
     
  9. whirlpool

    whirlpool Well-Known Member

    I also have DEUHD installed, but was pretty sure I had removed deuhd.sys.

    But I have de-installed/re-installed it a number of times in the past. Maybe on one occasion deuhd.sys was left in place and I got a ‘Failed to send host key (bus encryption)’.
     
  10. Blazkowicz

    Blazkowicz Well-Known Member

    Thank you for your reply @James. I removed it via ImgBurn, then powered up the external drive and voila, the host key could be send :)

    EDIT: Now for another disk, same drive :(
    Also after a complete reboot. New log attached.
     

    Attached Files:

    Last edited: Nov 18, 2020
  11. Blazkowicz

    Blazkowicz Well-Known Member

    Any other idea what I can try? The drives are uhd-friendly or else they would not work with other disks.
     
  12. James

    James Redfox Development Team Staff Member

    No idea, sorry.
     
  13. 0x0x0x0x0

    0x0x0x0x0 Well-Known Member

    I'm hitting this error with a German release of IT (remake) but is fine with a German release of IT Ch. 2. Would the logs tell you the reason for the failure or are they pretty useless at this point?
     
  14. SamuriHL

    SamuriHL Moderator

    You could attempt to post a log but it probably won't make a difference. We can look though.
     
  15. 0x0x0x0x0

    0x0x0x0x0 Well-Known Member

    here goes nothing... between .5.0 and 5.2 beta the message went to being unable to retrieve volume id (LG and an ASUS one (rebranded LG really) just to make sure).

    The disc plays fine in a Sony 4K player.
     

    Attached Files:

  16. SamuriHL

    SamuriHL Moderator

    I'm confused. 8.5.0.2 looks to have decrypted the title fine. So what is the issue? Yes, I saw the bus encryption error with 8.4.9.0 but it worked with no issue with 8.5.0.2.
     
  17. 0x0x0x0x0

    0x0x0x0x0 Well-Known Member

    I thought that "Error retrieving VolumeID!" was a deal-breaker for decrypting the disc... So, anyway, I went back and tried to rip it, and we're back to square one with .2, and I even rebooted for a good measure:
     

    Attached Files:

  18. SamuriHL

    SamuriHL Moderator

    Not for UHD, no. That error is meaningless for UHD. However, the bus encryption issue isn't. I've no idea what's different about each log on the same disc/drive where one worked and one didn't.
     
  19. 0x0x0x0x0

    0x0x0x0x0 Well-Known Member

    Good to know re. the volume id for UHDs. Intermittent failures are fun ;-)
     
  20. SamuriHL

    SamuriHL Moderator

    Yea, no idea on that one. Not seen any problems like that. Usually it works or it doesn't UNLESS it's having issues reading the disc. Which is always possible.