BD ISOs not playing in PDVD 8 (no problem at PDVD 7)

Discussion in 'AnyDVD HD (Blu-ray issues)' started by spcav, Apr 22, 2008.

  1. spcav

    spcav Beta Tester

    OK, I know that the whole thing with BD ISOs has been discussed a lot but I am facing this strange problem:

    I have many BD movies ripped to folders for about 1,5-2 years now.

    Most of them have been ripped with AnyDVD HD (various versions over the last 1,5 year).

    I am using imgburn (2410), magiciso or Nero to create ISOs from these folders and then I mount the image with daemon tools or magiciso.

    I read SamuriHL’s guides and I can say that I couldn’t find something I am doing wrong.

    All ISOs created are working fine with PDVD 7 but almost all of them do not work with PDVD 8.

    I get either a message ‘no disc in drive’ or ‘unsupported disc format’.

    In some cases playback starts but I get only a black screen (the counter keeps going on).

    In some rare cases the intro of the movie (the first clip of the studio’s intro) may appear normally but then I get the black screen (as above).

    In very few cases (1-5%) the ISOs are playing with no problem.

    Please note that the above happens even with very recent movies (0-2 weeks old which have been ripped with the latest version of AnyDVD HD).

    Enabling or disabling AnyDVD HD during ISO creation and / or mounting / playback doesn’t change a thing.

    The strange thing is that I read that people over the net don’t have the same problem (at least not regarding latest rips).

    When I am following the same procedure but ripping again an original disc the ISO is playing normally with PDVD 8.

    I suspect that there is something wrong with the structure of the folders / iso which in only ‘bothering’ PDVD 8 and not 7. This assumption is based on the fact that, as mentioned above, I am getting 4 different types of errors when I am having the problem (‘no disc in drive’, ‘unsupported disc format’, black screen, in some rare cases the intro of movie (the first clip of the studio’s intro) may appear normally but then I get the black screen (as above)).

    I just read this http://forum.slysoft.com/showthread.php?t=15871 and I am wondering if this could the problem (although in PDVD 7 everything is OK). I am not at home right now so I cannot test it.

    Any thoughts on the above would be highly appreciated.

    PS I mainly tested under WinXP.
     
    Last edited: Apr 22, 2008
  2. Bigrick

    Bigrick Well-Known Member

    im not sure your exact problem because i use windows vista and i dont know if that makes a difference cause all my BD movies work just fine with PowerDVD 8 but i havent heard that there has been a problem playing BD with Version 7 and not with 8 unless you might have changed something in the settings of powerdvd. you might even need to update your drivers. are you sure you have anydvd hd enabled during playback?
     
  3. Bigrick

    Bigrick Well-Known Member

    what version of powerdvd 8 are you using is it a beta, ultra or the delue version which doesnt play Bluray ?
     
  4. spcav

    spcav Beta Tester

    Thanks for the response but if you read my post you will see that the problem is only BD ISOs and only with PDVD 8 (Ultra of course).
     
  5. Bigrick

    Bigrick Well-Known Member

    im not sure what to tell you then maybe SamuriHL is out there and he can shine some light on the subject;)
     
  6. spcav

    spcav Beta Tester

    Please don’t misunderstand this but I am quite familiar with PDVD, AnyDVD HD, drivers and in general with HD playback, so I don’t think that there is an issue there.

    The ‘’problem’’ seems to be the ISO building / structure or something like that especially related with PDVD 8 and not 7.
     
  7. Bigrick

    Bigrick Well-Known Member

    i understand that completly its just weird that your movies play in 7 but not in 8 i dont get that at all
     
  8. starz

    starz Well-Known Member

    Are your ISO all in UDF 2.50?
    Are these random errors on the same title or are random titles giving random errors?
    I have seen some of the errors you described in PDVD Ultra 7
    the cause is usually cause power DVD needs to be updated
    since you say it's happening with new titles, this could be why.
    then again if they play in 7 and not 8 8 may have a bug to be worked out with them titles,
    Also another cause maybe the region code, one disc of mine did this awhile back I riped with automatic region code removal and wound up with a disc that did nothing but loops and black screen, I have noticed that powerdvd is rather unstable from time to time, and when they do Finlay fix 1 problem they tend to create 5 new ones, "Just what it feels like sometimes"
    other then that I don't know sorry:(

    starz,
     
  9. Bigrick

    Bigrick Well-Known Member


    that a good point to what did you set the region to in powerdvd 8, at the begining when you install it it asks you what region you want and you have up to 5 times to change it are you sure sure you set it to the right one also im sure the UDF is set to 2.5, it has to be if it plays in 7
     
  10. spcav

    spcav Beta Tester

    Yes, the strange thing is that there is no problem in 7, only in 8.

    All ISOs are in UDF 2.5 of course.

    These random errors come from almost all titles. Each title gives the same (possibly different than other ones) error all the time.

    I am using the only PDVD 8 Ultra version available (the first one officially released). Not any beta etc.

    I think that the more ‘clean’ way is to make the ISO with AnyDVD HD disabled (aka no region coding removal there).

    During playback, I tried changing regions from AnyDVD HD but without success.
     
    Last edited: Apr 22, 2008
  11. Bigrick

    Bigrick Well-Known Member

    sorry im a little off this morning and i didnt follow, are you saying when you made the ISO that you had anydvd hd disabled or enabled also check the region settings of powerdvd like i said above
     
  12. spcav

    spcav Beta Tester

    I am saying that the ISO making procedure was done both with AnyDVD HD enabled and also disabled.

    The same stands for playback.
     
  13. starz

    starz Well-Known Member

    you said it was power dvd 8 that had the problem up at your first post
    All ISOs created are working fine with PDVD 7 but almost all of them do not work with PDVD 8.
    :confused:
     
  14. Bigrick

    Bigrick Well-Known Member

    thats why im think its a region setting with powerdvd 8 and if thats the case he just need to go into the setting and chage that other then that i dont see what the problem is because its not the ISOs
    because they play fine in version 7
     
  15. starz

    starz Well-Known Member

    can you name some of the problematic titles?
     
  16. starz

    starz Well-Known Member

    could be but what I meant earlier was with region settings in anyDVD removing the region code incorrectly from the disc during the rip
     
  17. Bigrick

    Bigrick Well-Known Member

    thats a good point to none the less im sure its a region setting somewhere because he ripped everything properly so its either with anydvd or powerdvd
     
  18. starz

    starz Well-Known Member

    you also mentioned creating ISO with Nero and imgburn and something else is it possible to pinpoint ur problematic ISO to a any particular one of your ISO creation programs?
     
  19. spcav

    spcav Beta Tester

    I think i found the solution:

    As mentioned in another forum (don't know if it is a good idea to post the link):

    - in Root you also need a CERTIFICATE folder containing BACKUP folder
    - in BDMV you also need a BDJO, JAR, and META folder
    - in BACKUP you also need a BDJO folder

    So all these folders seem to be necessary for normal BR playback in PDVD 8 while 7 seems not to care.

    I think that some of ''folder'' rips don’t include all these folders so this could make sense.

    I will try and revert
     
  20. Bigrick

    Bigrick Well-Known Member


    everytime i make an ISO i rip the whole disc i dont take out any folders which could be a reason to why mine work and his dont unless thats what spcav did and in that case were back to square one