AS 1.2.8.0 DRM works, but no subtitles

Discussion in 'AnyStream' started by DeepSpace, Dec 23, 2021.

  1. BillyBeer

    BillyBeer Active Member

    Going through a Marvel and Witcher binge, nothing is downloading with english assistive or english forced. Same for a half dozen anime series as well.
     
  2. mattu

    mattu Member

    +1, selected srt files, not a single one downloads - but so glad that AS is back up and running for NF :D
     
    DeepSpace likes this.
  3. Criss

    Criss Active Member

    Hi ! I have the same problem on NF with subtitles : I select them but when the file is downloaded there is no subtitles at all, and no error message.
    Besides that, HAPPY XMAS to all of you :))
     
    Last edited: Dec 24, 2021
    DeepSpace likes this.
  4. Lowpro

    Lowpro Well-Known Member

    I just finished authoring the Netflix TV show, Lost in Space: Season 3 to Blu-ray. The streams downloaded via AnyStream 1.2.8.0 without issue with the exception of the subtitles of course. The resulting video and audio was clean from start to finish. When authoring to Blu-ray I did include subtitles though. I found a set of English subtitles in SRT format (text based) which I converted to SUP format (image based), the format required for Blu-ray. I found very little in the way of errors when working them over in SubtitleEdit. They were quite clean with no adjustment in timing needed. In any event, just thought I'd share the love. I uploaded both sets of subtitles (SRT and SUP) to my secure website in the event anyone was interested. They can be downloaded here. Enjoy!
     
    Last edited: Dec 25, 2021
  5. vikingár

    vikingár Well-Known Member

    Can confirm that there were no subtitles from NF downloaded - whilst they were checked (but video is ok).
    I made it done with the Greasemonkey script mentioned above.

    Kudos to all the programmers!
    Happy Holiday!
     
    whatever_gong82 and DeepSpace like this.
  6. magicliff

    magicliff Member

    Thanks a lot. This is a great temporary solution.
     
    DeepSpace likes this.
  7. BoomKapoow

    BoomKapoow Well-Known Member

    Yes, that script will be a time and token saver in future as well so not just this time, very useful indeed not having to re-download stuff with AS just because of a missing sub, like when you grab stuff over VPN and movie becomes available later in your region you can just use that script downloading that subtitle
     
    DeepSpace likes this.
  8. robv14001

    robv14001 Member

    Interesting suggestion. Just tried that. Does not work.
     
  9. network

    network Well-Known Member

    I wrote this already in the German forum, but once again: Since the subtitles downloaded with the Greasy Fork Script are in .vtt or .dfxp format, here are some workarounds how to convert them into .srt:

    1) Online via https://gotranscript.com/subtitle-converter (In case you want to convert several subtitles, press "F5" after each conversion - otherwise you will get a CAPTCHA).

    2) You can install SubtitleEdit and do the conversion in a Command Prompt (here for Windows):
    Code:
    "%ProgramFiles%\Subtitle Edit\SubtitleEdit.exe" /convert *.vtt subrip
    or
    "%ProgramFiles%\Subtitle Edit\SubtitleEdit.exe" /convert *.dfxp subrip
    Alternatively you can use the enclosed batch file for automatic conversion, just put the .bat file into the directory containing your downloaded subtitles.[/QUOTE]
     

    Attached Files:

    BillyBeer and DeepSpace like this.
  10. Aceso

    Aceso Well-Known Member

    So I may be missing something, but I've used SubtitleEdit to batch convert a bunch of subtitles before.

    I used the GreaseMonkey script and got the VTT then I went to convert it over to SRT, but for some reason it takes the punctuation on each of the lines and moves it from the end to the start of the line.

    So something like
    Code:
    Let's test this!
    now becomes
    Code:
    !Let's test this
    Is there a particular reason it's doing that? I tried looking in the options, but nothing. First time I've had it happen before. I mainly used it on idx/sub files when I was converting my blurays over.

    Interesting enough running the batch script like you mentioned doesn't do it, but gives all the extra tags. If I run it through SubtitleEdit's batch convert it does.

    Edit: After noticing your script worked I went back through SubtitleEdit's options. Apparently it was the "Fix RTL" option that did it. Going to leave this post here in case someone experiences the same problem or I have it again in the future, haha.
     
    Last edited: Dec 27, 2021
    DeepSpace and network like this.
  11. robv14001

    robv14001 Member

    I replied to this already, but I don't see a reply here. In any case, I tried that, and it didn't work. I'm not going to try that Chrome add-on thing also posted in this forum. I will wait for a fix.
     
  12. BCloud

    BCloud Active Member

    When you download the title with external srt files it works.
     
  13. 10969

    10969 Member

    Can confirm. Subtitle files seem to work and are being downloaded properly now, at least for Itaewon Class, which was not working before. (Now to see if the video will not be corrupted after 2 minutes... (Edit: It was still corrupted))

    Not sure if this is what fixed the subtitle issue, but I am using ver 1.2.8.2.

    Edit: Subtitles also working for King's Affection.
     
    Last edited: Dec 29, 2021
  14. BillyBeer

    BillyBeer Active Member

    Did not work for:
    SWAT
    Karate Kid (movies)
    Cobra Kai
    Datedevil
    The Punisher
    The Terror
    Super Crooks
    Hellbound
    Great Pretender
     
  15. RedFox 1

    RedFox 1 Super Moderator

    Using 1282, should make no difference, as it only added more information in log files. for the developers to fix the issues
     
  16. PeterS

    PeterS Well-Known Member

    Workaround for missing subtitles on NF in single films:

    I am downloading the movie with 1.2.8.0; unfortunately without subtitles.
    Then I downloaded the same movie with an earlier version (1.2.6.0). This version complains that it is out of date, but I ignore that.
    After I started the DL, it logically aborts with an error message.
    But: I still have the subtitle files on my PC.
    Et voilà!

    This workaround is certainly only practicable for individual films, not for series. The expenditure of time would be too great and twice as many tokens are used.
     
    TheSunGod likes this.
  17. 10969

    10969 Member

    Have you tried with the beta version 1.2.8.2?
    https://sandbox.redfox.bz/SetupAnyStream_1.2.8.2_64bit.exe

    Subtitles are working for me with this version.
     
    Lowpro likes this.
  18. Ch3vr0n

    Ch3vr0n Translator NL

    That's not the latest, there's a 1283

    Sent from my Pixel 3 XL using Tapatalk
     
    Lowpro likes this.
  19. 10969

    10969 Member

    I saw on another thread that that version is mainly for Japanese users?
     
  20. Ch3vr0n

    Ch3vr0n Translator NL

    Perhaps, just saying it wasn't the latest

    Sent from my Pixel 3 XL using Tapatalk