Windows update 1903 Excellent

Discussion in 'General Chat' started by RedFox 1, May 31, 2019.

  1. RedFox 1

    RedFox 1 Super Moderator

    I really love the new 1903 update. No issues at all for me, I know I might be lucky but I did what the Microsoft forum said to do. Update all my drivers and programs.
     
    Last edited: Jun 3, 2019
  2. RedFox 1

    RedFox 1 Super Moderator

    This is by far the best update yo Windows yet. My machine was fast but now its almost like on Steroids
     
  3. Jeff R 1

    Jeff R 1 Well-Known Member

    It broke the 3 finger back swipe on my Logitech mouse pad in the Windows and Movie TV app, it simply no longer works.

    While I could just mouse up into the corner and click on the back arrow button, it becomes very tedious doing that on a 120 inch screen.
    This is even more so when I want to surf to see what movies are available and watching trailers.

    It created such a mess with the registry I had to go back to 1709 to get that function back.
     
  4. RedFox 1

    RedFox 1 Super Moderator

    Sorry to hear that Jeff, it didnt break anything on mine, just made things better and faster.
     
  5. Jeff R 1

    Jeff R 1 Well-Known Member

    The mouse pad gesture appears to be working now, at least on the 3 year old Dell Alienware laptop in the kitchen.
    I spent the better part of two days installing and re-installing different versions of W10, finally settling on 1709.
    I then allowed it to upgrade to 1803 which killed the function again, so I reverted back to 1709.
    When one does this, Microsoft wants to why and I told them specifically what the problem was, this mourning it's working on this machine.

    This has happened before going from one version to another and reporting it to Microsoft.

    Maybe someone actually looks at that particular feed back when a function stops working, going from one version to another that is, you can imagine the thousands of people complaining on all the feedback hubs in all the apps.
    I'm tempted to create a USB system image of the HTPC now that I have it working and try 1903 again, or just slip in another hard drive.
     
  6. RedFox 1

    RedFox 1 Super Moderator

    From what I understand you have to have all your drivers up to date on your devices before installing 1903. Its been very good to me so far.
     
  7. Harley51

    Harley51 Well-Known Member

    The problem that I have is the Standard Sata AHCI Controller cannot start code 10 I/O adapter hardware has occurred. Still working it to find a solution.
     
  8. Jeff R 1

    Jeff R 1 Well-Known Member

    Well maybe, I plugged in the Logitech USB dongle and W10 1903 almost immediately installed the latest SetPoint driver and the 3 finger swipe worked right off the bat. :rolleyes:

    It's also quite possible that an in-situe upgrade is necessary in cases like this as apposed to clean installs, at least when it comes to Logitech and SetPoint.

    I'll know in a little while, I'm using another hard drive as the guinea-pig to experiment with doing an in-situe upgrade.

    EDIT:
    Nope, it refuses to work on the HTPC platform, God only knows why ???
    Even stranger is that it works perfectly fine on the Dell, but not on the custom HTPC.
    One would think that it shouldn't make a difference.
     
    Last edited: Jun 1, 2019
  9. Jeff R 1

    Jeff R 1 Well-Known Member

    It looks like I solved the problem, although I'm not exactly sure what I did.
    It appears that one has to update ALL the security features in the bloat-ware that Windows 10 install, eg. Candy Crush, X-Box crap and all the other useless stuff.
    After that I went on-line and physically updated Windows Movie and TV app, and then it magically started working.

    The updates are not really done through the normal "Check For Windows" up-date button, but with in the app store itself.
    Once that starts, they appear in Windows up date as security updates, it doesn't tell you specifically what the security updates are, but I'm assuming it was for all those useless apps, since it did take for ever and 1/2 dozen re-boots.

    What a Fuc*ing annoying OS; worse OS ever having to deal with all the bloatware.

    And one doesn't dare to hack the registry to get rid of it _ it might break something ! :rolleyes::mad:

    It's no wonder Microsoft is almost giving it away for free, it's just one big advertisement, it's being payed for by all the bloat ware providers.
     
    whatever_gong82 likes this.
  10. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    You do know you can uninstall that crap like candy crush right? The 1903 build allows you do uninstall even more now.
     
    RedFox 1 likes this.
  11. Jeff R 1

    Jeff R 1 Well-Known Member

    Are you kidding, off course I know, I just find it very annoying having to deal with it all. :p

    On a positive note, I finally got the mouse to pad to work, after running Windows update and rebooting several times it's working now.
    But I'm not sure if that fixed it, before I started un-installing all the bloat-ware, I ran the updater with in the Windows Store _ took a quite a while and ran it several times, I even re-installed the Movie and TV app which the mouse pad wasn't work in, I also ran Windows up date again just to be sure and now it's working with the latest SetPoint driver.

    I also have a very old Logitech Blue-Tooth media pad that works too and it shows up in the SetPoint software.
    It's quite possible too that the use of the media pad implemented the full functionality of the mouse pad with in the software _ who knows, it's working the way I want it too, so I'll leave the media pad connected.
     
  12. Carl D

    Carl D Member

    Been running Windows 10 1903 for nearly a week now - very pleased with it so far (did a clean install).

    To avoid getting Candy Crush, March of Empires, Bubble Witch, etc. and most of the other rubbish make sure your PC is not connected to the Internet during the Windows 10 install - regardless of how much it insists on having an Internet connection. I just unplug the ethernet cable or switch the modem/router off.

    Then, after Windows 10 is installed, turn off and remove the live tiles from the Start Menu - especially the 'blank' ones with the little arrows that say "A great app is on the way" (yeah, right) when you hover the mouse pointer over them.

    Then adjust all of your privacy settings, etc. before allowing Windows to connect to the Internet. This has always been a good idea for any version of Windows, not just W10, I've been doing it for years.

    If I ever decided to just do an upgrade instead of a clean install (not likely) I would download the new W10 ISO and upgrade with the PC disconnected from the Internet.

    All the other junk like XBox, etc. I remove with the Tools option in CCleaner. Later I found out that this actually just 'hides' the apps, doesn't remove them except from the Start Menu. I found a little app called AppBuster from O&O - the same people who make ShutUp10. This can be used to either hide (like CCleaner) or completely remove 99% of unwanted apps.

    The only unwanted item I can't remove from the Start Menu is 'Connect' (even though the app has been removed). I just ignore it.

    Result is a nice 'clean' install of Windows 10. Just the way I like it.
     
    Last edited: Jun 3, 2019
    RedFox 1 likes this.
  13. RedFox 1

    RedFox 1 Super Moderator

    I do the exact same thing, its easy for me to do a clean install because I only use a few programs and I can reinstall those without issue. You are spot on installing W10 without your internet turned on.
     
  14. Harley51

    Harley51 Well-Known Member

    I don't understand why you would install without internet connection. Can you briefly explain. I have two identical Computers. One went well with the update. The other did not and I'm going to do a clean install.
     
  15. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    There's 2 main reasons

    1. It won't download and install crap like 'candy crush' during installation
    2. It won't 'force' you to make your windows username a 'microsoft account' but instead by default go for 'local' or 'offline' account.

    Verstuurd vanaf mijn Nexus 7 met Tapatalk
     
  16. coopervid

    coopervid Well-Known Member

    Clean install is a no go for me.
    I had issues with Classic Shell. Doing a install over the old fixed it.
    Firefox seems to be more unstable with 1903. Otherwise I have no issues yet.
     
  17. Marty S. McFly

    Marty S. McFly Well-Known Member

    Firefox works great for me on 1903. :)
     
  18. coopervid

    coopervid Well-Known Member

    I also don't understand. On 3 computers same weakness. And on all it doesn't work to right click the AnyDVD icon and open RedFox. Try it...
     
    Marty S. McFly likes this.
  19. Marty S. McFly

    Marty S. McFly Well-Known Member

    Worked for me. IDK why it didn't for you.
     
  20. blank

    blank Well-Known Member

    Firefox works stellar here Devedition 68.