Warning PDVD Switcher - Trojan & Stutters!!!

Discussion in 'AnyDVD HD (Blu-ray issues)' started by wdgoldstein, Feb 10, 2008.

  1. wdgoldstein

    wdgoldstein Beta Tester

    Friends,

    This week I downloaded the version switcher for PowerDVD from the link found here. My AVG reported that there was a Trojan in the exe. I verified this with a McAfee on a second system so did not install it. Instead I downloaded the CMD version of the utility which checked out just fine. HOWEVER after installation according to directions I find that within a few days (first time I tried to watch HD content) that all RIPs either HD or Blu-Ray cause unwatchable stutters. This is not only on New rips but those I have successfully watched before with PDVD 3319a. It should be noted that Standard DVD's play just fine.

    I restored the main system using Ghost to a few days prior to installing the switcher and these same rips work just fine now. YMMV but this dude is going to stick with 3319a and avoid the switcher. I'm afriad I'll just have to wait for the guys at Slysoft to kill Blu-Ray protection and find a work around for playback from HDD.

    If you plan to use the switcher I strongly urge you to do a full system backup prior to its installation so if you have the same problem you can restore your system. It's a lot easier then blowing off your hard drive and reinstalling everything.
     
    Last edited: Feb 10, 2008
  2. andy o

    andy o Well-Known Member

    Are you using Comodo Firewall, for some reason? I did notice that after a while, after switching, my CPU would spike to 50% (cmdagent.exe process), and stay there. I found out the reason was that my Defense+ settings were on "Clean PC mode" and I had all these Cyberlink pending files (since they're not registered with Comodo, they stay "pending"). There were so many, that every time I switched, Comodo was reading or verifying, I don't know, but it made some movies stutter. I am guessing with a single core, if you have one, it would be worse.

    I just deleted all pending files from my list, and also I now run Comodo in "Train with safe" mode.
     
  3. wdgoldstein

    wdgoldstein Beta Tester

    No Comodo

    I use Windows firewall as well as a hardware one.
     
  4. flicker

    flicker Active Member

    Anyone else have this problem?

    Re: download link, do you mean the one via the Greek site?
     
  5. bk1987

    bk1987 Well-Known Member

    avg showed a trojan for me also for one of the versions you stated ( not sure which one)but the other one is clean but no shuttering here in fact the switcher works great. i did not think much of avg labeling it a trogan because i have had false alarms before with other legit programs, i hope this will turn out ok
     
  6. andy o

    andy o Well-Known Member

    Have you checked while the movie is stuttering, if any process is using an inordinate amount of CPU power (via Task Manager, for instance)? That's how I figured out it was Comodo.
     
  7. wdgoldstein

    wdgoldstein Beta Tester

    All OK

    Everything looked OK as to CPU usage. I suspected that there might have been conflicting DLL's but don't know. The films I tried were inwatchable which is why I did a restore rather than an uninstall and reinstall. Was afraid a latter dated DLL would survive the process.
     
  8. deaacs

    deaacs Well-Known Member

    This doesn't mean that the file was safe. Personally, I wouldn't have downloaded the 2nd file after the first was found to be infected, and this would be my suggestion to other forum members.
    This is one reason I'm creating my own website entitled deaacs which, in part, will cover the circumvention of all kinds of copy protections that go way beyond the scope of DVD and HD-DVD/Bluray (I'm talking about music drm, software-activation, etc). So that I can place however many links I want to clean sites and clean downloads - and/or host the file myself (which will ensure it is clean and safe).

    I think it is great you've brought this to everyone's attention, because these files that are from unverified sources can be harmful.
     
  9. RickS

    RickS New Member

    Attached Files:

  10. wdgoldstein

    wdgoldstein Beta Tester

    Verified, Sob...

    I'm sorry to see my fears verified. The switcher was a good util, at least in concept. Maybe someone can find a version that isnt infected and doesn't cause plyback problems. OR write one themselves. I do have some BD+ 1.1 discs so I really need a way to watch them on my system.
     
  11. Webslinger

    Webslinger Retired Moderator

    Last edited: Feb 12, 2008
  12. markcu

    markcu Well-Known Member

    Didn't James write a script to do this, or is that what we're talking about?

    If so I find it incredibly hard to believe that he or slysoft would deploy something with a trojan in.............
     
  13. andy o

    andy o Well-Known Member

    The .cmd scripts are just a few lines of text. I edited them myself. There is nothing going on there. The .exe, I don't know.
     
  14. Webslinger

    Webslinger Retired Moderator

    No. James didn't write this. Another user here did.
     
  15. wdgoldstein

    wdgoldstein Beta Tester

    Switcher

    I did not suggest that the CMD file had a virus. Rather that AVG & McAfee reported a trogan in the EXE. I believe the stutter problem is from mismatched DLL files rather than a trojan.

    My goal here was to report the problem see if others had experienced it, and, if so, give them an idea of the fix I had found.
     
  16. andy o

    andy o Well-Known Member

    Sorry, I was replying to the other user above, letting him know that it's not the same script that James put out.
     
  17. flicker

    flicker Active Member

    Is this the switcher linked to via the Greek site (that this forum linked to) ?
    That download is an AVClub switcher with 2 versions of PDVD in two specific folders, not a PDVDswitcher.exe program.
     
  18. sixtysixzero

    sixtysixzero New Member

    I did get a Trojan warning from AVG, but Nod32 reported nothing unusual over the same file. Tried to install the .exe in VISTA, but VISTA would not allow it - got an access denied message, either trying to copy the file to another folder or trying to execute it.

    Anyone knows how to circumvent this problem, is this permission related?
     
  19. RedFox 1

    RedFox 1 Super Moderator

    Try disabling the "UAC" in Vista. It might work.;)
     
  20. sixtysixzero

    sixtysixzero New Member

    Hmmm,
    No luck. Disabled UAC but still could not copy.
    The folder is tagged 'Read Only' and it seems I can't change the attribute...
    ...well it might not be that good an idea to install a potentially harmful program anyway.

    I find VISTA makes you feel like you're wearing a strait jacket.

    Thanks for the advice though...