Pioneer BDR-2208 (208M) software inconsistency

Discussion in 'CD/DVD/BD Drives' started by Loogs, Apr 25, 2013.

  1. DrinkLyeAndDie

    DrinkLyeAndDie Retired Moderator

    I'm a fan of Pioneer Blu-ray drives. They are nice and solid, IMHO. The eject button can feel a bit cheap, however.

    Not that I've ever noticed, no. I'll have to start paying more attention.

    I honestly have no explanation. I've seen talk about the 2x RipLock discussion with respect to AACS discs but I haven't experienced it. I also generally copy discs to my HDD using the AnyDVD Ripper rather than messing around with other programs. That isn't to say that I never use ImgBurn or another program but the vast majority of the time I just use the AnyDVD Ripper while keeping the protections intact to get the job done. I really haven't seen much of if any speed difference between leaving the protections intact or removing them, either.
     
    eviltester likes this.
  2. Jules

    Jules Member

  3. DrinkLyeAndDie

    DrinkLyeAndDie Retired Moderator

    Until very recently I didn't even have the Pioneer BDR-2209 Drive Utility installed so the drive was running at the default firmware settings. The default setting is for Advanced Quiet Drive Feature to be enabled in Quiet Mode versus Persistent Quiet Mode or Performance. Since installing the drive utility I now have the Advanced Quiet Drive Feature completely disabled, Peak Power Reducer disabled, and PureRead disabled. I honestly cannot say I've noticed a difference in speeds.
     
    Last edited: Apr 14, 2015
  4. Jules

    Jules Member

    Now it's even more mysterious to me. :confused:


    I guess you're running the drive with AHCI?
     
  5. DrinkLyeAndDie

    DrinkLyeAndDie Retired Moderator

    My system is a bit antiquated and in need of an upgrade but it's way down my todo list because money keeps getting diverted to more important things. I'm running an Intel Core2Quad Q9550 on an ASUS Rampage Formula motherboard. I built the system years ago now. When I configured it I had to play with the SATA settings in the BIOS. I set SATA Configution to Enhanced and Configure SATA to IDE for things to not give me a headache. I honestly can't remember why and didn't recall doing it. I would have switched to AHCI when I performed my clean install of Windows 8.1 but I forgot I ever made the changes. On a sidenote, one of the BDR-2209s is directly connected to the motherboard SATA ports. The other BDR-2209 and my BDR-2205 are connected via an add-in cards. I don't recall which board is being used, however. I have both a JMicron JMB36x based SATA controller card and a Silicon Image Sil3114 based SATA controller card installed.
     
    Last edited: Apr 14, 2015
    eviltester likes this.
  6. Jules

    Jules Member

    That's very interesting since someone else who used to have problems with the drive told me he had been using AHCI.

    If you ever get a SSD or any other reason occurs to switch to AHCI, it would be great if you let me know if it causes problems.


    Anyway, thanks a lot for all your efforts. :clap:
     
    eviltester likes this.
  7. DrinkLyeAndDie

    DrinkLyeAndDie Retired Moderator

    Interesting. I'll keep that in mind.

    Hopefully I'll upgrade sooner rather than later and already plan on going with a SSD for my boot drive. I'll let you know what happens.

    No problem. You are welcome.
     
    eviltester likes this.
  8. DrinkLyeAndDie

    DrinkLyeAndDie Retired Moderator

    Resurrecting this thread for an update.

    1. Due to somehow breaking Windows Update while installing an update via Windows Update under Windows 8.1 Pro x64 during a Patch Tuesday during late November or early December I finally decided it was time to do a clean install after countless attempts to completely resolve the issue. I figure Windows Update was 99% fixed but was still borked.
    2. I moved to Windows 10 Pro Threshold 2 x64.
    3. I grabbed a Samsung 850 EVO 1 TB SSD to do the clean install on. Would have preferred a 2 TB drive but the cost of SSDs in general let alone a 850 EVO made it simply too expensive.
    4. I switched the BIOS setting from configuring SATA from IDE to AHCI.
    5. All my other hardware is identical excluding the new SSD including the JMicron JMB36x based SATA controller card and a Silicon Image Sil3114 based SATA controller card. The older drivers still work under Windows 10 x64. Shocking!
    6. There is absolutely zero speed difference between my two Pioneer BDR-2209s after moving to using AHCI and I never encountered any slow speed issues. As before, one of the drives is connected to one of the add-in controller cards and the other is connected right to the mobo SATA ports.
     
    eviltester and Jules like this.
  9. Krawk

    Krawk Active Member

    Am replying to a relatively aged thread because it is relevant.
    According to Newegg.com, the Pioneer 2208 retail kit "Includes Pioneer BDR-208UBK Blu-Ray Writer" - Newegg link here --> http://www.newegg.com/Product/Product.aspx?Item=N82E16827129072
    With that being said, the link to Pioneer Japan's website shows a firmware version 1.50 for the drive numbered 208UBK. This is of course a use at your own risk. One would hope the firmware writer is smart enough to decipher and say whether or not there are any compatible drives with said firmware. I am going to download it and see. If it works, fantastic! If it blows up the drive, oh shit, but I have been waiting for a UHD BD compatible drive. Will see what happens.
    http://pioneer.jp/device_e/product-e/ibs/device_e/dev00001r_e.html

    [Edit] - And now the drive is reporting back that it has firmware 1.50. Flash was successful.
     
    Last edited: Jan 13, 2017
    eviltester likes this.
  10. MetalDave

    MetalDave Member


    Krawk: It sounds like you tried exactly what I've been mulling over today. Did you notice any performance improvements when you went to the v1.50 firmware, or was it just a wasted risk?

    When using MakeMKV, I'm not getting anything faster than 2X speeds on the rip. I'm suspecting this is a riplock issue, but I'd love to get some help in confirmation. Sadly, I bought this thing a couple of years back because it was rated better (quality, capability, and speed) than the LG equivalent at the time. Of course, no one ever expects it to be better at keeping the speed throttled for the rip inconvenience.

    Maybe I'll have to pick up an LG and replace this guy, but I wanted to see if anyone had any satisfaction with the BDR-2208.
     
    eviltester likes this.
  11. eviltester

    eviltester Member

    As Ch3vr0n and others will point out.....LG and Lite-on have never given them grief and are superb drives (I also concur with those statements :) )

    We also use Pioneer drives and also have no grief with them. The BDR-2208 and 2209 specifically.

    The following link will give you a more thorough and detailed reason why you should always choose AHCI mode over legacy IDE mode. If your motherboard and BIOS support it, it is the only way to go, especially with SSD.
    http://forums.crucial.com/t5/Crucia...D-Drive-Guide-Here-Crucial-AHCI-vs/td-p/57078

    Interesting side-note regarding the BDR 2208 series.(ties in to my future article I mention here https://forum.redfox.bz/threads/kaby-lake-required-for-powerdvd17.72521/#post-464818)

    Out of 10 or so BDR 2208's we have, 6 of them read and write BD-R QL (128 GB) and BD-RE TL (100GB) with no issues and play non-commercial UHD disks with no issues.
    Of the 50 or so BDR 2209's our OEM supplier provided us as replacements for the 2208's, only 2 out of the 50, actually performs consistently, as the 2208's I mention above.

    Seems newer editions were less reliable on 100 and 128 GB media then the older model.
     
    MetalDave likes this.
  12. Krawk

    Krawk Active Member


    I had never experienced any riplock related issues with this drive even pre 1.50 firmware. Just like my ASUS dvd writer I have observed that often times the read speed is directly related to a specific disc. I wonder if the quality of the stamped media is at play when the drive first identifies the disc or if it is a hard code somewhere on the hidden portion of the disc identifier track. Anyway, I get varied read speeds depending on the specific disc, not locked to 1.5x. I had heard of people ejecting the disc while it was ripping and then putting it back in and the program recovering and going faster. I have not had this issue but to be honest I have not ripped my BDs prior to 1.50. If a 133 minute movies takes 20 minutes or so to rip, that certainly sounds faster than 2.0x, no?
    As with any firmware, each version keeps claiming it supports more media or has compatibility fixes. I tried the firmware because I had a specific disc I could not rip with makemkv or anydvd. Replacing the disc with a totally different upc/version and the same disc still had a problem. It was one of the discs in the first season to the tv show CSI: Crime Scene Investigation. I kept getting read errors or hash table errors. I did eventually copy the files to hard drive and rip with DvdFab of all things. Sorry, I don't have Clone BD and MakeMkv was having a fit because I removed the AACS when I copied the files.

    Anyway, this new firmware did zero harm to the drive that I can tell. It is safe to install so have it at, you pretty much got nothing to lose.
     
    eviltester likes this.
  13. MetalDave

    MetalDave Member

    eviltester: Thank you very much for the feedback.

    I ordered an LG WH16NS40 from Amazon.com for $51 (should have it tomorrow). I figured it was a negligible cost if it saves me a ton of time ripping commercial discs.

    The reliability of the Pioneer drives (especially on write) was the primary reason I went with the BDR-2208 over the LG drives available at the time. I've read a lot of reviews that offer the same reports of reliability, and I appreciate your feedback and experience that corroborates as well.

    Here's my interesting spin: I'm using my BDR-2208 in an external enclosure (VANTEC ST-530S3-BK 5.25" SATA USB 3.0). This enclosure uses a Prolific PL2773 chipset for the controller. I can confirm I'm connected via USB 3.0 Bus. Either way, I'm sure I'm not running a Legacy Parallel ATA mode on the drive.

    Can't wait to see that write-up.

    A sincere thanks again for the input and any further feedback.

    - Dave
     
    eviltester likes this.
  14. MetalDave

    MetalDave Member

    Krawk: Thank you very much for circling back on this thread. The input is appreciated!

    That is VERY interesting. I know that I've seen the MakeMKV app re-try (for whatever reason), and immediately ramp-up to a 2.0X maximum. I've, obviously, tried several commercial discs, and this is a consistent behavior. Full-length films take about an hour to rip.

    I'm, of course, in favor of reliability and quality versus speed. It's, really, no big deal to let the thing run for an hour while I'm off doing other things, but getting more discs done in less time would be ideal (I've got a large personal collection I'm converting).

    The Firmware Revision on my Pioneer BDR-2208 is v1.10. I'm not sure doing the upgrade to v1.50 (albeit intended for a different model drive) would do much to bypass the apparent limiting of the BD-R read speed. I'd hoped you'd have some feedback on ripping from pre and post upgrade.

    Please correct me if I'm wrong, but firmware upgrades for these optical writers are, primarily, to address media compatibility for the write process. For example, I've read they didn't update the firmware for this specific BDR-2208 model because the BDXL compatibility didn't go beyond Pioneer's own in-house brand of disc media. This could be speculative, but I believe I read about someone's experience upon querying Pioneer on compatibility when the cost of that media came down.

    I, actually, had a copy of DVDFab downloaded to give it a try. I'm running a straight rip right now (no conversion, straight source). Noteably, I'm ripping Batman v. Superman Ultimate Edition, and it's telling me an estimated rip time of 30 minutes. We'll see if that proves out to be true, but that would, seemingly, be faster than 2.0X.

    Maybe MakeMKV is more to blame for this issue. It could also be the AACS library I'm using. I've switched between the built-in MakeMKV one and a downloaded compile from another site (which addressed an apparent compatibility issue with newer commercial discs). I'm guessing the Ripper in DVDFab is also using their own incorporation of the AACS library as well.
     
    eviltester likes this.
  15. Krawk

    Krawk Active Member

    I just ripped a movie last night with MakeMKV on the Pioneer and it was reporting a speed of 8.5 X once it hit its peak. It started at 4X and climbed rather quickly to 8X. It took around 15 minutes so that sounds about right.
    The comment about media compatibility is generally almost always about writing but as we all know Lionsgate and Fox are well known for trying to break the standard with regards to movies so there has had to have been at least one update in there for that as well. You never see the complete list of fixes in a firmware. I can personally speak about fixes as I have dealt directly with manufacturers on issues and when the official firmware hits there is no mention of the issue being fixed, although it was.

    I have never had any luck with an LG Optical drive, ever. Even in the home theater I tried 2 BD players of one model and a 3rd of another model. I watch 1 - 2 movies a week and the Home Theater power stays OFF when not in use. Each time the players started failing around the 90 day mark. Failure to read discs, skipping, picture freezing, bitstream audio bombs. I had an LG internal PC drive that failed to work the second time I tried using it. First time I ripped 3 discs. Then about a week later I tried ripping another and it just kept spinning for very long time and then decided there was "no disc" in the drive.
     
    eviltester likes this.
  16. MetalDave

    MetalDave Member

    As an FYI, I attached a photo of the MakeMKV ripping. It's, definitely, running at 2.0X speed with the ripping time. I wonder if that's just a MakeMKV issue with my configuration.

    Effectively, it shows a hard read rate of 8.5 M/s [2.0X] and an elapsed time of 1:24:55 with 0:06:07 remaining. Obviously it's far slower than the DVDFab 10 trial software I used with the same configuration.
     

    Attached Files:

    eviltester likes this.
  17. MetalDave

    MetalDave Member

    Yeah, there's something weird about MakeMKV and my configuration. I'm not sure if there's any IO options that would make a difference in the settings, but it sure behaves differently than DVDFab 10 did.
    I've seen this many times in my career as well. No one wants to admit they made a mistake. Lol.
    Well, my LG WH16NS40 arrives tomorrow. I'll swap it in place of the Pioneer BDR-2208 and try both MakeMKV and DVDFab to see what they do.

    Either way, I'll let you know the difference. Then, I'll probably try the firmware upgrade on the Pioneer to see how that goes. Right now, there's a lot of variables on this configuration/software/etc., so it will be great to narrow it down a bit.

    Thanks again for the input, Krawk!
     
    eviltester likes this.
  18. Krawk

    Krawk Active Member

    I also ran the Pioneer utility to set the drive to performance mode rather than balanced or quiet. Is available on the same Japanese site. Maybe that alone sped the drive up and the firmware update simply improved compatibilities.
     
  19. MetalDave

    MetalDave Member

    Hello, there.

    So, I've been using the LG WH16NS40 for a couple of weeks now, and I am getting improved performance during the rip. Interestingly enough, I did test with the Pioneer BDR-2208 with a different title (Draft Day), and it was ripping at (what seemed like) maximum speed. It peaked out at about 7.5X (32.4 Mbps).

    As reported above, my primary test titles (Batman V Superman - both Ultimate Edition and Theatrical Edition) was hard stopping at ~2.0X on a consistent basis. When I tried the same titles in the LG WH16NS40, I was getting 7.6X (32.6 Mbps) at the peak.

    It seems like MakeMKV tends to throttle higher as the process moves along (starting at a lower speed and moving up). This may have to do with the read locations on the disc (moving the laser from outside to inside or vice versa), but, either way, the behavior of the testing on the Pioneer seems to clearly indicate something flagging the hardware/software combo to stop asking for more speed.

    I just swapped the drive into the same Vantec NexStar DX enclosure I was using with the Pioneer (connected via USB 3.0 to my iMac), so everything in the test is consistent.

    I'll, probably, buy another external enclosure and have both running, so I'll update the firmware at some point and update this thread on my results accordingly.

    Thanks for the input, all!

    - Dave