Heat (2017, Region A)

Discussion in 'AnyDVD HD (Blu-ray issues)' started by pat411, Oct 9, 2017.

  1. pat411

    pat411 Member

    Heat (2017, Region A)
    UPC: 02454327132180
    Source: http://a.co/3EGnMUF

    This is a weird problem, and I have a weird setup that might be to blame. When I insert the disc, the scanning dialog is displayed and the progress bar loops around a few times. When the dialog goes away, it is as if the drive has been disconnected. AnyDVD no longer sees it, and it no longer shows up in Windows Explorer.

    I am running AnyDVD inside a Windows 7 VM using VirtualBox, hosted on a MacBook Pro. I have a drive attached via USB, and I use the "passthrough" option in VirtualBox so that AnyDVD can see the drive. I have only copied a handful of discs this way, but they have all worked great apart from this one. When the drive disappears in Windows, it disappears in macOS too. Disconnecting and reconnecting the drive causes it to show up again in macOS, but the VM must be rebooted for the drive to show up there again.

    I have attached a log created after the scanning was finished, but it doesn't seem like it will be very helpful.
     

    Attached Files:

  2. theosch

    theosch Well-Known Member

    You must know using AnyDVD and other software like burning software with virtual machines can be tricky sometimes in many cases.

    You say "Heat" is Region A, so it's a Blu-ray.
    I've found a logfile of the Blu-ray "Heat" from another member, but it's from a virtual drive software for Windows / ( or perhaps even too from a virtual drive provided by within from the VM itself, or from virtual drive software installed on Windows within a VM). Oh dear that's complicated :)
    https://forum.redfox.bz/threads/heat-20th-anniversary-commemorative-edition-can-not-be-rip.72218/

    Seen from the logfile from the (mounted image?) it pretends "Disc asks for bus encryption"

    What Blu-ray drive model do you have?
    Maybe your optical drive supports bus encryption, but this does not work correctly via the passthrough.
    Maybe this is causing the problem (by coincidence)

    Maybe the other titles don't use bus encryption, where your drive via passthrough didn't disappear.
    Nethertheless Is there still some title , where it didn't vanish, still with bus encryption?

    So this is speculation, maybe you can test that.
    Bus encryption support of an optical drive actually is not needed at all anyway and rather handy.

    AnyDVD should most certainly be working fine with this disc when you use it directly in Windows without a VM.
    Try to make a logfile directly in WIndows. The other user, who had problems with this title a few months ago, didn't post a logfile from the original BD-ROM, too.
     
    Last edited: Oct 11, 2017
  3. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    Sounds like a windows / VM issue at first, if can't appear stable to the mac and then VM you need to sort that out first. You can't blame anydvd for your VM not having/getting a stable connection to the external drive. This is not an anydvd issue.

    bus encryption has nothing to do with this problem and works just fine over USB (bus encryption secures the data between the optical drive and the OS, via some encryption). Whether the drive is connected internally via sata, externally via USB/eSATA, thunderbolt, ...whatever... is irrelevant.
     
  4. Pete

    Pete Forum Admin Staff Member

    That is a strange behaviour, yes. Maybe the vanishing disc is somehow an aftereffect from the fact, that you're running it through VirtualBox.

    I have to disagree with Ch3vr0n - it may well be bus encryption.
    If the VirtualBox passthrough filters out "unknown" extended commands, like anything related to AACS, it will not work for the same reason AnyDVD sometimes can't decrypt so-far unknown discs in this scenario.
    To handle bus-encryption, AnyDVD has to authenticate with the drive in both situations.

    I don't know VirtualBox too well, "passthrough" sounds to me like all scsi commands are, well, passed through blindly.
    But we know, that occasionally this doesn't work.
    VMWare handles BDs fine, though.
     
  5. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    See, that's why ur the expert! My bad.

    Sent from my Nexus 6P with Tapatalk
     
  6. pat411

    pat411 Member

    Far more replies than I was expecting. :) I definitely understand this setup is not normal and is likely to have issues. I am thankful it has worked as well as it has so far!

    The BD drive in question is an ASUS BW-12B1ST purchased in early 2013. I also have a Samsung SH-B123L from 2011 I can test with.

    I will do some more testing this weekend and update the thread.
     
  7. pat411

    pat411 Member

    The Samsung drive didn't work with my external adapter, so nothing to report with that. I moved the VirtualBox VM to a different Mac and tried again. This time, AnyDVD kept trying to scan, but eventually it crashed. It produced a dump, but I doubt it's interesting; I do still have it if I'm wrong.

    I then went to a Windows 10 PC and it seems to work fine, as expected. I've attached the log from that system. It is currently creating an ISO of the disc without issue. It did spam the "AnyDVD is scanning" notification a few times, but I've not used AnyDVD on Windows 10 before, so I don't know if that's abnormal.
     

    Attached Files:

  8. pat411

    pat411 Member

    Testing a few more discs today. Arrival and Hidden Figures both demonstrated the original behavior (drive disappears in VM and host after scanning, no error message). For a disc that works, there is no mention of the disc requesting bus encryption:

    Summary for drive D: (AnyDVD HD 8.1.9.1, BDPHash.bin 17-07-03)
    VBOX CD-ROM 1.0 2011/04/20 21:37
    Drive (Hardware) Region: 0 (not set!)
    Current profile: BD-ROM
    Media is a Blu-ray disc.

    Total size: 20968512 sectors (40954 MBytes)
    Video Blu-ray label: ASH_VS_EVIL_DEAD_S2_D1_BD
    Media is AACS protected!
    Drive supports bus encryption!
    AACS MKB version 61
    Removed AACS copy protection!
    Bad sector protection not found.​

    Ultimately, I think it's a VirtualBox limitation with respect to the bus encryption commands. Looking at the VM log, there are errors that look suspiciously related:

    00:00:05.789289 PIIX3 ATA: LUN#1: CD-ROM passthrough cmd=0x5a sense=5 ASC=0x24 ASCQ=0x0 VERR_DEV_IO_ERROR
    00:00:06.971973 AHCI: Error (VERR_NOT_IMPLEMENTED) while updating the tracklist during READ TOC/PMA/ATIP, burning the disc might fail
    00:00:06.990289 AHCI: Error (VERR_NOT_IMPLEMENTED) while updating the tracklist during READ TOC/PMA/ATIP, burning the disc might fail

    In the meantime, I decided to try out VMware Fusion. I exported my VirtualBox VM, imported it to Fusion, and aside from the host machine crashing when I first tried installing VMware Tools, everything just works, as Pete suggested.

    Summary for drive D: (AnyDVD HD 8.1.9.1, BDPHash.bin 17-07-03)
    NECVMWAR VMWARE SATA CD01 1.00
    Drive (Hardware) Region: 0 (not set!)
    Current profile: BD-ROM
    Media is a Blu-ray disc.

    Total size: 23146752 sectors (45208 MBytes)
    Video Blu-ray label: Arrival
    Media is AACS protected!
    Drive supports bus encryption!
    Disc wants bus encryption!
    AACS MKB version 62
    Removed AACS copy protection!
    Determined region(s): A
    Blu-ray Java signatures fixed!
    BD-Live deactivated!
    Removed UOPs!
    Bad sector protection not found.​
     
  9. Pete

    Pete Forum Admin Staff Member

    Good choice (y)
    VirtualBox is a neat and lean virtualizer, but VMWare is more advanced and professionally maintained, because it's a commercial product, they have to please their customers - the free editions benefit from that as well.