AMD Radeon VII

Discussion in 'CloneBD' started by dr dark, Mar 6, 2019.

  1. dr dark

    dr dark Member

    Hi,

    Any chance of supporting the AMD Radeon VII / AMD VCE for HEVC / H.265. Hard ware encoding works great with h.264, very fast compared to software / cpu w/ clonebd.

    Unfortunately CloneBD currently only does not support hardware encoding via VCE for HEVC/H.265 w/ the Amd Radeon VII -- Only cpu/software which is very slow. I have used handbrake and other encoders with excellent and fast results. It would be excellent if we can get this support in CloneBD. I wouldn't mind beta testing this.

    Attached Speccy and Drone Output.

    Thanks

    - DRD
     
    Last edited: Mar 6, 2019
  2. Fabian

    Fabian Developer

    Yes, it will be added very soon. For Radeon VII, Vega 56/64 and the RX 590/580 series.
     
    whatever_gong82 likes this.
  3. dr dark

    dr dark Member

    Wonderful! -- Do you have any sort of ETA? Just wondering.. :)
     
  4. Fabian

    Fabian Developer

    It is hard to say because of testing, but expect in in about 1-2 weeks if everything works out as expected.
     
    whatever_gong82 likes this.
  5. dr dark

    dr dark Member

    Hi Fabian,

    Any progress or update for Radeon VII, Vega 56/64 and the RX 590/580 series support?

    Thanks

    DRD
     
  6. Fabian

    Fabian Developer

    Yes, we made good progress. Unfortunately, it won't make it for the next release, but expect it right after that.
     
    neomaine and whatever_gong82 like this.
  7. 3D-VR-Fan

    3D-VR-Fan Member

    When will Hardware decoding be completed for RX 590/580? It would be very helpful...
    Thank You in advance
     
  8. Fabian

    Fabian Developer

    Sorry for the delay. We are adding support for the latest Navi (RDNA) at the moment. As soon as this is finished, all AMD cards will be fully supported (that support HW decoding of course).
     
  9. 3D-VR-Fan

    3D-VR-Fan Member

    Thank You for update, hope it will come soon this year.
     
  10. dr dark

    dr dark Member

    I have just tested and clonebd still does not detect HEVC hardware encoding with AMD Radeon VII / AMD VCE.

    I tested it with AMD's latest drivers.

    Is there any ETA for this? I've been on standby since March, and hope clone bd will support my hard ware soon (AMD Radeon VII / AMD VCE for HEVC / H.265).

    Thank You..
     
  11. 3D-VR-Fan

    3D-VR-Fan Member

    I tested on Win7 with latest AMD drivers for Radeon R580 and lates CloneBD, hardware decoding still not activated
    HVEC software only
    I tested on Win10, hardware decoding UVD AMD APP activated there, also better CPU usage.
     
  12. dr dark

    dr dark Member

    Software decoding has worked, the encoding is the issue.
     
  13. Pete

    Pete Forum Admin Staff Member

    A CloneBD release is due today - but I think, HEVC encoding will still not be on board, because presently the latest AMD drivers appear to have a bug.
    Elby is currently sorting that out with AMD tech support. Once that is through, HEVC/HEVC10 will be fully implemented.
     
  14. dr dark

    dr dark Member

    Thanks, It must be a bug specific to clonebd, as it encodes HEVC fine with other encoder such as handbrake, ffmpeg, resolve, etc, I hope to see the support soon.
     
  15. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    If it's an AMD system/gfx card it's not a bug, AMD driver support for hw acc was broken the last few versions cause AMD had changed things again in the drivers afaik.

    Sent from my Pixel 3 XL using Tapatalk
     
  16. Ghildebr

    Ghildebr Active Member

    Any word on when hardware encoding will be fixed for the AMD line? I am using an Radeon Pro 560 with the latest drivers, (Radeon Pro Software Version 19.9.2).
    Thanks,
    Gary
     
  17. Fabian

    Fabian Developer

    It will be fixed and working in the next beta (or release).
     
  18. 3D-VR-Fan

    3D-VR-Fan Member

    I have parallel Win7 and Win10. For Win7 with R580 encoding is not available until now.
    For Win10 it works in a way and is activated. With current drivers installed. Situation unchanged since about August, I think.
    The reason for Win10 is steamVR with DX12 and related issues like current driver, encoder VR support.