.properties files missing on Paramount and 20th Century Fox titles

Discussion in 'AnyDVD HD (UHD only)' started by Manni, Apr 8, 2019.

  1. Manni

    Manni Well-Known Member

    Hi there,

    I've experienced a weird bug with AnyDVDHD rips of Paramount and 20th Century Fox titles.

    The menus wouldn't work.

    I reported this in the jRiver forums initially https://yabb.jriver.com/interact/index.php/topic,114628.msg831335.html#msg831335

    But after some debugging, I realized that jRiver had nothing to do with this, it was due to .properties files missing in a few subfolders in the JAR folders. Copying the missing files solved the issue.

    I tried to re-rip one of these titles with the latest AnyDVDHD build and the .properties files seem to be copied as expected.

    So I wanted to know if this bug has been fixed recently, just to understand why this happened in the first place. I had to re-rip all my discs very recently as I moved to BD Folders, so it would have had to be fixed in the last few weeks.

    Thanks!
     
  2. Pete

    Pete Forum Admin Staff Member

    Since there are numerous ways you could use AnyDVD to copy a disc, can you please describe in detail how you do it?
    AnyDVD does not touch any files, that are not part of the protection and will always copy them.
    I'm pretty certain, that this is not AnyDVD's doing.

    No bug of that sort is known nor has it been fixed.
     
  3. Manni

    Manni Well-Known Member

    As I said precisely in the jRiver report, the original discs were ripped to BD Folders with AnyDVDHD.

    It's definitely AnyDVDHD rips as the disc.inf is present.

    I have no idea why these .properties files were not copied at the time (it's unlikely they were deleted selectively afterwards). I checked a few recent rips, and they are present.

    It looks like there might have been a bug that has been corrected in a recent build, or for some reason .properties files have been deleted from my shares, only for paramount titles or 20th century fox titles, and only when they have been ripped by AnyDVDHD. Which sounds the most plausible ? :)

    Maybe James would know if this was an issue at some point or not. Anyway, I can confirm it's not an issue anymore with the latest build.
     
  4. James

    James Redfox Development Team Staff Member

    No, nothing changed. Maybe a bug, that AnyDVD wasn't able to create the destination file, and didn't report an error?
    My general advice: Do NOT rip to folder. Ripping to iso will keep the sector layout, meta data, ...
     
  5. Manni

    Manni Well-Known Member

    Thanks James. I don’t see how only .properties files would have an issue when writing them and not the others, or why anydvdHD would not report such an error. Anyway, if you say this hasn’t been corrected I trust you. I just have no idea what happened or why.

    Can’t save to ISO (except 3D) for various reasons: mymovies launches tv episodes directly from bd folders, saving measurements files for madVR, etc.

    But I never really had any issues with BD Folders. I guess I’ll just check for a while that all the .properties files are saved.

    Very weird!