Pioneer BDC-202 1.01 - Disc Detection Broken

Discussion in 'High Definition Hardware' started by CX23882, Nov 10, 2007.

  1. CX23882

    CX23882 Member

    Brief Summary of Problem
    When AnyDVD is enabled, disc detection fails.

    System Config
    Pioneer BDC-202 BD-ROM combo with 1.01 firmware
    Tried various versions of AnyDVD 6.x.x.x
    Dell Dimension E521 (GeForce 6150LE+430 chipset)
    Windows XP Professional SP2 or Windows Vista Ultimate 32-bit

    Detailed Description
    When I insert a disc (any type of disc) into the Pioneer drive, I see the "AnyDVD is scanning the disc" balloon appear, but then nothing happens. If I look in My Computer, the drive simply says "DVD-RAM Drive" - as if no disc is inserted. If I then simply right-click on the drive, the disc is detected and autorun etc start.

    The same behaviour occurs when the disc is removed. Windows doesn't realise the disc has been removed until I right-click on the drive through My Computer.

    If I disable AnyDVD on the Pioneer drive, disc detection works 100% correctly every time. The Pioneer replaced a Toshiba-Samsung DVD-RW drive, and if I put the TSST back in, disc detection works correctly with Autoplay enabled. I'm currently running with both the TSST drive and the Pioneer, but with AnyDVD disabled on the Pioneer.

    I have searched the forums and can't find any other reports of this behaviour. I would suspect a fault with the drive except that it works every time when AnyDVD is disabled. Dell-induced software glitches can be ruled out by the problem also occuring on a clean Vista 32-bit installation, and I have removed most of the filters that were installed to help provide packet-writing etc.
     

    Attached Files:

    Last edited: Nov 10, 2007
  2. pjouy

    pjouy Well-Known Member

    I have the same problem. Most of the time, I need to open "Computer" on Vista in order to start the autorun... but everything works fine when AnyDVD is disabled...
     
  3. sarah99

    sarah99 Well-Known Member

    reboot the PC with the Blu-Ray disk already in the pioneer drive.
     
  4. captain_video

    captain_video Well-Known Member

    Mine works fine with XP. It must be another one of those bonus features Microsoft included with Vista. Aren't you glad you upgraded? 8)
     
  5. James

    James Redfox Development Team Staff Member

    Unlikely... can you post your firmware version? Maybe your drive is newer / older?

    EDIT:
    Forum member CX23882's status log says:
    PIONEER BD-ROMBDC-202 1.01 07/05/15PIONEER
     
  6. CX23882

    CX23882 Member

    I have the same problem in both XP and Vista, so it's not a Vista-specific problem. It also occurs with any disc type (Data CD, Data DVD, Video-DVD, Blu-ray).

    For the record, I'm using the standard IDE drivers in both XP and Vista (especially under Vista, since the out-of-box nVidia-specific SATA drivers seem to cause BSOD problems under heavy I/O e.g. importing several GB of music into iTunes).
     
    Last edited: Nov 11, 2007
  7. James

    James Redfox Development Team Staff Member

    It would be interesting to see the AnyDVD status info of captain_video's drive...
     
  8. Clams

    Clams Well-Known Member

    He stated in the text as well that it's 1.01 firmware...

    -W
     
  9. James

    James Redfox Development Team Staff Member

    Forum member captain_video? Am I blind?
     
  10. jnegamble

    jnegamble New Member

    same drive no problem

    I am running vista 32 bit with no problem. Updated to newest beta for spiderman 3 and ratatouille. Although no sound when they play back from hard drive!
     
  11. James

    James Redfox Development Team Staff Member

    Could you please post the AnyDVD status window of the drive (with a disc inserted)?
     
  12. captain_video

    captain_video Well-Known Member

    My 202 has firmware version 1.01. In fact, that's the only version currently available for this drive that I was able to find. I looked to see if a newer version had been released but it appears that 1.01 is the latest and greatest.
     
  13. sarah99

    sarah99 Well-Known Member

    My Dell did exactly the same thing, reboot the Dell with the disk in the drive and it will most likely read it (mine did anyway). Put the 202 in another PC and it may work.

    The Pioneer 202 is very picky about which mobos it works in.
    It hates some Dells. (my Dell 520 is fine, my Dell 5150 is the rebooter)
    Asus P5 mobo, same problem, cured with BIOS update
     
    Last edited: Nov 13, 2007
  14. CX23882

    CX23882 Member

    Thanks. I have tried in the only other SATA-equipped PC I have (EPoX EP-9NDA3J motherboard) and the problem persists there too.
     
  15. MickJT

    MickJT Well-Known Member

    Problems happens here too. BDC-S02BK, however it's the same as the BDC-202 (so much so the computer says it's a BDC-202).
     
  16. Wrick

    Wrick Member

    I had a similar problem with that drive with an Asus AM2 motherboard but it worked fine for me connected via USB (via a £5 adaptor). To elaborate, when connected to the SATA connectors on the motherboard I got what appears to be the same problem, i.e. the disc contents could be seen without AnyDVD, but the disc was completely unrecognised when I started AnyDVD up. No good for me for HDCP reasons. I then connected the drive via my nice wee USB2 adaptor and it worked perfectly.

    (It wasn't a big problem to connect it via USB and I just figured it must be some peculiarity with my machine.)

    I've since changed to a Gigabyte board with an incompatible South Bridge controller so I have to connect it via USB now anyway.

    Hope this helps.
     
  17. AstroGhost

    AstroGhost Member

    This drive is imcompatible with the AMD SB600 Southbridge Chipset

    The Pioneer drive isn't currently compatibile with the AMD SB600 Southbridge Chipset manufactured between March 2007 and end of June 2007. If you have an Intel based motherboard you will experience no problems.
     
  18. pjouy

    pjouy Well-Known Member

    In fact, we *do* have problems with Intel ones (P5B series as said before).
     
  19. AstroGhost

    AstroGhost Member

  20. graham_h

    graham_h Member

    Hi Wrick
    I'm having similar issues with my Gigabyte board.
    Exactly what sort of sata>usb adapter did you use.

    Cheers
    Graham