No joy with mpeg2 passthrough

Discussion in 'CloneDVD mobile' started by Rod Martin, Jan 7, 2017.

  1. Rod Martin

    Rod Martin Member

    A pretty self explanatory issue here. All I want to do is to create separate mpeg2 files for my movies. I want best quality possitble, so I don't want the encoder to touch it... just passthrough the vob's into a single output file. Why no workie? Other modes work... mpeg2 passthrough does not. I accept all defaults, give it a destination, and same error every time. Nothing happens... Please advise.

    WARNING: Video aspect ratio is given as 720:480[1.50] but encoded as 1.777778:1[1.78].
    This is Chameleon transcoder engine [2.0.1.5] (09/23/2013)
    LOG: [NEW SEGMENT] VOB:1 CELL:1
    LOG: Video Start PTS = 4095
    LOG: AudioA Start PTS = 4095
    LOG: SendPacket:#194 // V:60, A:31, S:0 // __ensure( WriteFile(PipeWrite, Header, sizeof Header, &Have, NULL) && Have == sizeof Header )
    The pipe is being closed.
    An encoding error has occurred

    Using Win10 Pro. Latest release 1.9.5 (registered)

    Looks like no joy with mpeg2 re-encode too. I get more diagnostic info with it... again, all defaults are accepted:

    This is Chameleon transcoder engine [2.0.1.5] (09/23/2013)
    LOG: [NEW SEGMENT] VOB:1 CELL:1
    LOG: Video Start PTS = 4095
    LOG: AudioA Start PTS = 4095
    FFmpeg version from svn, Copyright (c) 2000-2008 Fabrice Bellard, et al.
    NOTICE: This app contains changes made by SlySoft Inc. in compliance with GPL.
    All changes are available as patches from http://oss.slysoft.com
    This file was digitally signed by SlySoft Inc.
    FFmpeg maintainers receive SlySoft products free of charge. If you're
    interested then please contact us at support@slysoft.com
    Input #0, cham, from 'pipe:':
    Duration: N/A, start: 0.000000, bitrate: 7884 kb/s
    Stream #0.0: Video: mpeg2video, yuv420p, 720x480 [PAR 32:27 DAR 16:9], 7500 kb/s, 59.94 tbr, 90k tbn, 59.94 tbc
    Stream #0.1: Audio: ac3, 48000 Hz, 5.1, s16, 384 kb/s
    [NULL @ 013f7170]Unknown option 'vb'
    [swscaler @ 01210050]Unknown option 'vb'
    [mpeg2video @ 0123e5a0]too many threads
    Output #0, vob, to 'V:\Output\CHUCK_SEASON_4_DISC_1.mpg':
    Stream #0.0: Video: mpeg2video, yuv420p, 720x404 [PAR 254:255 DAR 3048:1717], q=2-31, 3238 kb/s, 90k tbn, 29.97 tbc
    Stream #0.1: Audio: libmp3lame, 48000 Hz, 2 channels, s16, 192 kb/s
    Stream mapping:
    Stream #0.0 -> #0.0
    Stream #0.1 -> #0.1
    Error while opening codec for output stream #0.0 - maybe incorrect parameters such as bit_rate, rate, width or height
    LOG: SendPacket:#194 // V:60, A:31, S:0 // __ensure( WriteFile(PipeWrite, Header, sizeof Header, &Have, NULL) && Have == sizeof Header )

    The pipe is being closed.
    An encoding error has occurred
     
  2. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    There's quite a few bugs with the 190x versions. You could try 1802 which afaik is linked in the stickies up top. Other than that, a new version is on the plans for release by redfox but first the CloneBD encoding engine needs to be fully ready. As thats the encoding engine that will be used in the next major CDVDm version.
     
  3. mmdavis

    mmdavis Well-Known Member

    Nope, can't find any link for 1802 that works. No point in having the sticky with defective links. And has been requested before, guess it hasn't been important enough. https://forum.redfox.bz/threads/red...pp-error-vector-t-too-long.69475/#post-451474
     
    Last edited: Jan 7, 2017
  4. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    as i said, there will be no next version until the conversion engine is ready. As to the sticky, we're in the process of cleaning the mess up on ALL sections. As to 1802 i'll see if i can't get my hands on a link. Tha closes i have is 1806
     
  5. ErichV

    ErichV Well-Known Member

    Have fun!
     

    Attached Files:

  6. Rod Martin

    Rod Martin Member

    Great idea... however, all it seemed to do is create new errors... I also tried compatability mode... still no joy. Same result. Nothing output, just error.

    I uninstalled the old software, installed the new, rebooted, reregistered... then:

    WARNING: Video aspect ratio is given as 720:480[1.50] but encoded as 1.777778:1[1.78].
    DEBUG: Feeding ffmpeg.exe with 'ffmpeg.exe -i - -v 9 -xerror -threads 12 -f vob -metadata title="ANTMAN" -r 30000/1001 -vcodec copy -vb 1000 -acodec libmp3lame -ac 2 -ab 192000 -s 720x480 -aspect 16:9 -deinterlace -vol 810 -y "V:\Output\ANTMAN.mpg"'.
    This is Chameleon transcoder engine [1.8.1.0] (01/03/2012)
    CLOCK RESET: Video, STC = 0, DTS = 15695
    CLOCK RESET: Audio AC3, STC = 0, PTS = 18698
    ----- NEW SEGMENT -----
    Segment Start: 1, Video:18698 Audio:18698 => 0 (0 ms)
    > Synchronized :: 18698 / 18698 => 0 = 0 ms
    Segment 1 > Video 0 > 0 / 18698 -> 21701 / 18698
    Segment 1 > Audio 0 > 0 / 18698 -> 21578 / 18698
    Segment 1 > Video 1 > 3003 / 21701 -> 24704 / 18698
    Segment 1 > Video 2 > 7507 / 26205 -> 29208 / 18697
    Segment 1 > Video 4 > 12012 / 30709 -> 33712 / 18697
    Segment 1 > Video 5 > 15015 / 33712 -> 36715 / 18697
    > Video is looking fine and synchronous, suppressing output
    Segment 1 > Audio 1 > 2880 / 21578 -> 24458 / 18698
    Segment 1 > Audio 2 > 5760 / 24458 -> 27338 / 18698
    Segment 1 > Audio 3 > 8640 / 27338 -> 30218 / 18698
    Segment 1 > Audio 4 > 11520 / 30218 -> 33098 / 18698
    > Audio is looking fine and synchronous, suppressing output
    >>> QueueSend, #506 : ffmpeg terminated

    The pipe is being closed.
    An encoding error has occurred
     
  7. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    Then all that is left to say is to either don't use that specific mode, or use a different encoder for the moment. The next version with the new engine will be a while longer of waiting
     
  8. Rod Martin

    Rod Martin Member

    I even installed a fresh win7 x64 SP1 in vmware. Still no joy with passthrough... mp2 Re-encode works, but that defeats the purpose. I would go right to mp4 if that is what I wanted to do. Funny that an encoder is even necessary given its passthrough.

    Ok, how do I give it a different encoder to use? I didnt see that an external encoder was even an option.

    Should I stop screwing with this? Just regret my purchase, and sink another $50 into MakeMKV? The demo works great, but I was hoping not to have to push more money into silly software pieces that tend to go defunct.

    I do appreciate your quick replies.
     
  9. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    you don't unfortunately. You could try swapping out the ffmpeg executable with your own but no guarantees that will work. The ffmpeg lib is very buggy, which is why it's due for an overhaul with a new engine. The one CloneBD uses. I meant a fully different software program. I can't speak for makeMKV as i don't use it.
     
  10. mmdavis

    mmdavis Well-Known Member

    Try the older version 1201. It's slower, but works all the time.
     

    Attached Files:

  11. Rod Martin

    Rod Martin Member

    Yes! mmdavis, exactly what I needed. I just change the ext from vob, to mpeg, and all is good. Actually, its quite fast... I'm able to strip off a full 2.5hr movie to a single file from my iso images on my qnap storage to my PC in less than 2 minutes. I think I can wait that long!

    Thanks much,
    Rod
     
  12. Daron2000

    Daron2000 New Member

    I downloaded and installed AnyDVD and CDVDM yesterday and encountered the same issue referenced here (not able to just create a passthrough mpeg). I downloaded the 1201 and installed it per above and it seems to be working fine, but it is now asking me to register it. I am not sure how to do that, as the version I downloaded yesterday has a separate registry file that is used with the registration tool. Any suggestions for this noob?
     
  13. blank

    blank Well-Known Member

    You need a slysoft license for old versions of CloneDVDmobile ...

    "CloneDVD mobile Revision History

    Version 1.9.5.0: 2016 04 29
    - Updated languages
    - Updated engine interface
    - Software rebranded (RedFox)
    "

    Maybe ask support for a license file that will work with old versions.
     
  14. FurryGuy

    FurryGuy Well-Known Member

    The CDVDM license didn't change, just the branding.
     
  15. blank

    blank Well-Known Member

    OK I haven't tested with my redfox license, as I also have a slysoft license ...