GameJackal 2.9.18.610 - release

Discussion in 'GameJackal' started by Tom, Nov 23, 2007.

  1. Tom

    Tom Redfox Team Member Staff Member

    http://www.slysoft.com/download.html

    Release v2.9.18.610 - release (2007-11-22)
    • Added profile import / export functionality.
    • Improved driver stability and performance.
    • Fixed a bug with the driver that could cause image mode to work incorrectly.
    • Profiles now automatically lock when first captured.
    • Profiles can now have their protection type changed (via the advanced options).
    • Fixes a bug with the driver that could cause a game to crash when launched.
    • Fixed a bug with the driver that could cause image mode to work incorrectly.
    • Fixed a bug that was causing an exception when clicking on the plugin list.
    • Updated Arabic language support.
    • Updated blacklisting support.
    • Fixed a bug with the launcher (parameters are now passed correctly).
    • Missing profile data is now tracked to allow for a "update profile" to be performed.
    • Update profile feature implemented (assessed by right-clicking on the profile). This will update the profile with any data that has been flagged as missing.
    • Collection files are now deleted when a profile is deleted.
    • Minor interface improvments
     
  2. kathy4u2nv

    kathy4u2nv New Member

    lost profiles after upgrade

    Well, did exactly what the download instructions said to do, all installed fine, no errors until a restart and then was asked if i wanted to repair, selected yes and game jackel just opened and sat there.....all profiles were lost, cant even import.....great! Needless to say, i am quite impressed
     
  3. Bifford

    Bifford Member

    I am quite ecstatic to say that whatever you have changed since the last beta and this full version has totally solved the Neverwinter Nights 2 problems of crashing the computer!!!! :D

    Well done team! :)

    Thanks.

    Sam
     
  4. Bill1426

    Bill1426 Member

    Fixed a bug with the launcher (parameters are now passed correctly).

    Still not working for BattleField 2142..
     
  5. daleparr

    daleparr New Member

    Missing Profiles

    Yes - Me too...... However the "Create Desktop shortcut" still works so i was able to create and play from the shortcut icons.

    and yes - not an impressive upgrade.
     
  6. matthew

    matthew SlySoft Team Member

    Can you post your launcher.log file after starting BF
     
  7. Bill1426

    Bill1426 Member

    I deleted it, thinking that was the issue..
    I re-ran the game from GJ, but it didnt remake the file...
     
  8. matthew

    matthew SlySoft Team Member

    Ah yes... the BF plugin looks after the launching of that game.
    Basically the plugin creates a batch file to launch the game. Check the folder "C:\Program Files\SlySoft\Game Jackal\Plugins\battlefield\" and post the content of bf.bat
     
  9. SHARKMEAT

    SHARKMEAT Active Member

    Works Fine, I unistalled and replaced the profiles started anew with Ver .610
     
    Last edited: Nov 30, 2007
  10. Bill1426

    Bill1426 Member

    rem Battlefield launcher [11/29/2007 2:11:00 PM]
    C:
    cd \Program Files\Electronic Arts\Battlefield 2142\
    start "Battlefield" "C:\Program Files\Electronic Arts\Battlefield 2142\BF2142.exe" "+menu 1 +fullscreen 1 +eaAccountName xxxxxxxx +eaAccountPassword xxxxxxxx +soldierName xxxxxxxxx"
     
  11. cybmole

    cybmole Well-Known Member

    installing over prefious game jackal

    decided (finally) to update my old pre-slysoft version, so I installed this latest full release & activated it with the key OK - but it seems to have left the old version on the system still, in the same folder. For a wile I had bothe versions sitting in the system tray which was very confusing as they both use the same icon!

    Is that what should have happened & should I try to tidy things by somehow removing the old version. I don't want to lose & have to recreate all my old profiles though, as at present they seem to still work.

    But I can't get medievel II total war to ework even though the slysoft version has a profile for that game - the game still asks for the DVD after apparently profiling OK.

    I'm wonderign if I should just un-install versions & clean re-install but I could do with some instructions for how to do that while still preserving older profiles please.
     
  12. mike20021969

    mike20021969 Well-Known Member

    i'm not sure how GJ works as i dont have it.not sure why i'm replying....i must be bored :)
    can you not uninstall the old version first then install the new version?

    some should know about how to keep your profiles.
     
  13. matthew

    matthew SlySoft Team Member

    This looks fine. GJ seems to be passing the parameters as required.
     
  14. matthew

    matthew SlySoft Team Member

    Yes... uninstall the old version first.
     
  15. cybmole

    cybmole Well-Known Member

    lost all profiles

    OK - so I did that- uninstalled & reinstanlled, after first taking a copy of profile library folder , as per your advice in a "how to backup thread"

    I've now lost all my previous profiles !!!

    why has that happened. I have the same key & have replaced the saved profile directory

    Is ther any way to recover those profiles without remaking them all over again please?
     
  16. cybmole

    cybmole Well-Known Member

    any way to recover the situation

    update: not only did I lose all my profiles, but I still cant' make a working profile for Safedisc protected Medieval II total War. As soon as launch from teh GJ profile I get please insert correct DVD eror message. I read in reviews of the slysoft product that it can handle Safedisc so is there a known problem with the particular game ?

    FYI here's my exact install/ nstall sequence & I'm using Xp Home SP2.

    1. started with old maplom GJ installed & working

    2. Ran the latest slysoft installer - that installed into my existing GJ directory - it said it had found & repaired a profile key & my old profiles still worked, but there seemed to be a lot of old stuff in the Gj directory

    3. Made the earlier post about doing a clen install & searched forum for how to back up profiles

    4. Copied my profile key, copied the profile folder, uninstalled GJ via control panel & deleted old GJ directory.

    5. Installed latest slysoft, which now went to a slysoft folder, It again found & repaired a profile Key, & I checked that that key matched my previously saved copy. FWIW, the new slysoft program folder looks jsut as cluttered as the previous one, with several .exes

    6 Registered the slysoft version, then copied my saved profile folder into the correct location & re-launched but no profiles found - also tried import profile but that fails to find any. There are lots of files in the program library folder with various extensions - and also some maplom files.

    7. Tried making a brand new profile of Medieval II but can't get it to work at all. I used the standard procedure - selected the game profile from the drop down list & followed all the regular default steps. GJ made & locked a profile but it does not work! I did this 3 times then gave up!

    8. Have not tried recreating any other old profiles as yet, awaiting feedback /advice on what I did wrong & how to fix it - if possible.

    PS If i uninstalled slysoft & then reinstalled my old maplom version ( which I still have somewhere), and copied the saved profile library into that, would I then get my profiles back ??? and could I then repeat all the above steps in a way that would put the old profiles into a clean install of the slysoft version ???
     
  17. matthew

    matthew SlySoft Team Member

    The fact that no profile were found is very strange. There should be a file called "maplom.lib" in the profile directory. This contain all your profile information. I have sent you a PM with an email address so you can send me this file... I will take a look.

    In the meantime, try creating another profile... we need to determine if GJ is installed correctly.

    Also, post your "profile.log", "launcher.log" and "proc monitor.log" files.
     
  18. cybmole

    cybmole Well-Known Member

    the maplom.lib file does indeed exist, but I still do not see any profiles. I have emailed it to you + all of the log files.
    when I first installed slysoft over the older maplom version I did then test my old profiles & they all worked. I lost them when I did the uninstall-reinstall procedure above.
     
  19. cybmole

    cybmole Well-Known Member

    progress


    Progress - i retried the profile backup stuff, firstly shutting down GJ totally ( maybe I did not do this before) , then copying out the current profile library and copying back in the old profile library, then restarting jackal. This worked! - i got an error message saying the profile library was not saved correctly & offering to repair it, agreed to that & all was OK. reversed the entire process & got back to my 1 new profile. All OK again,

    But now I can't see how to combine the 2 libraries. The Import profile option still finds no files of the correct type whichever way around I try it. and there does not seem to be an export option. So Am I missing a trick or is there no simply way to combine the 2 folders ? The new library contains a workign profile for Mediaeval II, wich has been very troublesome to make, & the old library contains my old working profile for NWN2, which asso has a reputation for being troublesome to profile, so I'd really like to get both of those into the same folder.

    Ps I think my earlier error was not realising that clicking the x in top right does not close down the program, it just send it to the task bar. So I was not comptetely exiting the program before moving profile library files around.
     
  20. matthew

    matthew SlySoft Team Member

    First up... I checked the library file and it loaded fine on my machine. Just make sure you select "no" when asked if you wish to restore the profile file.

    Yes it is very important that you shutdown GJ before updating the library files.

    Also the import feature only imports exported profiles... you need to export the profile first.