GameJackal 2.9.18.574 - beta released

Discussion in 'GameJackal' started by Tom, Aug 31, 2007.

  1. Tom

    Tom Redfox Team Member Staff Member

    GameJackal 2.9.18.574 (beta) is available:
    http://sandbox.slysoft.com/gj/SetupGameJackal.exe


    Release v2.9.18.574 - beta
    - Improved blacklisting support.
    - Improved dynamic extended profiling.
    - Minor interface updates.
    - Added some debugging options for the BF2 / 2142 freezing issues.
     
  2. KoRn

    KoRn Well-Known Member

    no x64 OS support - useless for me:mad:
     
  3. d.chatten

    d.chatten Well-Known Member

    I ceated some profiles from desktop shortcuts with GameJackal 2.9.18.570 and everything was working fine, after i installed version 2.9.18.574 the desktop shortcuts now open GameJackal instead of launching the games, even if i delete and recreate the GameJackel profiles or the desktop shortcuts GameJackal still opens instead of launching the games, games still launch ok if i launch them from within GameJackal, is there anyone else noticed this issue?
     
  4. cheapherk

    cheapherk Active Member

    I can now create a successful profile with BIOSHOCK :clap
     
  5. d.chatten

    d.chatten Well-Known Member

    I have found another but very strange bug with GameJackal 2.9.18.574, when GameJackal is running in the system tray and i try to login to MY Account on the Play.com website Vista's Internet Explorer 7 crashes, if i right click and exit GameJackal i can login to My Account on the Play.com website without issue, below is how i tested this.

    1) IE7 closed, GameJackal running in system tray, open IE7, login to My Account at Play.com = IE7 crash

    2) IE7 closed, GameJackal NOT running in system tray, open IE7, login to My Account at Play.com = No crash & successful login

    This was tested on Vista Home Premium 32bit and Inernet Explorer 7 at least 20 times, also this never happened with GameJackal 2.9.18.570, this issue only showed up when i updated GameJackel to version 2.9.18.574, i have re-installed GameJackal 2.9.18.570 because this issue is not present in version 2.9.18.570.

    The screenshot below is one of many problem reports from Windows when this issue accured, as you can see the Fault Module Name is 12380HSW.dll which can only be found in C:\Program Files\SlySoft\Game Jackal and the Fault Module Version is 2.9.18.574 which again is related to the new beta version of Game Jackal.

    [​IMG]
     
    Last edited: Aug 31, 2007
  6. Ravenger

    Ravenger Active Member

    Great job! Bioshock now works. Thanks!
     
  7. matthew

    matthew SlySoft Team Member

    Thanks for the details... Play.com, is that "www.play.com" you are logging into?
     
  8. matthew

    matthew SlySoft Team Member

    This has been fixed for the next beta ;)
     
  9. ShadowDestroyer

    ShadowDestroyer Well-Known Member

    Did you fix SecurROM support on vista? I will test it and post results.

    In both .570 and the new beta, my shortcuts do nothing. I run them, and nothing happens.

    Edit: Sadly, all my SecurROM games still do not work without a CD.
     
    Last edited: Sep 1, 2007
  10. ShadowDestroyer

    ShadowDestroyer Well-Known Member

    C:\Program Files\SlySoft\Game Jackal\GameJackal.exe

    An error occurred while trying to replace the existing file.
    DeleteFile failed; code 5.
    Access is Denied.


    I am an administrator using windows vista. Not sure why I am receiving this error during installation.

    EDIT: DOH! Duh, GJ was running... The installation should probably prompt to close Game Jackal...
     
    Last edited: Sep 1, 2007
  11. matthew

    matthew SlySoft Team Member

    None of them work? Very strange, all current Securom titles should work with the beta.
     
    Last edited: Sep 1, 2007
  12. d.chatten

    d.chatten Well-Known Member

    Yes it's www.play.com i'm logging into.

    Thanks for the info, i will look forward to the new beta.
     
    Last edited: Sep 1, 2007
  13. Zeitgeist

    Zeitgeist Member

    Thanks for the update, but unfortunately, Kaspersky Internet Security 7.0.0.125 finds a trojan horse, which is, I assume, most likely a false alert:
    Code:
    gefunden: trojanisches Programm Trojan.Win32.Madtol.d (Modifikation)	URL: http://sandbox.slysoft.com/gj/SetupGameJackal.exe//file07
    :policeman:
     
  14. ShadowDestroyer

    ShadowDestroyer Well-Known Member

    Ok, I will do more SecurROM testing in this beta.

    And no, none of the shortcuts I tell game jackal to make do anything. The computer just sits there.
     
  15. Webslinger

    Webslinger Retired Moderator

    Provided you downloaded from Slysoft's website, yes, that is a false alert.
     
  16. Thraxas

    Thraxas Active Member

    Well I have tried 3 times with this update to get a working profile for Bioshock but so far have been unable to.
     
  17. ShadowDestroyer

    ShadowDestroyer Well-Known Member

    Yeah, my SecuROM games still do not work. (Diablo 2)
     
  18. matthew

    matthew SlySoft Team Member

    If you post that it does not work, can you also give details such as the error message you receive etc.
     
  19. matthew

    matthew SlySoft Team Member

     
  20. Thraxas

    Thraxas Active Member

    For me (with Bioshock) it's just the standard "No disc Inserted. Please insert the original..." securom message that you get if you try and play without the disc in the drive...