Autoplay Not Working

Discussion in 'AnyDVD HD (DVD issues)' started by breeza, Feb 20, 2008.

  1. breeza

    breeza Member

    I have a Gigabyte GA-EP35-DS4 intel based LGA775 motherboard (latest f2 bios) with a new SATA Pioneer DVR-215BK (firmware 1.18 ) DVD writer attached to the southbridge ICH9R SATA controller in AHCI mode.

    This is loaded with a fresh build of Vista x86 and SP1 RTM.
    ATI 8.2 drivers
    AnyDVD version 6.3.1.5

    With AnyDVD disabled autoplay works quickly and every time. With AnyDVD enabled autoplay only works occasionally and sometimes will take several minutes to kick off Media Center. The first disk you put in after a reboot is good but on disk swap it sometimes works fine, sometimes takes ages and sometimes doesn't autoplay at all. As soon as I right click the DVD drive in my computer the autoplay kicks in immediately.

    DVD drive is set to region 2. I am using R2 PAL original DVDs.

    I have also tried connecting the DVD drive to the gigabyte sata controller in IDE mode and autoplay is still not working correctly.

    All the AnyDVD settings are at their default values but I have tried ticking and unticking the PC-Friendly (Autorun on Video DVD) option but it doesn't seem to have any effect either way.

    All other AnyDVD functions are working fine including the baloon tip that shows the disk is being scanned.

    Diagnostic info zip file attached.

    Any ideas?


    ***** UPDATE *****
    I would obviously like this function to work as advertised but I think I have found a work around. I have created a command file that waits 5 seconds and then opens the e: drive (my dvd). I have set Anydvd to run this when any disk is inserted and it seems to work! Strangely if I remove the wait I get a windows error saying the the disk is not accessible. I guess this could be related to the issue: ie when windows gets the autoplay request the drive is still being accessed by anydvd and the first autoplay attempt fails, it subsequently runs when you refresh the drive or wait a very long time.

    ***** UPDATE ******
    I have tried this again with an older NEC DVD writer and autoplay works perfectly with anydvd. Looks like its a compatibility problem with pioneer drives. Anydvd support has recommended that I use LG or Plextor units.
     

    Attached Files:

    Last edited by a moderator: Jun 3, 2008
  2. DrinkLyeAndDie

    DrinkLyeAndDie Retired Moderator

    Do you have the PC-Friendly (Autorun on Video DVD) setting check in the AnyDVD settings? This disables autorun for discs and helps prevent the installation of garbage from DVDs & CDs.
     
  3. breeza

    breeza Member

    Post updated with further information
     
  4. oldjoe

    oldjoe Well-Known Member

    My best guess is the AHCI Mode. I would disable it in the BIOS.....that will allow it to use the native Windows XP drivers.
     
  5. breeza

    breeza Member

    I am using Vista and have installed this on a SATA hard drive on the same Intel controller. If I switch that controller to IDE mode Vista will unfortunately no longer boot.

    I did try moving the DVD to the gigabyte SATA controller which I set in IDE mode but this didn't resolve the autoplay issue.
     
    Last edited: Feb 21, 2008
  6. oldjoe

    oldjoe Well-Known Member

    Sorry, I assumed you were using XP.
    Vista will not boot when switching to IDE Mode because you are using an SATA HDD. Have you tried just disabling ACHI in the BIOS or is that what you are referring to when you say you switch to IDE?
    I don't use Gigabyte MOBO's so I'm not familiar with Gigabyte's BIOS.
     
  7. breeza

    breeza Member

    Yes when I disable AHCI Vista will no longer boot from the HDD.

    Right, well I have plugged in a Pioneer DVR-111 IDE DVD writer into the standard IDE socket and I get exactly the same issues. I am now thinking it may be a Vista Service Pack 1 final RTM issue.

    Does anyone have SP1 RTM with fully reliable autoplay?
     
  8. breeza

    breeza Member

    I have tried the IDE pioneer DVR-111 on Windows XP MCE SP2 on an ASUS P4C800-E Deluxe motherboard on the standard IDE connector.

    I have also tried disabling the AHCI controller on the gigabyte motherboard selecting the standard IDE mode with the DVR-215 SATA drive and installing Vista without any service pack.

    Both these configs still give me the exact same unreliable autoplay issue.

    Maybe AnyDVD just doesn't get along with the pioneer drives???

    I now give up!
     
  9. breeza

    breeza Member

    Can anyone recommend a current SATA DVD drive that is quiet, has good media compatibility and that definately has reliable autoplay in Vista with anydvd enabled?
     
  10. Charlie

    Charlie Well-Known Member

    You want auto play to work?
     
  11. breeza

    breeza Member

    Yeah its got to be wife and child friendly :)
     
  12. Charlie

    Charlie Well-Known Member

    This is simple just untick PC Friendly (Autorun on Video DVD). This is in the AnyDVD Settings not the program settings but the settings.
     
  13. breeza

    breeza Member

    Quoted from my first post:
    "All the AnyDVD settings are at their default values but I have tried ticking and unticking the PC-Friendly (Autorun on Video DVD) option but it doesn't seem to have any effect either way."
     
  14. Charlie

    Charlie Well-Known Member

    Right click and exit out anydvd then put a disc in and see if autorun starts.
     
  15. breeza

    breeza Member

    Yeah autoplay works fine if you just disable anydvd or if you completely exit it.

    The most common functionality is that if I put a disk in with anydvd enabled it pops up with the balloon saying that it is scaning the disk and the cd or dvd does not autoplay. As soon as I open the standard windows "my computer" screen you see windows detect the media and the autoplay kicks in.

    Its a shame because other than this issue its great!
     
  16. Charlie

    Charlie Well-Known Member

    This auto play annoys the majority though.
     
  17. breeza

    breeza Member

    Sure but in a family htpc environment it is essential functionality.

    I would obviously like this function to work as advertised but I think I have found a work around. I have created a command file that waits 5 seconds and then opens the e: drive (my dvd). I have set Anydvd to run this when any disk is inserted and it seems to work! Strangely if I remove the wait I get a windows error saying the the disk is not accessible. I guess this could be related to the issue: ie when windows gets the autoplay request the drive is still being accessed by anydvd and the first autoplay attempt fails, it subsequently runs when you refresh the drive or wait a very long time.
     
    Last edited: Feb 28, 2008
  18. vbcrayon

    vbcrayon Member

    Friends, I have the same problem. But I am computer technical, and install too many AnyDVD's everyday. Conclusion: AnyDVD is incompatible with Pioneer driver's (independent of firmware, including Buffalo and variations) and others.
     
  19. Webslinger

    Webslinger Retired Moderator

    I don't.

    You're mistaken. Autoplay works perfectly fine for me with the PIONEER DVD-RWDVR-215D drive.

    Summary for drive E: (AnyDVD 6.4.3.2)
    PIONEER DVD-RWDVR-215D 1.18 08/01/11PIONEER
    Drive (Hardware) Region: free

    Media is a DVD.
    Booktype: dvd-rom (version 1), Layers: 1
    Total size: 2131763 sectors (4163 MBytes)

    Video DVD (or CD) label: BIG
    Media is CSS protected!

    *snipped*

    1. Download Clonecd: http://static.slysoft.com/SetupCloneCD.exe (free 21 day trial)

    2. Run Clonecd

    3. Navigate to Tools-->Settings--->Autoplay

    4. Check "Play data discs automatically".

    5. Click "ok"

    6. Navigate to Tools-->Settings--->Auto Insert Notification

    7. Check "Enable Auto Insert Notification". Click "ok"
     
  20. vbcrayon

    vbcrayon Member

    Webslinger, the same thing...:bang:

    My Status:
    Summary for drive F: (AnyDVD 6.4.3.2)
    PIONEER DVD+-RW DR-K17Y 0.96 07/08/01PIONEER
    Drive (Hardware) Region: 4

    Media is a DVD.
    Booktype: dvd+r (version 1), Layers: 1
    Total size: 1735456 sectors (3389 MBytes)

    I tried many ways what you said and... NOTHING. Sometimes working. But it was just eject the DVD from the drive and the problem appeared.
    I have this same problem in several customers. And all drivers are pionner...

    PS: This happens too in Clean installations of XP.

    But apparently I solved the problem. Following the tips of the user "breeza" I made a CD shortcut and marked "start external program on media change". Placed in "Non Video", removed the parameters and put the path of the shortcut. It worked.

    But I wanted a permanent solution. See the whole topic or search on Google and see how many consumers are having the same problem...

    Sorry my bad English.
     
    Last edited: May 29, 2008