Workarounds for the shortcut bug in 2.9.18.545 (and Loonie's Observations thus far)

Discussion in 'GameJackal' started by Loonie, Jun 3, 2007.

  1. Loonie

    Loonie Well-Known Member

    Observations thus far

    SlySoft's GameJackal is finally upon us, and I've messed around with it on my laptop for an evening. How is it looking in the hands of the new owner?

    Well, firstly I was glad that my profiles didn't need to be redone. All the profiles appear to be functional. One thing to bear in mind with regard to the shortcuts to the profiles is that SlySoft have changed the name of the binaries. To point the old shortcuts in the right direction, go into the properties of the shortcut, and in the target section, change the part of the link that says "Maplom_sc.exe" to "GameJackal_cl.exe" and all will be well.

    I've also noticed that the profiles themselves seem to kick in considerably quicker. My C&C3 profile, which previously took around 7 seconds to get going, now seems to start within one second. Quite a difference.

    While I'm talking about shortcuts, there is, as many have encountered, a problem with creating desktop shortcuts. It just does that "List index out of bounds (-1)" thingy. For now, you can create your own shortcuts to get around this problem as follows:

    • Create a new shortcut in the location you want it (like the desktop).
    • Point it to "C:\Program Files\Maplom\GameJackal_cl.exe" (or wherever you installed GJ to).
    • Name the shortcut appropriately and hit "finish".
    • Now you will need to open GameJackal and bring up the properties of the profile in question (do this by right-clicking the profile in GJ and selecting "Edit profile"). The item of interest here is the number in the "Game Jackal Profile" box.
    • Meanwhile, back at the shortcut, bring up its properties. In the target box after link, you will need to add a space, then the following:
      ...where xxxxx-xxxxxxxxxx is the Game Jackal Profile number, and Profile Name is the exact name of the profile in GJ. Yes, you include the quotes. The weird character separating the two is the vertical line with a gap in it on your keyboard. If you're not sure, you can copy and paste the character from the above example.
    • If you wish (and you probably will), change the icon to the appropriate on e for the game. Hit "Apply" on the shortcut when done.

    All being well, you should have yourselves a working shortcut. It sounds a bit long-winded, but it's actually not too bad a workaround for now. As an example, my Oblivion shortcut's target looks like this:
    Finally, it seems to suffer the same level of SecuROM annoyance as the last version. I was expecting this, as efforts thus far will have been focused on the transition of the software to the new owner. No mean feat. The good news is that the HideJack plugin still works (sort of), and I can successfully run C&C3 1.04 using the same method as described previously (it may be luck, but the method seems more reliable with this version).

    So there we have it. A few teething troubles (unsurprisingly), but nothing that can't be ironed out relatively painlessly. As I said, it seems to me to be more of a transition than a big update. I think it has ended up in good hands.

    Death to DRM, long live GJ!
     
    Last edited: Jun 3, 2007
  2. Webslinger

    Webslinger Retired Moderator

    Thank you! Thank you! :clap:

    I thought I was going insane.

    I thought I had done something wrong. I spent hours agonizing over installations and my registry.

    The shortcut thing is a bug.

    :bowdown:

    *stickied*
     
    Last edited: Jun 3, 2007
  3. SHARKMEAT

    SHARKMEAT Active Member

    Well that is a funny thing I have had no problem's with my old icon's after intalling the New Slysoft GJ-Pro...CHEERS

    PS: Only diff I found in the too, It does load the games faster.
     
  4. Webslinger

    Webslinger Retired Moderator

    Try to create desktop shortcuts directly from within Game Jackal.
     
  5. SHARKMEAT

    SHARKMEAT Active Member

    Yep seems to be a problem in that area, When I click on create desktop shortcut icon it give me a box saying List index out of bounds (-1) Now I no what you saying, but I always use the game icon to create a profile, so I never traveled to the create icon in side of GJ.....CHEERS
     
  6. Webslinger

    Webslinger Retired Moderator

    Now try creating a new profile for a different game from an icon on your desktop. Afterward try running that new profile--from the icon on your desktop (and not from within Game Jackal; in fact, exit Game Jackal before attempting to run the new profile you just created).
     
  7. SHARKMEAT

    SHARKMEAT Active Member

    My desktop icon worked when I made a new profile useing the game made Icon with the convert to GJ method, is that what you ment !!...
     
  8. Webslinger

    Webslinger Retired Moderator

    I'm not sure. I don't think so.

    1. Go to your game directory. Find the .exe file you would normally profile from.

    2. Hold down the alt key and drag the .exe file to your desktop.

    3. Start Game jackal.

    4. Right click the icon you just created on your desktop and choose "convert to Game Jackal profile".

    5. Profile your game.

    6. Exit Game Jackal

    7. Double click the icon on your desktop that you just created a new profile for.
     
    Last edited: Jun 3, 2007
  9. SHARKMEAT

    SHARKMEAT Active Member

    Well that is what I did, which is the same diff as you stated how to do it

    The "alt" key is no more than right clicking on the EXE Icon in the Game Dir Folder to create a game shortcut to place on your desktop then useing it to convert to a GJ Profile, and mine worked perfect......CHEERS
     
  10. Webslinger

    Webslinger Retired Moderator

    Hmm . . .

    I will have to retest.

    Regardless, creating an icon from within GJ is definitely bugged.
     
  11. Webslinger

    Webslinger Retired Moderator

    Yeah, it's not working for me. The new profiles I'm creating on my desktop are all pointing to maplom_sc.exe (right click-->properties), which isn't on my system. GameJackal_cl.exe is on my system

    I'd sure like to know why the new profiles I'm creating on my desktop are pointing to maplom_sc.exe instead of GameJackal_cl.exe
     
    Last edited: Jun 3, 2007
  12. DrinkLyeAndDie

    DrinkLyeAndDie Retired Moderator

    Looks like someone missed the reference to maplom_sc.exe when they went through and made the relevant changes to code. Tsk tsk for that.
     
  13. Loonie

    Loonie Well-Known Member

    My old icons worked as well. The only weirdness I noticed was that the GJ systray icon displayed the old "Game Jackal is running" tooltip, rather than the new looking one. That's when I consulted the task manager and noticed that it was running the maplom exe, rather than the game jackal one (this is for the shortcuts to the profiles, not the profiles themselves).

    Note that if you update your previous GJ with SlySoft's, the old Maplom exes are still there, and by default your GJ desktop/explorer shortcut will reference the old (still functional) executables.

    As Webslinger and DrinkLyeAndDie say, I think the "create icon" stuff is screwing up because some of the old shortcut related code was missed in the conversion.
     
  14. SHARKMEAT

    SHARKMEAT Active Member

    Yeppers :agree: ...........CHEERS
     
  15. arobertson

    arobertson Member

    Or what about copying GameJackal_cl.exe to Maplom_sc.exe....

    Alex
     
  16. Loonie

    Loonie Well-Known Member

    You'd have to do that with every GJ update, then.
     
  17. SHARKMEAT

    SHARKMEAT Active Member

    I'm sure Slysoft will fix the problem with the next update, but lets all send in a support request to Slysoft to fix the flaws, alone with other problem's you may have......CHEERS
     
  18. Webslinger

    Webslinger Retired Moderator

    I have already alerted at least one Slysoft developer about this issue.
     
  19. Webslinger

    Webslinger Retired Moderator

    Unfortunately, 2.9.18.550 still does not resolve an issue I have with creating new profiles by right clicking on the icon on my desktop and selecting "convert to Game Jackal profile". All my new profiles created in this manner try to load
    maplom_sc.exe, which is a file that doesn't exist on my system. GameJackal_cl.exe is on my system.

    This issue might depend upon where Game Jackal is installed on one's system. On mine, it's installed here:
    C:\Program Files\SlySoft\Game Jackal

    I notice, by default, on other systems Game Jackal is being installed in c:\program files\maplom

    So this issue might depend on whether the user upgraded over a pre-existing installation.


    The List index out of bounds (-1) issue is now fixed, however.
     
    Last edited: Jun 5, 2007
  20. AngryElectron

    AngryElectron New Member

    My Workaround

    I too am having problems with the profiles pointing to Maplom_sc.exe.
    Since I had the older Game Jackal. I uninstalled, then installed SlySoft's latest release. Same Problem.

    My simple fix: Copy GameJackal_cl.exe from the Game Jackal folder to desktop.

    Rename this file to Maplom_sc.exe

    Cut and paste this back in the Game Jackal folder.

    Done! Everything should work fine--and no messing with the registry.