Windows XP on Mac OS with VM Fusion

Discussion in 'AnyDVD HD (DVD issues)' started by Bronzer7, Jan 14, 2008.

  1. Bronzer7

    Bronzer7 Member

    I've recently purchased a mac and am running OS on it. I bought Windows XP and VM Fusion software so I can run these two operating system simultaneously. I've partitioned off the hard drive, but I can't seem to get AnyDVD to work on it. Any suggestions? :confused:
     
  2. oldjoe

    oldjoe Well-Known Member

    Could you be a little more specific about you problem?
    Did AnyDVD install or does it not work after being successfully installed?
     
  3. Bronzer7

    Bronzer7 Member

    It installed ok, and whenever I put a dvd in it says that AnyDvd is reading the disc, but then a pop up comes up and it says the following:

    WARNING!

    Failed to read DVD!

    1. - Dvd Media is dirty, you can try to clean it.

    2. - DVD Media is damaged, you have to replace it.

    3. - Your drive is a region locked RPC2 drive, which does not allow reading of scrambled sectors from a different region and you try to read a DVD from a different region.
    Known drives having this problem are RICOH/PHILIPS DVD Writers and Matshita/Panasonic DVD readers and writers.
    You can try to find a RPC1 patched firmware at http;//www.rpc1.com

    4. - Your drive is an RPC2 drive that has not yet been assigned a Region. Try to assign one, or try to find a RPC1 patched firmware at http://www.rpc1.com



    Now, I'm absolute crap with computers and have no idea what any of this means. Has anyone else encountered similar problems?
     
    Last edited: Jan 15, 2008
  4. Webslinger

    Webslinger Retired Moderator

    Anydvd is not officially supported on Mac, but anyway . . .

    1.Update to Anydvd 6.3.0.9 beta: click http://forum.slysoft.com/showpost.php?p=81164&postcount=1

    2. a) Ensure Anydvd is running.
    b) Put the problematic original disc in your optical drive/reader. Wait for Anydvd to scan the disc.
    c) Right click the red fox icon on your toolbar.
    d) Select "Create Logfile"
    e) Wait for Anydvd to create a log file.
    f) A pop-up screen will appear. Take note of the location where Anydvd created the logfile and the logfile's name. Click "ok".
    g) Go to your My Documents folder
    h) You will see a zip file called "Anydvd_Info_titleofmydisc.zip" (or something similar; see step f)
    i) When replying or posting in the Slysoft forums, look for the icon that looks like [​IMG]
    j) If you don't see that paperclip icon, click the "go advanced" button. You should see that icon now. Click the paperclip.
    k) A small pop-up screen should appear (if it doesn't please ensure your browser is enabled to allow pop-ups from the Slysoft forums)
    l) Click the "Browse" button, and locate and select the .zip file you created.
    m) click "upload"

    3) State the full a)error message(s) you encountered (click "details"), b)tell us what program(s) you were using when you received the error message(s), and c) describe in detail what you were doing when you received the error message(s). What problem are you having exactly?


    I can't promise I can help you, but this information may help those who can.
     
  5. Bronzer7

    Bronzer7 Member

    I attached the zip file for the DVD I attempted to watch (original obviously). I posted the ENTIRE error message above.

    Basically, I have a MacBook, which means I have OS, but I run Windows XP through VMware Fusion. I open up the program, run it in full screen and let windows boot up. Once I am logged in I put in a dvd and it says "AnyDVD is scanning the disc", just like it should. That's when I get the message I posted above. I can still open AnyDVD, and see all the details of the disc, etc, but the disc won't play in any media players. When I attempt to play it in RealPlayer I get the following message:

    "You must have DVD software installed on your computer to play DVDs. Please ensure the DVD software that came with your computer or DVD drive is properly installed, before attempting to play your DVD."


    When I attempt to play it in Windows Media Player I get this message:

    "Windows Media Player cannot play this DVD because compatible DVD decoder is not installed on your computer."


    I can easily view DVD's for the region that my computer is assigned to, so I know that they do work. And I've even switched the region once just to check, and it does still work just fine.
     

    Attached Files:

  6. Webslinger

    Webslinger Retired Moderator

    The problem is your drive. Region 2 Matshita drive trying to play a region 1 disc . . .

    from Frequently Asked Questions (READ BEFORE YOU POST)


    16. Help! I'm having problems playing discs from other regions with my Matshita drive! Why?

    Matshita (Panasonic oem) burners should really be avoided. They are cheap junk (which is probably why some laptop companies love these drives), die easily, and also suffer from region coding issues. Click this:

    "AnyDVD works with Matsushita (Panasonic) drives, as long as:

    1.) The drive is set to a specific region code. If your drive isn't, set your preferred region.
    2.) CSS protected discs match this region

    AnyDVD does not allow you with Matsushita (Panasonic) drives to watch or copy a CSS protected disc, which has a different region then the drive, unless you have a patched firmware. (AnyDVD allows this with every other drive)

    The reason is rather simple:

    MMC standard requires, that a drive should not reveal a title key on a region mismatched CSS protected disc. (It should return "Illegal request - region code does not match"). Some drives are even less restrictive and even give you the title key on region mismatch.
    But AnyDVD can usually reveal the title key with a brute force attack, as long as the drive allows you to read the scrambled sectors.
    Matsushita (Panasonic) drives do not! You CANNOT read the scrambled data, if the region code doesn't match.
    No other drive behaves this way, only Matsushita (Panasonic) drives do, as the standard does not require a drive to not reveal the protected data on region mismatch, but Matsushita (Panasonic) drives are more restrictive as they need to be.

    There is nothing AnyDVD, DVDDecrypter, or any other software can do about this. Sorry.

    Solution: Set the drive to a region, and only use matching discs. AnyDVD will remove CSS/Macrovision/Adverts/User prohibitions/forced subtitles/FBI warnings/... no problem.

    It cannot bypass region codes with Matsushita (Panasonic) drives.

    I hope this answers your question. --James"
     
    Last edited: Jan 15, 2008
  7. Bronzer7

    Bronzer7 Member

    It should be a region 1 drive though as I bought it in the US.
     
  8. Webslinger

    Webslinger Retired Moderator

    It's not. And what I posted above still applies. The problem is your drive. Get something else.

    The hardware region is set to region 2. The disc is region 1.

    For non-Matshita drives this isn't an issue when Anydvd is running in the background--but it's a big problem for Matshita drives.

    You can try to change the region code on the drive to region 1, but if you start playing a lot of discs from other regions you're going to run into more problems (and there will be a limited number of region changes you can make on the drive).

    i. Right click the fox on your toolbar. Exit Anydvd
    ii. Click start. Right click on "My computer"--->select "properties".
    iii.Click on the 'Hardware' tab--->click the 'device manager' button.
    iv. Open the dvd/cdrom branch---> right click on your optical drive
    v. Click "properties".
    vi. You should have a region tab. From there you can select a region.
    vii. Select the region that matches the region on the disc
    viii. Start Anydvd
     
    Last edited: Jan 15, 2008
  9. Neko

    Neko Member

    re

    Try changing the region of you drive. Also check if you have selected region 1 in anydvd.

    I had a Macbook with Matshita DVD Drive with region 2. I had no problems copying a protected region 1 original disc using Parallels under OSX Tiger.

    Only problems I had with this drive was, that it did not support cheap dvd-r mediums such as Prostore or Intenso...
     
  10. Bronzer7

    Bronzer7 Member

    I really can't just be switching the regions all the time as I'm American and live in the UK and am a film student (brought a ton of dvd's with me, get the rest from the library here). Since it's the drive itself that's the issue, what can I do about it? Can I get it replaced? Can I buy an external drive? AnyDVD has turned into an essential piece of equipment for my studies here and I literally cannot function without it but don't know what to do :(
     
  11. DrinkLyeAndDie

    DrinkLyeAndDie Retired Moderator

    Your options are pretty limited, unfortunately. Yes, you can buy an external drive. Replace the internal DVD drive with one that isn't a Matshita or get an external DVD drive that also isn't a Matshita.
     
    Last edited: Jan 16, 2008
  12. timhunt

    timhunt New Member

    It can be done

    There seems to be a little confusion about the different ways of running XP/Vista on Apple hardware.

    As I understand it, Bootcamp provides a dual boot environment, so XP/Vista has direct access to the hardware. In this environment, AnyDVD is going to work as it does on any other PC hardware.

    On the other hand, Parallels and VMware Fusion provide emulated hardware, so XP/Vista has to go through OSX to get access to the underlying hardware. In particular, the DVD drive is emulated, so OSX actually interfaces with the drive, and Parallels/VMware then reverse engineers the interface to pretend that it's interfacing with a real drive. As a result, if the DVD doesn't work with OSX (for example out of region), there's nothing AnyDVD can do.

    But all is not lost. VMware Fusion (and maybe Parallels) provides for a USB pass-through mode. In this mode, XP/Vista actually sees the underlying hardware, so if you connect an external USB drive (and it has to be USB), and then use the VMware Virtual Machine USB configuration, AnyDVD can talk to the drive directly and works just as if it's running on native hardware. And now you can use out of region DVD's, and any other DVD's that OSX does not like.

    One other note. There were a few cases where I found I had to play the DVD using the OSX DVD player (just for a few seconds) before AnyDVD would work.

    Hope this helps.
     
  13. scrytch

    scrytch Member

    Hi everyone,

    I have the identical issue as the initial poster when running under VMWare Fusion. A few notes:

    1. This only happens under VMWare Fusion.
    2. This does not happen under Parallels.
    3. This does not happen when booted in (BootCamp) natively to Windows on the same machine.
    4. My drive has had region-free (RPC1) firmware applied (see here).

    I have the "MATSHITA DVD-R UJ-857E" drive (built into my MacBookPro), and have attached the log from under Parallels for a DVD I got an error with under Fusion (there is no error under Parallels).

    I no longer have Fusion installed and run Parallels instead due to this issue, however I'd like to run Fusion due to it's support of VMWare standard images.

    Thanks,
    Shane.
     

    Attached Files:

    Last edited: Apr 2, 2008
  14. Webslinger

    Webslinger Retired Moderator

    Quite simply Anydvd doesn't officially support VMWare Fusion (and not that I'm going to bother troubleshooting Mac issues, but if you want troubleshooting help it would make more sense to provide a log while using VMWare Fusion)
     
    Last edited: Apr 2, 2008
  15. scrytch

    scrytch Member

    That's fair enough - to be honest I think the problems is actually in the virtualized drivers in Fusion.

    AnyDVD initially didn't work in Parallels either, but I sent a support note to them (and posted on their forums) and it was fixed in the next version.

    Problem with Fusion in that I sent a support ticket to VMWare and their tech came back and pretty much said "due to questionable legality of the software [AnyDVD] we may or may not look into it".

    Regards,
    Shane.
     
  16. Phrehdd

    Phrehdd Active Member

    I have installed and tested AnyDVD HD under both Fusion and Parallels. Both installs worked fine for DVDs. I later installed a "blu ray burner for Mac" device in a Mac Pro and settled on Fusion because it could see the SATA 5/6 ports from the motherboard itself. However, the drive proved inept as it was probably an earlier generation unit and failed to read in Mac or Xp/Fusion certain discs. - It simply couldn't even mount the disc.

    The issues remaining are not at all with the Slysoft products. They do exactly what they are supposed to do in the Windows OS. As suggested, this is more about Fusion and Parallels.

    In the meanwhile, I have to try to find a replacement for my blu ray to run in either Fusion or Parallels. Either an internal SATA to mobo solution or an external USB2/Firewire model. If anyone can recommend a blu ray reader or burner that does work..please let me know

    - Phrehdd