Windows 10 Fall Creators Update???

Discussion in 'AnyDVD HD (Blu-ray issues)' started by Steve55, Oct 21, 2017.

  1. Steve55

    Steve55 Well-Known Member

    Anyone else using this (version 1709, 16299.19)?
    Maybe it's just a problem on the PC I am using.
    But maybe they have built some new bus level copy protection in, I have many problems e.g. am no longer able to rip a different region BD.
    See Anydvd dump file attached.
    I am also no longer able to copy files from a protected bluray, several other problems.
    So - just me or a general problem?
     

    Attached Files:

  2. James

    James Redfox Development Team Staff Member

    Just you.
     
  3. Steve55

    Steve55 Well-Known Member

    Sh*****t.
    Was working fine - this update installed - Everything stopped working!!
    Nothing in error logs.
    Only way to rip bd's that still works is use anydvd to rip to iso, then mount the iso.
    But this only works for region B disks (my region), region A disks just hang.
    Already tried deinstall and reinstall of Anydvd, no change.
    Any idea what to do????
     
  4. harsh

    harsh New Member

    You may have up to two weeks to uninstall the Fall Update.
     
  5. Steve55

    Steve55 Well-Known Member

    I need to keep it on that PC unfortunately.
    I don't see any solution at the moment. It's a real bugger.
     
  6. Steve55

    Steve55 Well-Known Member

    Well the first PC mentioned above was a Surface Pro.
    Now I just 'upgraded' an HP desktop to this version of windows. Same problem.
    So it doesn't look that I am going to be totally alone.
     
  7. worknstiff

    worknstiff Well-Known Member

    Creators Update got me too. It created a "New" user account because it didn't like me having users docs and downloads on a different partition. Didn't release that was what had happened and removed Creators Update only to find all my stuff was gone because it "Created" errors on my second partition because it was supposedly empty now and did a check disk to fix it. By the time I realized this my stuff was deleted. Thanks Microsoft.
     
  8. Hephaestus

    Hephaestus New Member

    It's not just you. When I stick a Blu-Ray disc in, it spins and I can hear the head seeking, but AnyDVD says that no disc is present. The Windows 10 Fall Creators Edition is probably the worst release since Windows ME.
     
  9. DaGoatRancher

    DaGoatRancher Well-Known Member

    I don't rip Blu-ray disks from other regions so I can't validate if that is a problem after my Fall Creators update. I can say that I am not seeing any issue with reading a BD in my drive, or ripping to HDD using CloneBD. I have also not experienced any other issues after installing the Fall Creators Update for Win10. My PC is an old Dell E6430s upgraded from Win7 to Win10 a while back. I have gone through all updates and system was up to date when the Fall Creators Update was installed. So far so good. I have been running this new update for about a week now. I am going to give this update a few weeks to burn in before updating my HP Desktop system. FYI (y)
     
  10. Hephaestus

    Hephaestus New Member

    The discs that I have tried are all from my region.

    Both Creator Updates broke my VPN. On my Dell XPS 15 laptop, the machine would Blue-Screen on every attempt to wake from sleep or hibernation for the first two months until Dell released a new BIOS and a completely new suite of drivers for everything. It's not a small update. They've changed a lot of the guts of the system. This is really Windows 11.
     
  11. Recycle

    Recycle Well-Known Member

    I am using a fresh install of 1709 updated and have no issue with dvd haven't tried BD yet but will later tonight. And if DVD copies just fine then BD if no issue would backup without glitch as well. Even previous 1607 I had no issue using Elybyte and RedFox software so not sure that your problem was related to these software.

    How is CU and broken VPN issue a Anydvd HD issue? That makes about much sense as peanut butter and jelly sandwich. RedFox has no control over Windows CU. Your grabbing for straws here that neither software is RedFox or Elybyte properties. I used these software since they started and the problem your describing is misdirected here.
     
  12. Hephaestus

    Hephaestus New Member

    Recycle:

    Windows and the things that it breaks are not RedFox's fault. Still, if you are trying to diagnose a problem with software, it is often helpful to know what has changed since the software last ran successfully and if any other programs/systems are also demonstrating symptoms.

    To your analogy: if I said that my ham and cheese sandwich tasted terrible and you said that your peanut butter and jelly sandwich also tasted terrible, a good starting point would be to see if the bread was the problem.

    At this point in time, both Steve55 and I are just reporting a problem and describing what we have seen (AnyDVD stopped reading Blu-Ray discs after the Creators Update). If no one else sees this problem, I'll investigate possible driver issues. If others see a similar issue, then perhaps the fine folks on the RedFox team may want to see if something is now broken under the hood.
     
  13. Steve55

    Steve55 Well-Known Member

    Hi everyone.
    Agree this is not AnyDVD problem as such, but if is encryption related, fair to post it here I think.
    I have no problems with DVD only with BD. That was why I thought, bus DRM checking issue. Here is update on what I am seeing, with reference to my Microsoft Surface Pro.
    - Worked fine with Spring Creators update
    - Have subsequently installed all drivers in Microsoft's October driver download SurfacePro_Win10_16299_1710007_0.msi without improvement
    - Most BD's I am unable to do any rip that involves file level operation, such as using CloneBD or drag and drop an m2ts file
    - Most BD's I can however use without problem the copy to ISO function of AnyDVD to create an iso that can be mounted and works fine
    - Remaining BD's, about 1 in 4, (and nothing to do with Region this was just a coincidence and false supposition on my part) they just spin and the message "AnyDVD is scanning the disk please wait" comes up repeatedly HOWEVER if you wait long enough (I don't know how long because I haven't sat it out, but we are talking at least 20 minutes and maybe hours, reminds me of the old days of SMB network timeouts) the disk does eventually "mount" and I can copy to ISO. This sounds similar to what Hephaestus is seeing.
    I duplicated the basic issue on my HP Elite desktop PC (with a different BD drive), didn't test extensively, put it back down now to the previous version.
    The fact that not everyone has the problem, suggests to me a chipset issue. But I think I will go and buy also a new BD drive, just on the offchance.
     
    Last edited: Oct 27, 2017
  14. Hephaestus

    Hephaestus New Member

    Okay, I seem to have fixed my problem. I discovered that there was a newer (actually, three newer) version of firmware for my drive. After reflashing the drive, it appears to be working well. In fact, the death-rattle on start-up (it used to sound like the engine in an old Beetle on a cold morning) has gone away.
     
  15. Krawk

    Krawk Well-Known Member

    I think this thread was started originally because of the possibility that Microsoft had implemented new code, compliments of the BDA. On the chance that they did, one can bet that developers of the major BD tools would be scrambling to get around it.
    At this point I am afraid to download the update! Honestly, I did not do the Spring update. When I did the Anniversary update my system would not let me log in. Fortunately I used my phone to google search. Ultimately what fixed it was a software update did not finalize, when I went into safe mode it did finalize and let me log in. Well hell, it let me log in so I rebooted and all was fine.
     
  16. Steve55

    Steve55 Well-Known Member

    That was indeed exactly my original thought
    It seems now very unlikely that this is the case, but I don't think I would 100% rule it out yet.
     
  17. C Parker

    C Parker New Member

    Same issue from here. For no discernible reason my AnydvdHD is failing to recognise the discs on occasion and on others not stripping decryption due to bad sector issues and other non events. Trying to create back-ups of 8mile and a Disney film, both of which are presenting the same issue.
    Have updated to the beta 8.1.9.2 and given the above, have updated the Atapi drive firmware and am trying again. Will report back.
     
  18. funreviews

    funreviews Member

    I work in IT, for a living. Not sure why you must keep 1709 on this PC unless you're using your work computer to burn your discs and your IT department won't let you uninstall updates, but I highly recommend removing 1709. You'll find over the next few weeks that more than AnyDVD functionality has broken and then these other important thing(s) that broke cannot be fixed because you can no longer remove 1709. It is BAD. Sign up here (if you want) and read all the things that have broken because of 1709: http://patchmanagement.org/


    Sent from my SM-N900T using Tapatalk
     
  19. theosch

    theosch Well-Known Member

    I have similiar issue in Windows 10 Version 1709. BlueScreen after waking up from S3 sleep mode. It's a Dell OTX 755 computer. RAM (4*2 GByte = 8 GByte) and CPU are OK, memtest and Prime95 and Kernel compiling in a loop without issues.
    Perhaps better to use S1 sleep mode only in BIOS, maybe this helps.

    [Edit]
    My installed Win 10 Ver1709 is a fresh and clean installation.

    Not any additional programs installed nor ever run, nor ever any Anti-Virus software installed.
    Just Windows Defender deactiviated with a small Registry edit.
    It is very useful to have a spare HDD and a second computer or connect it via eSATA-bracket on slotpanel and boot from there.

    My computers are older (9 years) and Windows 10 boots fine on every computer, more reliable than Win7 (no additonal drivers needed) when swapping HDD between computers.
    Well, I'll install AnyDVD in Win10 Ver 1709 and see if AnyDVD detects the discs, and test ripping BD-ROMs.
     
    Last edited: Nov 1, 2017
  20. Steve55

    Steve55 Well-Known Member

    Just to close this topic off from my pov...
    Bought today a new drive LG BE16. It's a monster thing with its own power supply. Anyway with this drive everything is working fine, and it is very fast.
    The non working drives are Asus and Verbatim, god knows why they should suddenly hit problems with the latest Windows, but there you go.
    Sorry for the red herrings.
    Steve