Unable to install DVD reader

Discussion in 'CD/DVD/BD Drives' started by kermitfrogirl, Sep 29, 2007.

  1. kermitfrogirl

    kermitfrogirl New Member

    Using Windows XP Home, I have installed a DVD reader. I am unable to get it to work. ie, the tray can be opened and the green light comes on but it does not appear as part of my hardware in the Device Manager.

    I have it plugged into IDE 2 (the DVD Reader/Writer is plugged in IDE1 where the HDD is connected).
    I have swapped cables which connect it to the motherboard and then to the disk drive to make sure the cables are working. No change.
    I have moved the little pin cover to change it to master, then slave then secondary slave. None of these changes work.

    Another forum suggested the following-
    What you might want to try first is going into the BIOS and seeing if it appears in there. For some computers you have to make sure that your settings in the BIOS are set to detect Optical drives. If there is not setting in the BIOS or if it detects it in the BIOS, I would the go to the manufactures website of the Optical drive and download the latest firmware. Install the firmware and reboot. You can also try the DVD drive in another computer to see if the actual drive is defective. I would start with the BIOS and then the firmware.

    And more...
    As stated above, some computer manufacturers disable parts of the IDE channel from the factory if there is no device connected to that part of the cable. I know for sure that Dell does this, I'm sure others do as well.

    Most likely it is disabled in the BIOS. You would be looking for items titled, Primary Master, Primary Slave, Secondary Master, Secondary Slave. Make sure that whichever you have the DVD drive connected to, that you have it enabled in the BIOS.

    Your Hard drive should be connected to IDE1 (Primary), and would either be set as Master or CS (Cable Select). I'm not sure why your DVD-writer is connected to IDE1, generally this would be connected to IDE2 (Secondary) as either Master or CS (Cable Select), but in any case...

    Connect your new DVD drive to the LAST connector on the IDE2 cable, and set it to Master. Go into your BIOS and make sure that the "Secondary Master" is set to 'enabled' or 'automatic'.

    This should clear up your issues. IT DIDN'T!

    what I then did
    I have looked at the bios and I am not sure whether I am understanding it completely but here is what I found:-
    My bios version is Gigaraid bios V1.71, copyright 2002-2004 ITE
    When I made changes to the pins to master on the DVD reader I get this message when restarting the pc before going into the BIOS to make changes:- Error firmware is not ready.
    The BIOS is as follows:-
    IDE CHANNEL 0 = HDD - Samsung SP1604N - master auto
    IDE CHANNEL 0 = HL-DT-ST DVDRAM GSA - slave auto (this is the DVD WRITER which is working)
    IDE CHANNEL 2 = Extended IDE Drive (AUTO)
    IDE CHANNEL 2 = NONE access Mode = (AUTO)
    Am I right in assuming that the IDE channel 2 is set to auto detection?

    I tried downloading new firmware for the Optical Drive from the manufacturer - Lite on IT Corporation
    It is Model No. LH-16D1P185C. With no success I can only download the instruction manual.

    The HDD is connected to the IDE 1 with the DVD Burner connected via a dual cable to the HDD. The pins do not have any selection, it does not have the plastic selector piece on it.

    Answer 3
    test the dvd drive on a working pc, to be sure it is ok, or try with another drive.
    you can also disconnect the dvd r/w; and connect your reader there properly jumpered, as you may have 1 bad atapi controller channel.

    What I then did
    I have installed the dvd drive onto another pc and it works fine. I have connected the DVD reader where the DVD writer was and it now works. I then hooked the DVD writer up to where the DVD reader was not working and surprise, surprise, it didn't work there. What is the atapi controller channel? Is it something I can fix?

    I am learning heaps but not getting anywhere any help is appreciated.
     
  2. oldjoe

    oldjoe Well-Known Member

    Is this PC a Pre-Built? If so, what brand and model number?
    Your Samsung is connected to your Primary IDE channel with your HDD.
    My preference, as well as most builders(PC manufacturers and custom builders), is to have your HDD(s) on your Primary IDE channel and optical drives on your Secondary IDE channel.
    My suggestion would be to put both of the optical drives on the same IDE channel and set the jumper pins to CS on both drives. If that solves your problem you can change them to Primary(the drive you want to use as the burner) and Secondary(the drive you prefer to use as a reader) if you prefer.
     
  3. mmdavis

    mmdavis Well-Known Member

    Secondary IDE

    If you put your new reader on the Primary IDE and it worked and your existing writer on the Secondary IDE and it didn't work, then the system is not recognizing your Secondary IDE or it is bad on the Motherboard. If the motherboard connector is bad, there's not much that can be done. If it's just the system not recognizing it, you might try going to Control Panel/System/Hardware/Device Manager/IDE ATA-ATAPI Controllers. You should have listed a Primary IDE Channel and a Secondary IDE Channel. If it's not listed, you may need to check with the motherboard manufacturer and see if they have a driver to do it or see if Windows XP will add one. If it is listed, you may try deleting it and restarting your computer and let Windows find it and add the driver for it. If it doesn't recognize it after deleting and restart, it sounds like the connector may be bad on the motherboard.

    It also looks like you may have some SATA slots. You might need to check and see if using the SATA will disable the Secondary IDE by default. You said your had IDE Channel 0 and IDE Channel 2. I wonder why IDE Channel 1 was skipped.
     
    Last edited: Sep 29, 2007