The UHD-Friendly patcher WORKS, that is until I goofed on one drive.

Discussion in 'CD/DVD/BD Drives' started by SAI_Archives, Mar 8, 2019.

  1. SAI_Archives

    SAI_Archives New Member

    Hello,

    First off, I want to think Coopervid for forwarding Billycarr11's "Easy and Safe" Flash patcher kit.

    I have about 20 of LG's WH16NS40 drives that bought over the past 3 years, and only in the past few weeks did I discover the dreaded 1.3 firmware that block for UHD-friendly disc playback.

    So... I patched the affected drives all seems to be working perfectly now.

    However, getting too eager, I also tried to patch an older WH14NS40 drive, not realizing it was *not* an NS50 chip device. The result is the drive will still appear in windows device manager, open and close, but it won't play anything now. Any attempt to re-flash it with the factory authorized v1.03 firmware files fail with a checksum error.

    So, any suggestions on how to recover my afflicted drive, since it still seems addressable? I tried "reading" the firmware from another identical, working, WH14NS40, but DOSFLASH gives me an invalid chip error.

    Any suggestions? I can't seem to find any earlier flash tools that might let me rescue my crippled drive.

    Thanks!!
     
  2. ErichV

    ErichV Well-Known Member

    I‘m afraid that your drive is useless.
     
  3. coopervid

    coopervid Well-Known Member

    Please try the firmware for the old models (lower 4). The one on the top is for the new one. You can see that there are two that are called 1.03 while the one for the old model says 1.03-A0. I would start with the oldest and if it works then upgrade it to 1.03-A0.

    https://www.lg.com/us/support-product/lg-WH14NS40
     
    theosch likes this.
  4. theosch

    theosch Well-Known Member


    I'm not sure whether you used Dosflash 1.7 +FreeDOS or Dosflash 2.0+WinPE (or both) for trying to rescue it.

    However using Dosflash 2.0+WinPE I had once such kind of error message "invalid chip error" or "invalid chipset".
    My computer has two SATA-IDE emulation settings in BIOS:
    ->SATA-configuration ->"Enhanced" ->IDE
    (SATA 0=IDE Primary Master; SATA1=IDE Secondary Master ;;; SATA2=IDE Primary Master; SATA3=IDE Secondary Master; SATA4=IDE Primary Master; SATA5=IDE Secondary Master; etc)

    Or otherwise other kind of IDE configuration through BIOS:
    ->SATA-configuration ->Compatible
    (SATA 0=IDE Primary Master; SATA1=IDE Primary Slave ;;; SATA2=IDE Secondary Master; SATA3=IDE Secondary Slave; SATA4=IDE Primary Master; SATA5=IDE Primary Slave; etc)
    ---------------------------------------------------------------------------------------------------------------
    I'm no longer sure which of the two of those it was, but one of those IDE-setting-kinds certainly didn't work with Dosflash 2.0+WinPE.
    Taking the other IDE-mode setting solved that kind of issue ("invalid chip error" or "invalid chipset")
    -------------------------------------------------------------------------------------------------------------
    Also testing with Dosflash 1.7+FreeDOS, even both IDE settings work for them for me,
    not any error-warning even on both SATA-IDE-modes.
    Aditionally:
    IDE compatible detected SATA ports 0+1 2+3 4+5
    (IDE Enhanced) detected only SATA ports 0+1 2+3 (so 5+6 not recognized)


    Also Some different motherboards I tested with, it was sufficient using a "Primary Master" SATA-Port but even at a higher SATA-port number as Master than port 0 (eg SATA-Port 0; 2 or 4) functioning (Asrock P43Pro/USB3) (Core2 LGA 775).
    My Asus P5Q3 supports just SATA port 0 afaik (so only one SATA-port), so less tolerant.

    Did you try with Dosflash 2.0+WinPE (WinPE= Windows PreInstallation environment = Windows installation media), or with Dosflash 1.7+FreeDOS?
    -------------------------------------------------------------------------------------
    Maybe trying out with both IDE-settings (if available) helps,
    and/or using other Dosflash version 1.7 / 2.0 (if not done already);
    and/or other SATA port (preferably BD-drive in the first port in a SATA-port-2-er-group,
    or possibly using the first connector in the frontmost-numbered 2-er-SATA-connector-group) (port 0).
    ------------------------------------------------------------------------------------------------------
    Afaik my newer mainbaord with LGA1155 just has one SATA-IDE-mode-setting (->IDE), so not any 2nd named entry for s.th. like "compatible".

    Just to clarify. Even with an erased EEPROM (also having a safety original firmware backup dump!) Dosflash detects the MediTek chipset (just tested with Dosflash 1.7 on a BH16NS55/BW-16D1HT) allowing to reprogram the EEPROM (principially with any firmware) (also having a safety original firmware backup dump!)

    Hope this helps.
     
    Last edited: Mar 14, 2019
  5. coopervid

    coopervid Well-Known Member

    I'm not completely sure but I think he was helped over at the makemkv forum. Appeared with another nickname but same issue and same day.
     
    theosch likes this.
  6. SamuriHL

    SamuriHL Retired Moderator

    LOTS of people have flashed their NS40 with the wrong service code and have borked them. We managed to help one person get theirs recovered by using dosflash 2.0 in a WinPE environment. It's not terribly difficult, but, it is a royal pain in the ass. Marty has been working on patching his flasher to get it to flash the correct firmware in Windows but so far no luck. I'm pretty sure what seems to be happening is once it's flashed with the wrong (ns50) firmware, the Windows flashers refuse to allow it to be flashed with the old firmware. I suspect this is something built in to prevent someone from screwing up an NS50 drive by flashing the wrong firmware. Shocking, I know. LOL But dosflash doesn't care. It just erases the eeprom and writes the bin file to it. So to recover one of these borked drives:

    o) You need a 32 bit WinPE environment with dosflash, eeprom data mover, and the firmware you're flashing to on it
    o) SATA port set to IDE mode
    o) First thing you do with dosflash when you boot the WinPE environment is EXTRACT (read) your existing firmware. This is THE MOST CRITICAL STEP. Failing to do this will brick the drive permanently.
    o) Run the data mover, giving it your extracted firmware, then the clean factory firmware for the ns40, and output a new bin file
    o) Flash (write) the new bin file with dosflash

    Done.
     
    coopervid, theosch and ErichV like this.
  7. theosch

    theosch Well-Known Member

    It's also working even with eg. Win10 PE (32 Bit + 64 Bit) media, e.g. from ISO extracted to flash drive+made bootable,
    or via Windows Media Creation tool.

    When booting the WinPE x32+x64 media the Windows PE -Windows-BCD-Bootmanager pops up at first, where you can select 64-Bit or 32-Bit PE variant to boot.

    Off Topic . By the way that also works with chainloading from Grub on the USB flash drive to boot the WinPE bootmanager.

    So if s.o. should have 64 Bit+32 Bit Win10 PE installation flash drive, there's anyway not any need to extraly redownload a 32 Bit-only variant etc. Just select the 32-Bit entry to boot :)
     
  8. coopervid

    coopervid Well-Known Member

    @SamuriHL ,

    you still rule! Magnificent help for all issues and blessed with patience I will never have. (n) And most likely I could be your grandpa age wise :ROFLMAO:
     
    whatever_gong82 and theosch like this.
  9. SamuriHL

    SamuriHL Retired Moderator

    LOL Don't look at me. I'm just one of MANY people helping people with these issues. I didn't create these methods only helping people through them when I can. Many others deserve far more credit.
     
    whatever_gong82 and theosch like this.
  10. coopervid

    coopervid Well-Known Member

    I know that you are around for ages now and you always bring it to the point. Was just kidding with the "grandpa" thing...