Rare reading errors on some UHDs

Discussion in 'AnyDVD HD (UHD only)' started by ultrahorst, Jun 10, 2021 at 11:10 PM.

  1. ultrahorst

    ultrahorst Member

    Hi,
    I am experiencing weird and erratic read issues with two of my UHDs and AnyDVD. I am using a Windows 7 machine with AnyDVD HD 8.5.5.0 and a ASUS BW-16D1HT with patched 3.10 firmware (supporting LibreDrive). Empty disc ziplog is attached. I know about the effect MakeMKV has on the drive, on all of my tests I did either reboot or cycle the drive to ensure LibreDrive is not active together with AnyDVD.

    The worst one is Gemini Man. When inserting the disc, the drive makes horrible seeking noises, as if the motor wants to move the laser further than possible. This continues for roughly two minutes, then at first, AnyDVD would either not continue reading at all (see message at the bottom of this post), or one time would fail with a "Failed to send host key (bus encryption)" error (see attached Gemini Man ziplog). MakeMKV on the other hand was able to decrypt the disc 100% of the time whenever Any struggled with it. I just closed Any, loaded MakeMKV and it worked. Sometimes with the same horrible seeking noise, but it would always succeed decrypting the disc. I tried rebooting, I re-tried after several days, nothing.

    Then out of the blue, Gemini Man works. No updates, no hardware modification. I insert the disc, horrible seek noises and AnyDVD can decrypt. Now I am failing to reproduce the issue, it just works. I suspect that either the disc, the drive or the combination is partially at fault, the seek noises do occur on GNU/Linux (Ubuntu) as well.

    The second case is Murder on the Orient Express. Initially when I got the disc, it was not supported by AnyDVD (not in OPD i guess) but read just fine. MakeMKV couldn't decrypt either, but the day after I submitted their logs, I could decrypt with MakeMKV. Today I tried to check whether the disc is supported now, but on my first try, Any would not read the disc at all (see message at the bottom), albeit without the horrible seek sound Gemini Man makes. MakeMKV reads it no problem: Quit AnyDVD, started MakeMKV, disc decrypts fine. Then I exit MakeMKV, cycle the drive, start AnyDVD and it suddenly reads the disc, and decrypts it fine. Can't reproduce either.

    I don't know if AnyDVD is to blame or if it is an OS/drive/disc issue, but it sticks out that other software can read the disc on every try. My other 17 UHDs read just fine in AnyDVD on the first try. I'm thankful for each thought onthese issues, I could live with them as all disc can be read one way or another, but I'd be happy if I can contribute towards improving AnyDVD somehow.

    Message (in German) when AnyDVD does not continue reading:
    Code:
    AnyDVD untersucht den Datenträger!
    Der eingelegte Datenträger ist in Kürze verfügbar.
    Bitte warten!
    
    ASUS BW-16D1HT 3.10
    
     

    Attached Files:

  2. SamuriHL

    SamuriHL Moderator

    Ok, my crazy idea stuff requires some questions. I know you said LibreDrive is not in the mix here and I trust that...however, that being said I have some thoughts.

    1) When you use LibreDrive (I.E. scan a disc with MakeMKV), are you using speed control? This is important
    2) When you are done using LibreDrive, are you simply ejecting the disc in hopes that it removes the LibreDrive in memory firmware from the drive? Or are you POWER CYCLING the drive? Rebooting SHOULD count as power cycling but in my experience that's not always true. Hence when you say "cycle the drive" I want to be clear what that means.

    Let's start with that. I want to get a very clear picture on this.
     
    whatever_gong82 and ultrahorst like this.
  3. ultrahorst

    ultrahorst Member

    1) The speed control options in AnyDVD are disabled and I am not using any additional software for that purpose.
    2) By "cycling" I simply mean ejecting and inserting the disc again. I verified that this would work by first decrypting a disc with MakeMKV, then trying to decrypt with AnyDVD. This fails as expected, when ejecting and re-inserting the disc, Any would decrypt the disc fine. Whenever I tested those two discs (or any other disc), AnyDVD is always the first software that ran and accessed my disc drive after cold boot. I'd only open MakeMKV when the the first attempt had already failed.
     
  4. SamuriHL

    SamuriHL Moderator

    1) I mean for LibreDrive. They are set in the registry and activate when LibreDrive is enabled
    2) Right that's what I was concerned with. It DOESN'T always work as you've discovered. I've had similar issues and I sometimes have to power cycle the drive. And if speed control is used in LibreDrive even this isn't always successful. Hence my questions.
     
    whatever_gong82 likes this.
  5. ultrahorst

    ultrahorst Member

    Hi SamuriHL, thanks for the insights. I didn't even know about the speed configuration possibility with LibreDrive, will check that out another time ;)
    1) I have never actively configured any speed control settings, the fact that I had to search for the registry path reinforces that claim. I found a (probably autogenerated) REG_SZ entry starting with "speed_ASUS_BW-16D1HT_3.10", but it has no value (Empty string).
    2) I'll keep that in mind to always do a proper shutdown when LibreDrive was previously active. On the other hand, I only resort to MakeMKV when there are issues with AnyDVD, the first tries (where I noticed the aforementioned issues) were always executed after a cold boot (proper shutdown, no standby nonsense), LibreDrive/MakeMKV was not active before.
     
  6. SamuriHL

    SamuriHL Moderator

    Is your drive an actual BW-16D1HT or is it cross flashed?
     
  7. ultrahorst

    ultrahorst Member

    It is an actual BW-16D1HT (retail version), bought in March 2021.
     
  8. DQ

    DQ Well-Known Member

    Please continue to follow whatever SamuriHL says.

    But I just wanted to note that the one time I had something similar to this behavior wise was when I had a bad Blu-Ray laser on my drive. At first it was having issues reading UHD discs doing all the seeking and making the noises like you describe. And after struggling with that it ended up not reading anything Blu-Ray at all. Had to replace it.

    That is just my experience I am not at all saying this your issue.
     
  9. SamuriHL

    SamuriHL Moderator

    It could be though. I've seen a bunch of problems with these drives in the last year or so. I'm guessing you have the latest mk firmware on it. See if you can find 3.02 non mk (the good one that works not the changed one that doesn't... yes there are two versions of it out there sigh), flash that, and see if this problem persists.

    Sent from my SM-G998U1 using Tapatalk