Please support Windows 2003, too

Discussion in 'Virtual CloneDrive' started by tino, Jun 27, 2007.

  1. tino

    tino New Member

    Hello,

    if you are on Vista compatibility of VCD, can you please think on adding support for Windows 2003 Server, too?

    When I currently install it on Server 2003, the reboot says, that some driver could not be loaded. You guess it: It's the virtual drive for VCD.

    Why Server 2003 is important:

    When you lease a Server at a hoster, you have no chance to access the CD/DVD drive even if it has one. Well, perhaps you can access the drive, with following procedure:
    - Drive to the next airport.
    - Fly to the continent where the machine is hosted.
    - Go figure.
    It's really a lot more easy to just upload the image and load it into an emulator.

    Of course there are other drive emulators out there which support W2003. However those are not free! DT is only free for noncommercial use. However we are talking about *server*, this usually means a commercial license is needed. Also I do not need all anti-copy-protection at all. I am talking about ordinary ISOs, like mounting the Windows® Server 2003 R2 Platform SDK ISO Download, see:
    http://www.microsoft.com/downloads/...AC-60BE-41BD-AA14-7F1E0F19CA0D&displaylang=en
     
  2. James

    James Redfox Development Team Staff Member

    Virtual CloneDrive should work fine on 32 bit versions of Win2003 Server. It will not run on 64bit versions.
     
  3. tino

    tino New Member

    On my Win2003 servers (32 Bit, German language) I was not able to get it running. On startup I observed a popup window telling of "some driver did not start correctly" (sp?) and then I was unable to mount images as the VCD-driver was marked defective. Therefor I deinstalled VCD again and the driver message vanished with it.

    However I am not sure, perhaps this was a *double* glitch at my side. Yes, I tried to install it on *different* servers, with the OS installed from different sources (different serial) by different people. The only one who both times failed to get VCD running was me. ;(

    So I admit, the error may be on my side. However please note that, in the meanwhile, I found out that VCD runs fine under Vista (32 Bit, Home Premium, German) for me. So I will test it again on my W2K3s when I find the time and document the outcome. However I am now on holidays (abroad) for 1 month, so I don't think I find the time before August 2007. When I find out something, I will report it here.
     
  4. Travelcard

    Travelcard New Member

    I've just had the exact same thing here :(

    It's Server 2003 R2 SP2 if that matters.
     
  5. allenrtsx

    allenrtsx New Member

    I think its R2

    I'm experiencing the problem as well but only with 2003 R2 SP2 servers.

    The virtual drive works fine on my 2003 SP1/SP2 and Windows 2000 SP4 servers.

    I'm looking at Data Execution Prevention which was a new feature introduced with R2 that may be causing problems. I'll post whatever I find out.

    -Allen
     
  6. allenrtsx

    allenrtsx New Member

    Well doesn't seem to be DEP. But its Definetly something with R2. I re-verified all my non-R2 SP2 and SP2 2003 Standard servers are fine.
     
  7. hikariuk

    hikariuk New Member

    Aye, I have VCD running on Windows Server 2003 SP2 box just fine, the Windows Server 2003 R2 SP2 box, on the other hand, just doesn't want to know; the driver fails to start, with the ever helpful error code 10.

    It's a little annoying, because it's a very handy thing to have on a remote server.
     
  8. Travelcard

    Travelcard New Member

    Whahey. It works with R2 now. thanks guys.
     
  9. DangerousDriver

    DangerousDriver New Member


    What did you do to get it to work? I've tried with v 5.2.0.2 on an R2 server with no success.

    Cheers

    DD


    ps If it's any help my error is EventID 4; Source VClone

    "Driver detected an internal error in its data structures for \Device\Scsi\VClone1."
     
    Last edited: Nov 24, 2007
  10. Ranco

    Ranco New Member

    Any new installation information?

    Hi, I am experiencing the same problem as DangerousDriver on Windows Server 2003 R2 Enterprise Service Pack 2 with CloneDrive 5.2.0.2 (same error in eventlog).

    Can somebody give me a hint on what to do to make this work?
     
  11. cerdo

    cerdo New Member

    Had problems... got it to work

    I couldn't even get it to install on Windows 2003 SP2 (not R2), at least not at first. I received an "installation failed" message when it tried to extract vclone.inf. I checked C:\WINDOWS\INF\, and vclone.inf was not there.

    I copied over vclone.inf and vclone.pnf (the .pnf might not be necessary) from a computer that had Virtual CloneDrive already installed, and tried to install it again (over itself). This time, I was presented with the "unsigned driver" warning from Windows (the three previous installation attempts never prompted me about this - they failed almost silently). I was able to accept the unsigned driver, and it worked, even without a reboot.

    Hopefully that helps...
     
  12. spgsitsupport

    spgsitsupport Member

    VCD 5312, W2K3 R2 SP2

    Every time I get device can not start Code 10

    Reinstalled x number of times, simply NO GO

    Seb

    PS
    Removing & re-installing the driver by hand makes no difference

    C:\nst4.tmp>devcon32.exe install VClone.inf root\vclone
    Device node created. Install is complete when drivers are installed...
    Updating drivers for root\vclone from C:\nst4.tmp\VClone.inf.
    Drivers installed successfully.
     
    Last edited: Jul 28, 2008
  13. James

    James Redfox Development Team Staff Member

    Have you tried VCD 5405?
    http://forum.slysoft.com/showthread.php?t=18634
     
  14. spgsitsupport

    spgsitsupport Member

    And it DID the trick, works now OK!

    Seb
     
  15. Chumbo

    Chumbo New Member

    I'm running Windows Server 2003 R2 Enterprise Edition with SP2. I just installed 5.4.2.5 and it failed. After the reboot, I can configure it via the UI, but it does not work.

    I couldn't find the vclone.inf file, not even on my XP PC which has it installed and working fine. Ideas? Thank you.
     
  16. James

    James Redfox Development Team Staff Member

    http://forum.slysoft.com/showthread.php?t=30519
     
  17. Chumbo

    Chumbo New Member

    Hi, that was fast. ;)

    I was going to post this first since I had found 5428 first. I installed this but had the same issue. So I reinstalled it back-to-back and when I did that, Windows Server 2003 found the driver and installed it.

    I uninstalled 5.4.2.8 and went to the link and grabbed .9. After uninstalling .8, .9 caused a BSD crash. I just rebooted and Windows was trying to install some driver, but was not able to find anything. I'm going to try to install .9 again right now and see what happens. I'll report back shortly.

    [EDIT] The installation still showed "Installation failed" but Windows Server 2003 was able to recognize the drive after the install finished. I just successfully mounted an ISO image. Whew. ;)
     
    Last edited: May 18, 2009
  18. scmeis1

    scmeis1 Well-Known Member

    It does, I have windows home server and it definitely works on it.
     
  19. James

    James Redfox Development Team Staff Member

    It sure does. But on 8th July 2007 (when I posted this) it didn't.