Please help, I'm getting a downsampled Hd audio through PCM

Discussion in 'ReClock' started by Dorohedoro, Jun 5, 2017.

  1. Dorohedoro

    Dorohedoro Member

    Hi!

    Please I need help. I can bitstream with no problem lossy audio and dtshd ma with reclock, but with true hd I'm getting an ocassional audio drop, so, I'm trying to pass the audio to the receiver in PCM but reclock is sending the audio downsampled from 192000hz to 48000hz (24bits).

    What I'm doing wrong? I've set the audio in windows settings to exclusive mode 192000hz 24bits, the reclock settings are untouched and Im sending the signal through wasapi exclusive. Also, the settings on the built-in audio filter (pot player) are "as is" no resampling... and 24bits.

    I'm getting audio, but is not loud like the original truehd track and is downsampled to 48000hz (lossy), I want to send the lossless audio through PCM without losing quality. What can i do?

    Thank you so much!
     
  2. hadar

    hadar Well-Known Member

    Play the file, click the reclock symbol and check the audio stream info. If it is downsampled already then the problem lies earlier in the chain, i.e. not a reclock problem.
     
  3. Dorohedoro

    Dorohedoro Member

    Yeah, the problem is on my config (the filter maybe?), what can I do to detect the source of the issue?

    Thank you!
     
  4. hadar

    hadar Well-Known Member

    What filter? Check everything in your audio chain from first to last and the first one which changes the format is the culprit. I guess you should check what potplayer is outputting first.
     
  5. el Filou

    el Filou Well-Known Member

    What filters does PotPlayer use? Is there a way to access the filter or the graph properties while playing? For example with LAV Filter you can see the info on the currently playing audio and its input and output format:
    LAV_Status.png
    This might help finding what component is causing the downsampling.

    Edit: in your message you say "I've set the audio in windows settings to exclusive mode 192000hz 24bits", but FYI the option for sampling rate and bit depth in the Windows Control Panel control the format for Shared mode. In Exclusive mode, it's the applications themselves that choose the output format they want.
     
  6. el Filou

    el Filou Well-Known Member

    I'm not the one having the problem, I just posted the screenshot to help Dorohedroro find the same info in their player. ;)
     
  7. Dorohedoro

    Dorohedoro Member

    Ok, as soon I get home I will upload some screenshots.

    And btw, Im playing truehd content, if I play the movie with the bitstream passthrough mode it shows 192000hz 24bits in reclock, the same movie with PCM shows 48000hz 24bits in reclock.

    Thank you all for all the help.
     
  8. Dorohedoro

    Dorohedoro Member

    Ok, here are some of my settings, let me know if you need more info.

    2xYAKnb.png
    OSzroSl.png
    4FaXxUj.png
    btqGR7P.png รง

    Thanks!
     
  9. hadar

    hadar Well-Known Member

    Your outputting DSound (resampled by Windows to 24 bit/48 kHz by default) with ReClock. If you don't want Windows to touch the audio set PCM to WASAPI in the third picture.

    Please mark 'LAV Splitter Source' in the first picture with the mouse. What's written there for audio? (According to blu-ray.com this movie has Dolby TrueHD 7.1, 48 kHz, 24-bit and not 192 kHz.)
     
    Last edited: Jun 5, 2017
  10. Dorohedoro

    Dorohedoro Member

    Ok, I'm really stupid, it turns out that the source is 48khz..... I'm so sorry to bother you all with my nonsense... case closed. I got confused because in the bitstream info it says 192000khz... but I'm assuming now that reclock is just showing what is capable to stream, not the actual khz of the track.

    Btw, I will ask one final question: if I'm sending the audio like this 1/1? what I'm asking is... is this the lossless audio just like the real truehd track? and btw, I must send the data through Dsound because I cant do 24bits with wasapi, it says my hardware is not supported.

    Thank you all so much and I'm so sorry for my mix up.
     
  11. el Filou

    el Filou Well-Known Member

    When bitstreaming encoded audio on HDMI, it always shows 192 kHz 24-bit, it's due to the way the bitstream is sent on the data link. That information doesn't matter when you use bitstreaming.

    In the second screenshot (audio processing settings of PotPlayer), do you have the option "same as input" instead of 24 bit? If yes, then select that.
    Then in ReClock config, for format try to set it to 24 bit there, or if it doesn't work, to "24 bit padded to 32". One of those two should work.
    As a rule: if you go to Windows Audio/Sound Control Panel, choose an audio output format for your sound device and click "Test" and it plays correctly, then it means that format is supported and it's just a matter of the application choosing the correct format in Exclusive Mode.

    Regarding losless audio, your decoder config looks just fine as it doesn't process anything, and if you follow hadar's advice of using WASAPI instead of DirectSound then you'll have the best quality. Please note that it is normal if the sound is not as loud when decoding as PCM with a PC as when bitstreaming, because official Dolby and DTS decoders (like in your receiver) can change the volume of the track depending on metadata and most non-commercial PC decoders don't. Just boost the volume level to compensate, it makes no difference to the audio quality itself.
     
  12. Dorohedoro

    Dorohedoro Member

    Thank you so much for all the info, I will test that when I get home.