Off The Rails (CloneBD Stopped Working)

Discussion in 'CloneBD' started by Beck38, Apr 9, 2018.

  1. Beck38

    Beck38 Member

    Having had CloneBD for quite a while (for it's cin* removal use), I decided a couple weeks ago to try utilizing the stripping/recoding features, as I owned a few discs that I had precessed using manual (and other) methods that ended up a bit 'rough', and there were several I simply hadn't spent time on.

    I processed several discs utilizing the version I had originally d/l'ed, 1.1.7.0. Everything worked pretty much as advertized, I figured out just how 'deep' (or not) to strip unwanted 'crud' out of the discs, and utilized several playback methods to 'sight check' the results before sucessfully burning to disc that was playable in standalone consumer players. But I did run into a couple that had problems properly processing (and that I couldn't quite figure out how to massage the program to work on them 'properly'), and as a new version (1.1.9.0) was available, I thought I'd give it a try.

    That version was a bit of a disaster. Part of the problem appeared to be the version of ffmpeg that was used in it (years ago I had run into problems with that when I was doing extensive recoding with various programs like handbrake etc.) so I uninstalled it and re-installed the 1.1.7.0 as it had worked 90% of the time. I did due diligence in rebooting the machine (fyi vista64) after I uninstalled and again after re-installing the 1.1.7.0, even though I didn't get any prompt to do so as like most Windows users of any era, rebooting after uninstalling or installing programs is an automatic thing to do.

    But guess what, the 1.1.7.0 did not return to the mostly stable operation. Although the program itself appeared to install (and run to a point) just fine, discs that had previously processed fine now failed to run the main movie from the main menu (which came up just fine; any extras and such run just fine from the menu, just the movie won't play, either stalling when started up (requiring the player program to be closed and re-started) or returning to the main menu.

    So okay, apparently the 1.1.9.0 put something in the machine which the uninstall program doesn't take out, leaving it to mess up 1.1.7.0, or the program itself simply cannot be 'rolled back' to the previous version, in which case one is really ***** if the programmer(s) mess up with a release.

    So, anyone run into this before, or ran into it recently, with what appears to be an inability to 'roll-back'
    the program to a more stable version, and what can be done to properly get the older version to run properly.
     
  2. blank

    blank Well-Known Member

    rolling back should work as far as I know.

    You can try beta 1.1.9.4
     
  3. Beck38

    Beck38 Member

    Same ffmpeg problem, so program won't even start up.

    In doing some review of this programs updates since 1.1.7.0, I found that changes made in 1.1.8.0 started using the incorrect ffmpeg version that is incompatible with my OS, and that the uninstall program is not completely eliminating bits and pieces of the program, so that if one installs a later version (that won't work due to the ffmpeg incompatible version), one is hosed from ever getting the program running again on an earlier version.

    Until those problems are corrected, this program is dead in the water.
     
    Last edited: Apr 10, 2018
  4. tectpro

    tectpro Translator (ms_MY)

    Its always good to provide a log file if theres an error or something doesnt work.
     
    whatever_gong82 likes this.
  5. Reto

    Reto Elaborate Bytes AG

    The ffmpeg version installed along with CloneBD contains several bug-fixes of our own and is specifically built and tested for CloneBD and the types of media used.
    Together with the fact, than CloneBD mainly uses the codecs only, you can't imply that CloneBD's ffmpeg is misbehaving based on the version.

    That is completely impossible. CloneBD always installs and uninstalls completely - except for ElbyCDIO.dll/sys, which is merely the driver required for disc access. That one will always remain the latest version.
    Also it only uses executable files from CloneBD's program folder (again, ElbyCDIO excepted and, of course, the Windows API). So you can easily verify and make sure, that uninstalling cleaned out completely - if not, you can manually remove leftovers, but I don't think there would be any.
    If you uninstall and reinstall an older version - I bet my life on this - you have the older version in all respects on your system.

    Rebooting also doesn't change anything. The setup will tell you to reboot, if a CloneBD component is not writeable due to being executed at the time, but that is normally not the case.
    Whatever problem you have is not likely to be caused by the version.
    You may have changed the settings / the way you convert the discs and mistakenly associated the problems with the coinciding update - which is a very common mistake to make.

    Can you please elaborate in what way the ffmpeg version would be incompatible with your OS (and what is your OS)?
    We have never had any reports in that direction.

    It is difficult to tackle your problem, without knowing what it is.
    I suggest, you download the latest version (we're currently at 1.1.9.4 beta and that version is known to be fairly stable and problem-free).
    Then you go ahead and to a conversion - 1.1.9.4 will automatically place a log file in your output folder.
    If you're still having problems, please describe them in detail and post the log file.

    Trust me, it's very far from being that ;)
     
    antipodes and whatever_gong82 like this.