Last Man Standing CSS error with 8.2.7.0

Discussion in 'AnyDVD HD (DVD issues)' started by Torgs, Aug 19, 2018.

  1. Torgs

    Torgs New Member

    I am getting a CSS error when trying to rip to ISO for the Last Man Standing widescreen DVD. Previously my DVD player was not set (region 0) but I changed it to match the region of the DVD (region 1) to ensure that the HW and software were in alignment. Sadly, that did not solve the issue and I have now burned one of my region changes for the DVD player... :( Any ideas on what I can do to work around the CSS issue? Thanks.
     
  2. James

    James Redfox Development Team Staff Member

    Post an AnyDVD logfile. Exit AnyDVD before setting the region code.
     
  3. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    And don't use the iso ripper to begin with on DVD's, anydvd gives you a warning for that too. If you must have an iso, use CloneDVD's iso function.

    Sent from my Nexus 7 with Tapatalk
     
  4. Torgs

    Torgs New Member

    Thanks all. I've added the log file to this post.

    @Ch3vron, Thanks for the info. Maybe I'm doing things a bit wrong. I need to create ISOs for network playback but can't have the protection in place. I was using AnyDVD to accomplish this. From what I recall CloneDVD does not support that functionality. Really, I just need the protection removed and I can use any ISO maker...AnyDVD is just handy and has worked flawlessly so far.
     

    Attached Files:

  5. mmdavis

    mmdavis Well-Known Member

    As James said, EXIT AnyDVD before checking or setting the drive region.
     
  6. Torgs

    Torgs New Member

    Hmm. I think I must not have hit OK when setting the region the first time. I went ahead, rebooted the machine, set the region to 1, rebooted the machine, verified the region setting and then retried with AnyDVD. It doesn't throw the CSS error but it is also not removing the protection. I ripped the fullscreen version without issue but the widescreen version is giving me some trouble. I created a new log and think things are set correctly (below). I tried to generate an ISO from the AnyDVD software as well as open the movie directly on the BluRay drive via media software (requires decryption to open). Both failed to open the file. The strange thing is that if I use AnyDVD to copy the disk, the protection is removed and I can open the VOBs, etc. without issue. I think the easiest thing at this point is to just use another ISO creator to generate the ISO from the copied media. Still not clear on why AnyDVD is not decrypting the drive or able to generate the ISO properly but am happy that I can work around the issue.

    Code:
    Summary for drive E: (AnyDVD HD 8.2.7.0, BDPHash.bin 18-01-30)
    HL-DT-ST BD-REWH14NS40 1.02
    Drive (Hardware) Region: 1
    Current profile: DVD-ROM
    Media is a DVD.
    Booktype: dvd-rom (version 1), Layers: 1
    Total size: 2219264 sectors (4334 MBytes)
    
    Video DVD (or CD) label: LAST_MAN_STANDING
    Media is CSS protected!
    Media is locked to region(s): 1!
    Video Standard: NTSC
    
    AI scan forced, heuristic scan detected no protection!
    Found & removed structural copy protection!
    Found & removed invalid VOBUs!
    RCE protection not found.
    UDF filesystem patched!
    Autorun not found on Video DVD.
    Removed CSS copy protection!
    Found & removed 1 potential bad sector protections!
    Emulating RPC-2 drive with region 1!
    Thanks again all.
     
  7. James

    James Redfox Development Team Staff Member

    It sure does. If you have CloneDVD, you should use it instead.
     
  8. James

    James Redfox Development Team Staff Member

    Please post the logfile.

    Sorry, I am lost. What exactly does not work and what does work when where and how?
    Why do you think it is a decryption issue? What "media player" software are you using how? When does it work? From the original disc with AnyDVD running? When doesn't it?
     
  9. Torgs

    Torgs New Member

    Sorry all. I can clarify a bit.

    The purpose is to rip unencrypted ISOs for network playback using any ISO media player across platforms (MAC, Windows, iOS, Android and Linux). Typically I use VLC but my family uses an assortment of other software. None of the software will playback the media if I simply make an ISO of the BluRay/DVD without removing the encryption. I have to decrypt the DVD and then rip to ISO. I did not realize that CloneDVD could decrypt the media as well as create the ISOs. I'll have to look into that.

    For what is/is not working:
    • Before setting the region on the HW, I was able to rip the fullscreen version of Last Man Standing without issue.
    • Before setting the region on the HW, I received a CSS error when trying to do the same on the widescreen version
    • After adding the region, AnyDVD does not generate the CSS error but I cannot use VLC (or any other non-DVD software) to play the media directly from the DVD.
    • After adding the region and ripping to an ISO via AnyDVD, I cannot playback the ISO using any media software that I tried. Each piece of software throws their own error. These errors are the same as if I simply made a backup of the DVD without removing the encryption.
    • If I use AnyDVD to copy the contents to the HD, I can play the VOBs using any software. I was also able to use a freeware ISO maker and generate an ISO and play it that way.
    While I am not positive it is a decryption issue or not, some of the tests I have run align with the same behavior I see if I try to do the same with other BluRays/DVDs but have not decrypted them/don't have AnyDVD running.

    I'll have to post the logfile later as it is at home and I'll need to VPN and upload once I have a bit more time.

    Thanks.
     
  10. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    Simple. Then have AnyDVD active and use the image ripper in CloneDVD2. Problem solved. On the "target" page. Should be the middle button.

    Setting a drive region only affects DECRYPTING of the disc, it shouldn't have any effect on VLC's behavior as long as anydvd's running.