GameJackal 2.9.18.595 released

Discussion in 'GameJackal' started by Tom, Oct 12, 2007.

  1. Tom

    Tom Redfox Team Member Staff Member

    GameJackal 2.9.18.595 has been released:
    http://www.slysoft.com/download.html

    Release v2.9.18.595 - release (2007-10-11)
    • Updated blacklisting support.
    • Change to prevent the "Insert CD/DVD" error occuring with some profile after a reboot.
     
  2. jodokast89

    jodokast89 Active Member

    Thanks for the update!

    There is just one tiny thing that is bothering me ... Can we please get the old skins we had from Maplom?? I mean you could make your own if you want, but ANY different ones would be much appreciated. Pretty pleaseeee?? :D

    :bowdown::bowdown::bowdown:
     
  3. Bifford

    Bifford Member

    Thanks! Oh, and well done on the SLysoft Site finally incorporating the Game Jackal icon into the top graphic bar of the main website! ;-)
     
  4. Targon

    Targon Well-Known Member

    Still having problems with NWN2(with 595)

    Sorry for not posting this sooner.

    1. What version of Game Jackal are you running?

    Game Jackal 2.9.18.595

    2. What Operating system are you using? 64 bit? service pack?

    Windows Vista Home Premium 32 bit.

    3. If you have virtual drives, disable them while profiling and playing profiles. This includes Daemon Tools, Alcohol 120%, Virtual Clonedrive, Clonecdtray, and possibly Anydvd.

    No virtual drives enabled. Found Starwind service running(part of Alcohol 120%). Disabled the service.

    4. Remove packet writing software from your system (including Roxio's Directcd, Nero's Incd, Roxio/Sonic's DragtoDisc, Drive Letter Access, CyberLink InstantBurn, etc.)

    Nothing installed, though with all the extra bloat of the default Windows Vista install, I suppose there might be something Microsoft put in.

    5. What protection does your game use? Don't know? Find out before posting about issues (and include that information)! Use Protection ID. It's a free program. Use ProtectionID and scan your HD directory where the game is installed (right click the icon on your toolbar, and select "scan files/folders"). Or just scan the main program .exe(s) that you find in the game directory on your hard drive. Provide the protection name and the version number.

    Scanning -> C:\Program Files\Atari\Neverwinter Nights 2\nwn2main.exe
    File Type : Exe, Size : 11616256 (0B14000h) Bytes
    -> Suspicious MZ Header..
    [!] SecuROM Detected - Version 7.21
    [!] Possible CD/DVD-Key or Serial Check -> cdkey
    - Scan Took : 0.344 Seconds

    6. What is the name of the game you're trying to run?

    Neverwinter Nights 2 DVD

    7. What is the version of the game?

    1.010.1116

    8. Is it cd or dvd version?

    DVD

    9. What region or country is the original disc from?

    North America/USA

    10. What cpu are you running?

    AMD Athlon 64 X2 5600+

    11. What optical drives (dvd-rom,cd-rom, burners) are you using to create profiles with? What firmware version is installed on your reader?

    Lite-On DVDRW LH-20A1H ATA.
    Hardware ID: LL0A

    12. What security software (firewall, antivirus) are you using? Please provide version numbers.

    AVG Free Antivirus(shield turned off for testing). 7.5.488

    13. Describe your problem, provide full error messages, and please state clearly what you were doing when you received those error messages.

    I create the profile using the normal NWN2 profile, auto settings. Application crashes when I try to use the Game Jackal profile. Game runs fine with the game DVD in the drive and I run the normal executable.

    14. You should have two log files in your Game Jackal directory. The first is called. Proc Monitor.log, and the second is called Profile.log (do not post the Profiler.log file... notice the "r" at the end). Copy and past the information into your next post. Here is one way to do it:

    ------------------------------------------------------------------------
    Proc Monitor.log
    ------------------------------------------------------------------------
    Game Jackal log file - Proc Monitor
    Log date - 10/14/2007 6:14:57 AM

    ***********************************************
    [10/14/2007 6:14:57 AM] No process found!
    [10/14/2007 6:14:57 AM] Process ID 0 was not found, debouncing...
    [10/14/2007 6:14:57 AM] Process ID 0 still was not found, searching for another process...
    [10/14/2007 6:14:57 AM] Process ID 0 was still not found, leaving...
    [10/14/2007 6:14:57 AM] Process method used, monitored nwn2.exe

    -------------------------------------------------------------------------

    -------------------------------------------------------------------------
    Profile.log
    -------------------------------------------------------------------------
    Game Jackal log file - Profile
    Log date - 10/14/2007 6:14:46 AM

    ***********************************************
    [10/14/2007 6:14:46 AM] Profile - Neverwinter Nights 2
    [10/14/2007 6:14:46 AM] Profile mode: 2
    [10/14/2007 6:14:46 AM] Profile CP: 1
    [10/14/2007 6:14:46 AM] Driver mode: 21948
    [10/14/2007 6:14:46 AM] Process will be created in a suspended state.
    [10/14/2007 6:14:46 AM] Process created successfully
    [10/14/2007 6:14:46 AM] C:\Program Files\SlySoft\Game Jackal\87304H.dll loading...
    [10/14/2007 6:14:46 AM] C:\Program Files\SlySoft\Game Jackal\87304H.dll loaded successfully.
    [10/14/2007 6:14:46 AM] Resuming process.
    [10/14/2007 6:14:57 AM] Media information
    [10/14/2007 6:14:57 AM] Name - NWN2
    [10/14/2007 6:14:57 AM] Serial - ******
    [10/14/2007 6:14:57 AM] Size - 0
    [10/14/2007 6:14:57 AM] Profile deactivated.
    -------------------------------------------------------------------------



    My ImgBurn clipboard is here:

    ===============================================
    Filter Driver Load Order - ImgBurn v2.3.2.0
    ===============================================

    Upper Device Filter: [None Found]
    Upper Class Filter: maplom
    Device: CD/DVD-ROM Device
    Lower Class Filter: [None Found]
    Lower Device Filter: [None Found]

    Filter Name: maplom
    File Name: C:\Windows\system32\Drivers\maplom.sys
    File Version: 2, 9, 18, 595 [2.9.18.595]
    File Description: Maplom.sys
    Product Name: Game Jackal
    Product Version: 2, 9, 18, 595 [2.9.18.595]
    Company Name: SlySoft Inc.
    Copyright: Copyright © 2007 SlySoft Inc.


    I hope this is everything you need. As I mentioned, I stopped the Starwind service(from Alcohol 120%) since I found it running. I deleted and recreated the profile with it disabled to make sure it wasn't getting in the way.

    The exact symptom of the problem:
    Neverwinter Nights 2 has stopped working
    Windows can check online for a solution to the problem.


    Problem signature:
    Problem Event Name: APPCRASH
    Application Name: nwn2main.exe
    Application Version: 1.0.10.1116
    Application Timestamp: 00000000
    Fault Module Name: nwn2main.exe
    Fault Module Version: 1.0.10.1116
    Fault Module Timestamp: 00000000
    Exception Code: c0000005
    Exception Offset: 007cce22
    OS Version: 6.0.6000.2.0.0.768.3
    Locale ID: 1033
    Additional Information 1: 2309
    Additional Information 2: 62d79df7d790999d51cc9f537eb5220e
    Additional Information 3: 372d
    Additional Information 4: f4d0e6a9d2ad9061f532160decd26875

    Read our privacy statement:
    http://go.microsoft.com/fwlink/?linkid=50163&clcid=0x0409
     
    Last edited by a moderator: Oct 16, 2007
  5. BadIronTree

    BadIronTree Active Member

    for some reason NWN 2 with vista 32 never worked with me.. always say emulator detected
     
  6. Targon

    Targon Well-Known Member

    Emulator detected would be an improvement here. NWN 2 crashes on me. Emulation detected can sometimes be work around while the app crash indicates that the copy protection is conflicting with Game Jackal. :(
     
  7. matthew

    matthew SlySoft Team Member

    Ok... I suspect the crashing is caused from something incomplete within the profile (maybe try image mode???)

    However this emulation error is very odd. We have NWN2 as one of our test games and it runs fine (under Vista also). I can tell you that early versions of Securom that attempted to detect GJ also detected other applications as GJ even when GJ was closed (they have since cleaned up their act). I guess make sure there is noting else running before firing up this profile.
     
  8. Targon

    Targon Well-Known Member

    This has been the problem I have had with Game Jackal and NWN 2 since I got my new Windows Vista machine. I also had a similar problem with Civilization 4(and expansions) but this was fixed a while ago.

    I can say that I have attempted to make a NWN 2 profile many times now with similar results. Now, I just picked up Mask of the Betrayer and if I use the profile I made with the original it generated a blue screen.

    As for things running in the background, I shut down everything except the Vista sidebar, so that shouldn't be it.

    My motherboard is an Asus M2R32-MVP with the latest drivers available from Asus.

    I have AVG Free antivirus installed, and while I had turned off the resident shield, there were still a bunch of services turned on which could in theory cause problems. If AVG being installed(even with the shield turned off) can cause problems, I am sure it will affect others. The AVG Resident Shield service can NOT be turned off without uninstalling AVG.

    Readyboost and Superfetch services are turned on.


    So, what services do you have running on the test machines, and what Antivirus software have you tested with under Vista(not XP since XP works fine with NWN2)?

    I have seen in many cases with other companies that the test environment computers are set up to be as "clean" as possible to make sure that the software works, but clean machines also tend to have no anti-virus on them, which can make real-world problems difficult to trace. My own machine is also very clean overall. A vanilla Windows Vista Home Premium 32 bit setup with AVG anti-virus and the drivers off the driver CD.

    The only thing about this machine that is slightly unusual is that I have a flash card reader(one of those 15 in 1 type). The drivers for it are the generic drivers from Microsoft though. Generic USB xx Reader USB device.

    I also have my printer set up and connected through my home network. You can check the drivers for the HP Officejet 7310 network setup(TCP/IP). I have also shut down the services for it and am about to attempt to make a NWN2: Mask of the Betrayer profile. If that fails, I will try the vanilla NWN2 profile.

    The blue screen may be a hint at what is going on. If I have a Mask of the Betrayer DVD in the drive and a broken NWN2 profile causes a blue screen, what was it doing previously? Isn't GJ supposed to lock the CD/DVD drive so nothing has access to it? Perhaps that is a key point, that GJ is trying to block access to the drive while it emulates the protection, and at the same time, the copy protection is getting past GJ.
     
  9. Targon

    Targon Well-Known Member

    As an update, trying to make a straight new profile for Mask of the Betrayer, ultra-high scan with a fast drive, it causes a blue screen on my system. This in a way hints at it being some weird driver problem(ATI Chipset on the motherboard), or the copy protection is causing problems with Game Jackal:

    Problem signature:
    Problem Event Name: BlueScreen
    OS Version: 6.0.6000.2.0.0.768.3
    Locale ID: 1033

    Additional information about the problem:
    BCCode: 50
    BCP1: 8C173B89
    BCP2: 00000000
    BCP3: 81C91774
    BCP4: 00000000
    OS Version: 6_0_6000
    Service Pack: 0_0
    Product: 768_1

    Files that help describe the problem:
    C:\Windows\Minidump\Mini101607-02.dmp
    C:\Users\Administrator\AppData\Local\Temp\WER-45661-0.sysdata.xml
    C:\Users\Administrator\AppData\Local\Temp\WERD1AF.tmp.version.txt

    Read our privacy statement:
    http://go.microsoft.com/fwlink/?linkid=50163&clcid=0x0409
     
  10. matthew

    matthew SlySoft Team Member

    Normally you should get a message telling you about the conflict (i.e. a different cd is in the drive)... So yes these results are a little weired. Can you try creating a new profile with image mode checked.
     
  11. Targon

    Targon Well-Known Member

    Same problem, blue screen of death when I try to profile NWN2: Mask of the Betrayer, image mode, with ultra high scan(or auto). I get no message from either the game or GJ before the blue screen.
     
  12. matthew

    matthew SlySoft Team Member

    Download imgburn from http://www.imgburn.com/index.php?act=download
    Once installed, go to Tools -> Filter Driver Load Order and click "Clipboard". Then paste the information here. This will tell me what else is sitting in your driver stack. :confused:
     
  13. Webslinger

    Webslinger Retired Moderator