"Failed to read sector" errors

Discussion in 'CloneCD' started by jeff9329, Aug 17, 2007.

  1. jeff9329

    jeff9329 Member

    I have been successfully using AnyDVD and CloneCD for a few months now with spectacular results.

    I used CloneCD to write some firmware CD images recently too for my HD-DVD player.

    As of today, I had a three failed DVDs (first ones ever) and started looking at the logs and images created.

    I found that while I am reading to an image I get constant consecutive "failed to read sector" errors. The resulting image is then labeled 001...002...etc. I tried both my DVD drives and tried two brand new DVDs Im backing up. So, I think it is the software.

    Please help.

    AnyDVD 6.1.7.0
    CloneCD 5.3.0.5
     
    Last edited: Aug 17, 2007
  2. Webslinger

    Webslinger Retired Moderator

  3. jeff9329

    jeff9329 Member

    Here is the information:

    Summary for drive E: (AnyDVD 6.1.7.0)
    OPTIARC DVD RW AD-7170A 1.02 JUL14,2006
    Drive (Hardware) Region: 1

    Media is a DVD.
    Booktype: dvd-rom (version 1), Layers: 2 (opposite)
    Size of first Layer: 2075104 sectors (4052 MBytes)
    Total size: 4146681 sectors (8098 MBytes)

    Video DVD (or CD) label: CRZ0NNF1
    Media is CSS protected!
    Video Standard: NTSC
    Media is locked to region(s): 1!

    RCE protection not found.
    DVD structure appears to be correct.
    Structural copy protection not found.
    Autorun not found on Video DVD.
    Bad sector protection not found.
    Emulating RPC-2 drive with region 1!

    FYI, both this drive and this DVD, Cars, have been used previously to make a successful backup.

    Here is the CloneCD log:

    I 8:07:11 AM CloneCD Version 5.3.0.1 started!
    I 8:07:11 AM ElbyCDIO Driver 6.0.1.0
    I 8:07:11 AM ElbyCDIO.dll 6.0.6.5
    I 8:07:11 AM CCDDriver.dll 5.0.0.1
    I 8:07:11 AM ElbyECC.dll 4.0.0.0
    I 8:07:11 AM WriteDVD.dll 2.6.3.1
    I 8:07:11 AM Registered to: deleted
    I 8:07:11 AM Searching for SCSI/ATAPI devices...
    I 8:07:11 AM Device Scan found 0 CD-ROMs and 2 CD-Writers!
    I 8:07:26 AM Starting copy from Optiarc DVD RW AD-7170A to D:\IMAGE.dvd
    W 8:07:29 AM Failed to read Sector 32
    W 8:07:31 AM Failed to read Sector 6560
    W 8:07:33 AM Failed to read Sector 13152
    W 8:07:35 AM Failed to read Sector 19808
    W 8:07:39 AM Failed to read Sector 33312
    W 8:07:43 AM Failed to read Sector 47040
    W 8:07:45 AM Failed to read Sector 53920
    W 8:07:47 AM Failed to read Sector 60864
    W 8:07:49 AM Failed to read Sector 67872
    W 8:07:50 AM User has cancelled operation!
    I 8:07:50 AM Duration of operation: 00:00:23
    I 8:07:50 AM Average Speed: 6258 kBytes/s (4.64)
    E 8:07:57 AM Reading from Optiarc DVD RW AD-7170A failed!
     
    Last edited: Aug 18, 2007
  4. Webslinger

    Webslinger Retired Moderator

    As there is no protection on this disc (other than basic CSS), this is highly unlikely to be a protection (nor Anydvd) issue.

    1. Try cleaning your disc. Download Nero cd-dvd speed. It's a free program. With Anydvd running in the background, select the tab labeled "scandisc". Select the appropriate drive letter, and click "start". If Nero cd-dvd speed reports read errors, your disc is (probably) bad and needs to be exchanged--even if it plays fine (or your optical drive could be slowly dying).

    2.
    a) Download imgburn. It's a free program: http://www.imgburn.com/index.php?act=download
    (it's also an excellent program imo)

    b) Go to Tools > Filter Driver Load Order. Click "Clipboard". Then paste the information you pasted into your clipboard into your next post (ctrl-v).
     
  5. jeff9329

    jeff9329 Member

    Webslinger:

    The fail to read sector error occurs on any DVD during the write to image. I have tried several and the two I most want to backup are brand new, never even played. No doubt it is not a media problem.

    The problem also repeats exactly the same on all the optical drives on my system. So it is not a drive hardware problem.

    I recently installed a new motherboard and this may be the first backup since, I can't remember for sure.

    Im pretty sure there is a driver problem, just not sure how to resolve. Here are the drivers on my best optical drive:
    drivers.jpg

    I will try your advice below for now.

    Thanks

     
  6. Webslinger

    Webslinger Retired Moderator

    It's failing during the READ process:


    No. Lots of discs that are sold are poorly mastered or suffer from defects. It's not uncommon to buy a bad brand new disc. That said, I am aware of an issue in Anydvd 6.1.7.0, which may be the culprit here. I'm not sure.

    You can start by doing the steps I outlined originally. Step 2, in particular, will list the filters.
     
    Last edited: Aug 19, 2007
  7. jeff9329

    jeff9329 Member

    ImgBurn filter driver load order:

    ===============================================
    Filter Driver Load Order - ImgBurn v2.3.2.0
    ===============================================

    Upper Device Filter: redbook
    Upper Class Filter: GEARAspiWDM
    Device: CD/DVD-ROM Device
    Lower Class Filter: Pfc
    Lower Class Filter: PxHelp20
    Lower Class Filter: AnyDVD
    Lower Class Filter: ElbyCDFL
    Lower Device Filter: imapi

    Filter Name: redbook
    File Name: C:\WINDOWS\system32\DRIVERS\redbook.sys
    File Version: 5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)
    File Description: Redbook Audio Filter Driver
    Product Name: Microsoft® Windows® Operating System
    Product Version: 5.1.2600.2180
    Company Name: Microsoft Corporation
    Copyright: © Microsoft Corporation. All rights reserved.

    Filter Name: GEARAspiWDM
    File Name: C:\WINDOWS\System32\Drivers\GEARAspiWDM.sys
    File Version: 2.0.6.1
    File Description: CD/DVD Class Filter Driver
    Product Name: GEAR.wrks
    Product Version: 8.xx [2.0.6.1]
    Company Name: GEAR Software Inc.
    Copyright: Copyright (c) GEAR Software Inc. 2006

    Filter Name: Pfc
    File Name: C:\WINDOWS\system32\drivers\pfc.sys
    File Version: 2, 5, 0, 201 [2.5.0.201]
    File Description: Padus(R) ASPI Shell
    Product Name: Padus(R) ASPI Shell
    Product Version: 2, 5, 0, 201 [2.5.0.201]
    Company Name: Padus, Inc.
    Copyright: (C) Padus, Inc. 1999-2001. All rights reserved.

    Filter Name: PxHelp20
    File Name: C:\WINDOWS\System32\Drivers\PxHelp20.sys
    File Version: 2.03.32a [2.3.32.0]
    File Description: Px Engine Device Driver for Windows 2000/XP
    Product Name: PxHelp20
    Product Version: [2.0.0.0]
    Company Name: Sonic Solutions
    Copyright: Copyright © Sonic Solutions

    Filter Name: AnyDVD
    File Name: C:\WINDOWS\System32\Drivers\AnyDVD.sys
    File Version: 6.1.7.0
    File Description: AnyDVD Filter Driver
    Product Name: AnyDVD
    Product Version: 6.1.7.0
    Company Name: SlySoft, Inc.
    Copyright: Copyright 2002 - 2007 SlySoft, Inc.

    Filter Name: ElbyCDFL
    File Name: C:\WINDOWS\System32\Drivers\ElbyCDFL.sys
    File Version: 5, 2, 1, 3 [5.2.1.3]
    File Description: ElbyCDIO Filter Driver
    Product Name: CloneCD
    Product Version: 5, 2, 1, 3 [5.2.1.3]
    Company Name: SlySoft, Inc.
    Copyright: Copyright (C) 2003 - 2006 SlySoft, Inc.

    Filter Name: imapi
    File Name: C:\WINDOWS\system32\DRIVERS\imapi.sys
    File Version: 5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)
    File Description: IMAPI Kernel Driver
    Product Name: Microsoft® Windows® Operating System
    Product Version: 5.1.2600.2180
    Company Name: Microsoft Corporation
    Copyright: © Microsoft Corporation. All rights reserved.

    Nero CD-DVD Speed scandisc with AnyDVD running:
    nero with anydvd.jpg
    Nero CD-DVD Speed scandisc without AnyDVD running:
    nero without anydvd.jpg
    It is worse without AnyDVD running. These results are repeatable and the same with any of 3 drives.

    What could be wrong?
     
    Last edited: Aug 19, 2007
  8. DetroitBaseball

    DetroitBaseball Well-Known Member

    You have a bad disc.
     
  9. DrinkLyeAndDie

    DrinkLyeAndDie Retired Moderator

    What happens if you attempt to rip the DVD via the AnyDVD ripper?
     
  10. Webslinger

    Webslinger Retired Moderator

  11. jeff9329

    jeff9329 Member

    Okay:

    It is a driver problem. I have not figured out exactly which one or why yet, but it probably relates to my mobo install without a clean windows install.

    After uninstalling all the software and drivers for burning applications & reinstalling, it still initially gave read errors. I then started read testing on unprotected movie DVDs I had backed up. All the backed up burned DVDs read at 100%. I then tried again to read the original DVD that gave me problems and it too read fine with no errors! I then was also able to read and backup the other new DVD that I had tried previously too.

    So, somehow one of the drivers is causing sector read errors that are false. I have also caused an instability in CloneCD where it is now failing to respond or close (occasionally).

    I will try #1 listed below and hopefully that will help. However, I believe I should move on to SATA burners (and an OS clean install) as this motherboard (ASUS P5K Deluxe Wi-Fi/AP) dosen't really natively support IDE drives.

    Thanks, and I am up for more suggestions and/or reccomendations.


     
  12. jeff9329

    jeff9329 Member

    Sorry, just saw your post (appears edited from the email one I recieved).

    I have not tried that. I assume it would have failed as it wouldn't have been readable.

    I ocassionally rip them & reassemble, but usually go with an image because I want all the "junk".
     
  13. DrinkLyeAndDie

    DrinkLyeAndDie Retired Moderator

    I initially posted a message and then deleted it. Then I posted a new message. That's likely why it appears different.

    I would agree with you on the unreadable part but... I recently had a similar problem [with a different movie] where CloneCD threw out endless read errors but the image creation would finish at a snail's pace. However, Nero Recode wouldn't read the resulting image or the directly from the DVD, itself. AnyDVD ripper had no issues with the same DVD or the image of it. That's why I suggested it. I'm just curious to see what happens. I'm not saying it will work but it can't hurt to try.
     
  14. jeff9329

    jeff9329 Member

    FYI:

    Performing item 1. listed below is not valid on current P35 based motherboards and is likely to cause even more problems. The ICH9R southbridge controlling the IDE drives has it's own driver nowdays.

    Still not sure exactly what is wrong with my setup, but it's not working again and I haven't had time to clean install everything. The AnyDVD driver is certainly not working right. Not sure if it has a problem or other drivers are causing the problem.

    I will report later.

     
  15. Webslinger

    Webslinger Retired Moderator

    Works fine for me on an Intel P35 based motherboard . . .