DMA issues

Discussion in 'General Hardware Issues' started by mac007, Jan 4, 2008.

  1. mac007

    mac007 Active Member

    I had changed my settings to dma a while ago. I notiiced that my current back up was taking forever. I checked my settings, the system went back to pio on 1 of the primary ide channels: Device 0
    Transfer Mode: dma if available
    current transfer mode: pio
    Device 1

    Transfer Mode: dma if available
    current transfer mode: ultra dma mode 2
    I am not getting a drop down arrow to change the current transfer mode setting to dma . Thanks for any help you can give.
     
  2. Webslinger

    Webslinger Retired Moderator

    What operating system are you using?
     
  3. oldjoe

    oldjoe Well-Known Member

    Try uninstalling the drive(s)-reboot and let windows reinstall them. Then check the DMA and reset to DMA Mode if they are in PIO Mode. Windows "should" retain that setting.
    It is a possibility that your chipset drivers have been corrupted. If your PC is a custom build, reinstall the INF (chipset) drivers from the MOBO CD or download them from the MOBO manufacturer's site.
    You could also try a System Restore from a time when all was working properly.
     
  4. mac007

    mac007 Active Member

    DMA Settings

    Thanks, I deleted it and rebooted and everything is working fine.
     
  5. NIK_2021

    NIK_2021 New Member

    MAC, did you delete one drive or all of them? Didnt work for me
     
  6. Spanky

    Spanky Well-Known Member

    Mac007, you might want to keep an eye on this setting since it fell back once it might do it again. If it encounters too many IO errors or fails to negotiate a DMA channel it will fall back to PIO.