AnyDVD, DVDShrink and Vista compatibility.

Discussion in 'AnyDVD HD (DVD issues)' started by mrshoewater, Apr 3, 2008.

  1. mrshoewater

    mrshoewater Member

    I just bought a new computer with Vista Home Premium and I installed AnyDVD and DVDShrink without any install errors. However, every movie I have tried to backup except one, has given me a copy protection error from DVDShrink. DVDDecrypter would freeze up and send me through an unending cycle of error messages that I had to use task manager to close.

    I tried uninstalling and reinstalling. I updated to Service Pack 1 and I have version 6.4.04 of AnyDVD running. I tried running both DVDShrink and AnyDVD in combinations of compatibility modes and elevated administrator privledges, all to no avail.

    I just now grabbed an older movie off the shelf to see if it would work. No such luck. AnyDVD appeared to handle "Munich" with no problem, and DVDShrink opened it, but when i started the backup it gave me a copy protection error. I got the crazy idea of closing AnyDVD and running Munich through DVDshrink alone, and it worked just fine. It appears that my problem has to do with AnyDVD and/or Vista, but I have not seen any solutions out there that have worked for me.

    Thanks
     
  2. Webslinger

    Webslinger Retired Moderator

    1. Use Anydvd 6.4.0.6 beta: click http://sandbox.slysoft.com/beta/SetupAnyDVD6406.exe

    You may need to reboot after installing if prompted to do so.

    2. Click the red fox icon on your toolbar. Click "default". Click "ok".

    3. If you use DVDShrink, Nero Recode, or programs that generally can't handle structural protections, right-click on the fox icon on your toolbar and select "Rip video-dvd to Hard Disk". Choose your source and destination paths. Click "Copy", and wait for Anydvd ripper to finish. You can then import that rip into whatever program you want. This is an important step if the original disc contains structural protection.

    click http://forum.slysoft.com/showthread.php?t=3992 and read fully

    You don't need to do this if you own Clonedvd or are planning to make a backup with Clonecd.


    4. Use Clonedvd 2.9.1.6 beta: click http://sandbox.slysoft.com/beta/SetupCloneDVD2916.exe

    5. Follow the steps from this link in order: click http://forum.slysoft.com/showthread.php?t=476 (follow them step by step)

    If you're using +R DL blank discs, I recommend using Clonecd: click http://forum.slysoft.com/showthread.php?t=327


    6. If you still have problems, then . . .

    A)
    a) Ensure Anydvd is running.
    b) Put the problematic original movie dvd in your burner. Wait for Anydvd to scan the disc.
    c) Right click the red fox icon on your toolbar.
    d) Select "Create Logfile"
    e) Wait for Anydvd to create a log file.
    f) A pop-up screen will appear. Take note of the location where Anydvd created the logfile and the logfile's name. Click "ok".
    g) Go to your My Documents folder
    h) You will see a zip file called "Anydvd_Info_titleofmydisc.zip" (or something similar; see step f)
    i) When replying or posting in the Slysoft forums, look for the icon that looks like [​IMG] (in other words, look for the paperclip after clicking "quote" or when creating a new thread)
    j) If you don't see that paperclip icon, click the "go advanced" button. You should see that icon now. Click the paperclip.
    k) A small pop-up screen should appear (if it doesn't please ensure your browser is enabled to allow pop-ups from the Slysoft forums)
    l) Click the "Browse" button, and locate and select the .zip file you created.
    m) click "upload"
    n) Close the window. When you submit reply, or submit a new thread, the .zip file will be attached automatically for us to take a look at


    B) State the full a)error message(s) you encountered (click "details"), b)tell us what program(s) you were using when you received the error message(s), and c) describe in detail what you were doing when you received the error message(s). What problem are you having exactly?


    C) Click http://forum.slysoft.com/showthread.php?t=5091 to see if your question has already been answered
     
  3. mrshoewater

    mrshoewater Member

    I installed the beta version of AnyDVD and there is no difference. AnyDVD Ripper also would not work. I even tried turning off Vista UAC which I have heard causes a lot of problems and that had no effect. I have attached the logs for Munich and I Am Legend.

    Here are the error messages I got from AnyDVD Ripper and DVDShrink:

    ---------------------------
    AnyDVD Ripper
    ---------------------------
    FileIO 3 VTS_01_0.VOB 0 24576



    ---------------------------
    DVD Shrink 3.2
    ---------------------------
    DVD Shrink encountered an error and cannot continue.

    Failed to read file "E:\"

    Copy Protection Error - The read failed because the sector is encrypted.



    Both of these errors occured within a few seconds of clicking the "start backup" buttons on the programs.

    Also, I have had zero issues using AnyDVD and DVD Shrink on my XP computers. I tried a DVDFab trial and it works fine on my new PC with Vista.

    Thank you for your help.
     

    Attached Files:

  4. Charlie

    Charlie Well-Known Member

    FileIO 3 VTS_01_0.VOB 0 24576 in general is a bad disc. Filters looked fine.
     
  5. Webslinger

    Webslinger Retired Moderator

    There's nothing special with respect to protection on either disc. I'm not too sure why you're using an outdated version of Anydvd on I Am Legend, but that really shouldn't matter given the lack of anything resembling structural protection on the disc.

    Anydvd handles both discs perfectly fine.

    As Charlie noted, a FileIO3 implies a bad original disc even if it plays fine.

    Download Nero cd-dvd speed. It's a free program. With Anydvd running in the background, select the tab labeled "scandisc". Select the appropriate drive letter, and click "start". If Nero cd-dvd speed reports read errors, your disc is (probably) bad and needs to be exchanged--even if it plays fine (or your optical drive could be slowly dying).


    Dvdfab can skip over read errors. In those instances, your backup will not be perfect (it will be missing content; if you're missing just a few cells, you won't notice; if it's a big error it's skipping over you may notice a part of your movie missing).

    Anydvd ripper does not skip over read errors.

    Your options are to try cleaning the discs or try another drive.
     
  6. mrshoewater

    mrshoewater Member

    Bad disc? What does that mean? DVDShrink backed up Munich just fine with AnyDVD closed.
     
  7. DrinkLyeAndDie

    DrinkLyeAndDie Retired Moderator

    Please follow Webslinger's advice, mrshoewater, and update to AnyDVD 6.4.0.6 beta and follow the other steps again. You're still using AnyDVD 6.3.1.7.
     
  8. DrinkLyeAndDie

    DrinkLyeAndDie Retired Moderator

    If you update to the latest version the problem might go away. There have been changes made since v6.3.1.7 was released that might make a difference. We won't know unless you try. It would be wise to update, anyway, since you might run into newer discs that you won't be able to handle with an older version of AnyDVD.
     
  9. mrshoewater

    mrshoewater Member

    Sorry, I included an older log file for I am Legend since it was right next to the new one I made for Munich. I have the newest version.
     
  10. Webslinger

    Webslinger Retired Moderator

    Yeah, and Shrink should given that there's no protection other than CSS on the disc. Practically anything can handle CSS. So this isn't a protection issue.

    It's possible that something is conflicting with Anydvd on your system, but I'm noticing anything.

    Edit: try briefly disabling your ativirus and/or antispyware software.

    I would also try cleaning the discs and try a different drive just to rule out the drive.

    Unfortunately, I am unable to reproduce this problem under Vista 64 bit ultimate edition with Service Pack 1.
     
    Last edited: Apr 4, 2008
  11. mrshoewater

    mrshoewater Member

    Here is a new error message from the movie "Mask"

    ---------------------------
    AnyDVD Ripper
    ---------------------------
    FileIO 3 VTS_01_0.VOB 10240 141312


    Also, I was able to get AnyDVD Ripper to start the movies Munich and Mask, but once it started, I aborted to see if DVD Shrink would work, which it didn't, and then when I went back to see if AnyDVD Ripper would work again, I got those error messages.
     
  12. Webslinger

    Webslinger Retired Moderator

    I would try another drive (and maybe even a different cable on the back of the drive).

    It really doesn't make any sense to me that you should be getting read errors on all discs, much less ones that don't contain any special protection.
     
  13. mrshoewater

    mrshoewater Member

    Here is another error I received on the movie "Mask".

    ---------------------------
    AnyDVD Ripper
    ---------------------------
    FileIO 3 VTS_01_0.VOB 10240 141312


    Also, I was able to get AnyDVD Ripper to work on Munich and Mask, but after I aborted to see if DVD Shrink would work, when i went back to AnyDVD Ripper, I got this last error and the one from above. I guess the ripper doesn't like to be aborted.

    I still think AnyDVD should work with Shrink if Shrink works by itself.

    Thanks
     
  14. Webslinger

    Webslinger Retired Moderator

    Yeah, I agree. Anydvd and Shrink work perfectly fine for me on all of my computers.

    Out of curiosity, in Shrink's preferences, do you have "burn with nero" enabled? If so disable that option, and try again.

    But again, I would still try another drive. I have absolutely no issues with Anydvd working with Shrink on three different computers.
     
    Last edited: Apr 4, 2008
  15. mrshoewater

    mrshoewater Member

    I don't believe it fully yet, but unchecking Burn with nero actually worked......so far. If I abort after the backup starts then i still get the same errors with shrink and ripper, but if restart the computer they work again. I have not tested this fully, bnut that is the way it appears to work.

    If thats all it was that I needed to do, I will be amazed. But even if i need to do something else, Thank you very much for your help.
     
  16. Webslinger

    Webslinger Retired Moderator

    click http://forum.slysoft.com/showthread.php?t=3896 for related information (perhaps reading through there will help you)