AnyDVD + DVD Decrypter Problem (waiting for drive...)

Discussion in 'AnyDVD HD (DVD issues)' started by LzD, Jul 28, 2007.

  1. LzD

    LzD Member

    Hello.

    Since upgrading to a new PC some days ago I have strange messages in the DVD-Decrypter Logs, reading "Waiting for device to become ready". As this is not only annoying but also slows down the ripping process I´d really appreciate any hints to a solution for this problem.

    Some more info :
    - Problem only occurs when AnyDVD is activated
    - Problem shows on all three tested DVD-Drives as well as on all DVD-Medias
    - Files SEEM to be fine after ripping, I am not 100% sure though as I didnt have the time to test a full movie
    - I´ve tried ASPI, ElbyCDIO and SPTI Interface in DVD-Decrypter, all show the same symptoms


    DVD-Decrypter-Log :

    I 13:01:10 Source Device: [1:3:0] TOSHIBA ODD-DVD SD-M1802 J031 (F:) (SCSI)
    I 13:01:10 Source Media Type: DVD-ROM
    I 13:01:10 Source Media Region Code: 1; 2; 3; 4; 5; 6; 7; 8
    I 13:01:10 Source Media Copyright Protection System Type: None
    I 13:01:10 Source Media Implementation Identifier: UDF Toshiba DVD Video
    I 13:01:10 Destination Folder: C:\DVD\encode\POSTMAN_PAL_DISC2\VIDEO_TS\
    I 13:01:10 File Splitting: By File
    I 13:01:10 Detect Mastering Errors: No
    I 13:01:10 Multi Angle Processing: No
    I 13:01:10 Remove Macrovision Protection: Yes
    I 13:01:10 Stream Processing: No
    I 13:01:10 Copying VTS_01_1.VOB... (LBA: 16081 - 540367) - KEY: N/A
    W 13:01:11 Waiting for device to become ready...
    I 13:01:12 Device ready!
    I 13:01:12 Extracting Sectors...
    W 13:01:16 Waiting for device to become ready...
    I 13:01:16 Device ready!
    I 13:01:16 Extracting Sectors...
    W 13:01:20 Waiting for device to become ready...
    I 13:01:20 Device ready!
    I 13:01:20 Extracting Sectors...
     
  2. LzD

    LzD Member

    Just some system specs in case this is a hardware-related problem :

    Mainboard : Gigabyte P35-DS4
    CPU : Intel Q6600
    DVD-Drives : Toshiba SD1802; Toshiba SD1712 ; NEC ND-2510A
    OS : WinXP Pro

    All drivers are up to date.
    The 1712 uses a the No-limit-firmware ; other drives use their normal firmwares.
    AnyDVD-version is the newest trial version.
     
  3. linx05

    linx05 Well-Known Member

    Have you tried a fresh install of both DVD Decrypter and AnyDVD?

    By the way, no need to remove CSS protection as AnyDVD already does this. There are a few other options to disable in DVD Decrypter aswell if you want it to work with AnyDVD.
     
  4. PIGSgrame

    PIGSgrame Well-Known Member

    I don't think this is a hardware problem. Do you have a special reason for using DVDDecrypter? I haven't used this program for years, but if I remeber correctly, this tool will only remove the CSS copy protectiron, which AnyDVD can also do itself.

    I believe your probelm is that two programs try to decrypt your DVD and therefore interfer with each other. If you have CloneDVD, you don't need DVDDecrypter at all, as AnyDVD will remove the protection and CloneDVD will transcode your movie data. If you don't use CloneDVD, try deactivating all DVDDecrypter options that deal with removing copy protections, since this is AnyDVD's job. You might also want to consider using a different burning/transcoding tool, such as DVDShrink.
     
  5. sheep

    sheep Well-Known Member

    Maybe this helps:
    From the anydvd changelog:
    ......
    - Note: To use DVDDecrypter with AnyDVD set I/O Model to SPTI or ElbyCDIO.
    Set CSS Cracking method to none. Disable checking for structure
    protection.
    .............
     
  6. LzD

    LzD Member

    Thanks for the replies.

    The only reason I use DVD-Decrypter is cause i got used to that program over the last years and because it allows me to just rip the files I want (instead of the whole DVD). Removing CSS is deactivated though as AnyDVD does this.
    So far I have not found a ripping software which is on par to DVD-Decrypter, but in case anyone can recommend one feel free to do.

    After searching the AnyDVD-Logs I tried some more stuff and found a way to get rid of the error messages.

    Somehow AnyDVD continously scans my DVD-drives and when it scans a drive which has no disk inserted the error in the DVD-Decrypter logs shows up. (thats the way I interpret the logs)

    After deactivating AnyDVD for the burner or putting a disk in the drive everything seems to work fine.

    I guess I´ll just switch to SATA-drives next month as I think my IDE-controller is responsible for this mess.

    AnyDVD-log entry : (Log is full of those)

    debug: scan_drives_thread WaitForSingleObject timeout 2000!
    debug: scan_drives_thread timeout 2000!
    debug: Drive F: real max_transfer_count = 31, nobypass 0!
    debug: open_drive F: TOSHIBA ODD-DVD SD-M1802 10/24/03
    debug: active
    debug: medium state: 0
    debug: Sending Patchlevel 1
    debug: Drive G: real max_transfer_count = 31, nobypass 0!
    debug: open_drive G: _NEC DVD_RW ND-2510A 05012700
    debug: active
    debug: medium state: 2
    debug: ready

    In case anyone has an idea feel free to post.
     
  7. PIGSgrame

    PIGSgrame Well-Known Member

    I personally would prefer one program doing all the decryption. I am quite sure that DVDDecrypter cannot handle all the protection schemes that AnyDVD is able to handle, so I would leave the whole work for AnyDVD. But if you insist on using DVDDecrypter, maybe disabling some of AnyDVD's features actually does help.

    The problem is that ripping alone won't be enough. Because blank Media have a smaller capacity than original disks, you will need a trancoding tool in most cases. Apart from DVDDecrypter, you can try Shrink (which I've linked above), but also Nero Recode which is part of the Nero suite, or CloneDVD (which achieves best results together with AnyDVD). I am sure there are more transcoders, some of which might also be freeware such as Shrink.
     
    Last edited: Jul 28, 2007
  8. sheep

    sheep Well-Known Member

    ImgBurn is also like dvddecrypter. It is free, from the same developer but doesn't support CSS removing and so on. But for this you got anydvd.
     
  9. LzD

    LzD Member

    AnyDVD handles all protection-related stuff (except for some strange DVDs).

    All DVD-Decrypter does is copying the files I select.

    I´ll give IMGBurn a try.
     
  10. LzD

    LzD Member

    Unfortunately IMGBurn only creates images (the name should have made me suspicious about that :D) and doesnt have a file-rip-mode.

    I did some more tests and found out that DVD-Decrypter will crash the PC on program start when all drives are empty and AnyDVD is activated. It just keeps on searching for SCSI/Atapi devices, cannot be closed and messes up the IDE-bus. When I deactivate AnyDVD everything works fine, but thats not an option.

    Maybe its really time to use another ripping software, unfortunately there doesnt seem to be one which is even close to the vast amount of options in DVD-Decrypter.

    AnyDVD´s inbuilt Ripper doesnt allow any advanced stuff and simply rips the full DVD while other tools like DVDFab Decrypter let me select the PGC i want to rip but have no file mode.

    All I want is to select the VOB-files I want to rip and get some feedback on the ripping process so I guess I will keep on searching.
     
  11. bilbo65

    bilbo65 Well-Known Member

    CloneDVD2 and AnyDVD for SLs or CloneCD and AnyDVD for DLs.....
     
  12. LzD

    LzD Member

    Problem solved.

    The driver of the JMicron IDE-Controller on the Gigabyte P35-DS4 was responsible for the whole mess. After changing it to a default Two-Channel IDE-Controller in Windows (and losing 2 SATA-ports) everything is working flawlessly.

    The problem did not only occur in DVD-Decrypter but also in CloneDVD, just in case anybody has similar error symptoms.