Amazon Prime (Netherlands)

Discussion in 'AnyStream' started by sukafido, Sep 27, 2020.

  1. sukafido

    sukafido Member

    On the Amazon Prime in Netherlands the `Downloadables` button is grayed out when trying to download a season.

    Already tried:
    - Rebooting
    - Restarting application
    - Logout and login again
     

    Attached Files:

    Last edited: Sep 27, 2020
  2. Lenka Utsugi

    Lenka Utsugi Active Member

    Restart the program, Try Again. It solves my problem.
     
  3. sukafido

    sukafido Member

    Already tried that multiple times... I think the problem is because the UI is different in this country.
     
  4. sukafido

    sukafido Member

    Hmm, looks like switching the Region in settings from `Other` to `Germany/Austria` fixed the problem!
     
  5. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    That's very odd, other should suffice. I'm (in belgium) subscribed through Amazon UK and i have to use "other". Maybe in your case it's because you're a neighbouring country to Germany and Belgium is closer to the UK. But it still doesn't make sense that way. Other should be the way to go here. Maybe @Prospere can explain this.
     
  6. Prospere

    Prospere RedFox Development Team

    No...

    But! The region setting in AnyStream mostly is used for selection of proper url to go to. @sukafido where are you going to when in a browser? I mean is it primevideo.com or amazon.blablabla.com?
     
  7. kaosnews

    kaosnews Member

    @Prospere it's primevideo [.com] (for Dutch Amazon). Disabled my DNS proxy and tested this.

    @sukafido you really should use a DNS service so you can use the US Amazon which got a lot more content.
    US Amazon - 24329 movies and 2828 TV series
    NL Amazon - 1335 movies and 309 TV series
     
  8. Prospere

    Prospere RedFox Development Team

    Did you try AnyStream with DNS proxy disabled?
     
  9. kaosnews

    kaosnews Member

    Yes, but I know realize that my respond was not correct (sorry!). I use an US account here in the Netherlands. So when I disable the DNS I get the 'Traveling abroad' content, but not the Dutch content.
    You can change the region when you go to primevide. com and I think you will see the Dutch content... but still not really sure.
    Sorry about this (answered a question for someone else, story of my life...) - think @sukafido could give the correct information.
     
  10. sukafido

    sukafido Member

    Using
    Code:
    primevideo.com
     
    Last edited by a moderator: Sep 28, 2020
  11. Prospere

    Prospere RedFox Development Team

    Well, in either case a log file would really help.
    Since you cannot download, simply go to File->Create log file and upload it here.
     
  12. kaosnews

    kaosnews Member

    I have the same problem now. On primevideo I see the blue playbutton, on Anystream it's visible for a second and then it's gone. The download option is not there. Strange is that is sometimes works... don't know why. Region is 'Other'
    Part of the error log:

    Code:
    00:05:00.744 - [Notice] WCJS: AAC:GP: no props: [0]
    00:05:00.774 - [Notice] WCJS: Page is Primevideo
    00:05:02.054 - [Debug] Page timed out, finalizing manually
    00:05:02.054 - [Debug] QWE:event:documentLoaded(true).
    00:05:02.089 - [Debug] QWE:event:documentLoaded(true).
    00:05:39.239 - [Debug] QWE:event : documentLoadStarted. URL: https://www.primevideo.com/storefront/home/ref=atv_nb_logo
    00:05:40.087 - [Debug] QWE:event:documentLoaded(true).
    00:05:40.302 - [Notice] WCJS: AAC:GP: no props: [0]
    00:05:40.318 - [Notice] WCJS: Page is Primevideo
    00:05:41.402 - [Debug] QWE:event : documentLoadStarted. URL: https://www.primevideo.com/search/ref=atv_nb_sr?phrase=jiskefet&ie=UTF8
    00:05:43.540 - [Notice] WCJS: AAC:GP: props [2]
    00:05:43.575 - [Notice] WCJS: Page is Primevideo
    00:05:43.578 - [Debug] QWE:event:documentLoaded(true).
    00:05:43.767 - [Error] PBR retrieval error.
    00:05:47.315 - [Debug] Reloading the page due to PBR error.
    00:05:47.321 - [Debug] QWE:event : documentLoadStarted. URL: https://www.primevideo.com/detail/0NLSEVR2B4HM6QPF03A7H6I60G/ref=atv_sr_def_c_unkc__9_1_9?sr=1-9&pageTypeIdSource=ASIN&pageTypeId=B086Q1FR6Z&qid=1601405874
    00:05:49.204 - [Notice] WCJS: AAC:GP: props [2]
    00:05:49.223 - [Notice] WCJS: Page is Primevideo
    00:05:49.396 - [Error] PBR retrieval error.
    00:05:49.543 - [Debug] QWE:event:documentLoaded(true).
    00:05:51.808 - [Debug] Reloading the page due to PBR error.
    00:05:51.814 - [Debug] QWE:event : documentLoadStarted. URL: https://www.primevideo.com/detail/0NLSEVR2B4HM6QPF03A7H6I60G/ref=atv_sr_def_c_unkc__9_1_9?sr=1-9&pageTypeIdSource=ASIN&pageTypeId=B086Q1FR6Z&qid=1601405874
    00:05:53.723 - [Notice] WCJS: AAC:GP: props [2]
    00:05:53.744 - [Notice] WCJS: Page is Primevideo
    00:05:53.915 - [Error] PBR retrieval error.
    00:05:54.057 - [Debug] QWE:event:documentLoaded(true).
    Update: after refreshing and restarting it's now working again... weird!
     
  13. Prospere

    Prospere RedFox Development Team

    This is a known problem and is related to how QtWebEngine processes the page. Although, we have very little control over this, we are looking into it in order to find a solution.