3319a anomaly

Discussion in 'AnyDVD HD (Blu-ray issues)' started by thedatman, Mar 11, 2008.

  1. thedatman

    thedatman Well-Known Member

    My older RPTV only has one 1080i input. I have a component video switcher . I was able to run my resolution at 1920x1080 for all applications both windvd for dvds(480p) and the newer versions of PDVD for BD the aspect ratio was perfect, judging from the size of the black bars in a 2.32:1 film.

    When I installed 3319a so I can play rips. In a 1920x1080 resolution setting the picture was very small. I lowered the resolution to 1280x768 and that is very close. The black bars are a little too big. 1280x720 might be perfect but that resolution setting is not compatible with my set.

    1280x720 is the correct setting for a 720p display and my set does not do 720p, it up converts to 1080i.

    Why did the newer versions work perfect a 1920x1080 and is there a way for me to change a setting in 3319a to work at 1920x1080, that would be my best option. Second option is to do a custom resolution. It was a little tricky. So far I’ve been unsuccessful.
     
  2. YaniD

    YaniD Well-Known Member

    I get the same issue with 3319a under XP with 8600GT: it windowboxes video to approx 1600x900 and is unuseable for full 1920x1080p presentation. I think it is similar to the issue some were having with ATI graphics cards until a registry setting was changed, but I haven't heard of a registry change for Nvidia.

    I have to use either 2911 or 3516 to overcome the issues (3104 might also be okay but I have other issues with that), but they have their own individual problems.

    This makes it very difficult to playback some titles.

    If BD+ gets cracked, then there should be more playback flexibility, but until then...
     
  3. Octavean

    Octavean Well-Known Member

    I was running 3104a OEM from LG. I ran an HD DVD disc and was prompted with a critical update which turned out to be 3319.0 with no letter suffix. So if 3319a has an issue perhaps there is a minor step back that you can take to 3319.0,…. which can play from HDD?
     
  4. thedatman

    thedatman Well-Known Member

    I'm running ATI 2600 series. The card plays reg dvds fine with windvd but if you know of something I can try. I don't know of an registry change I can do.
     
  5. JimSa

    JimSa Well-Known Member

    I ran into something similar a while ago on my 30" DELL monitor. Build 3104 (not 3304) used the full resolution, but 3304 and 3319 messed with resolution. This issue is since fixed in 3370, but then you have to forego BD+ playback with that build...

    I'm not sure this will help because it's been a while and it's all kind of sketchy, but I seem to recall the reg key HKLM\Software\Cyberlink\PowerDVD\UI_FullScreenResolution and possibly UI_InitSmooth having some influence over this behavior. Note: he HKLM full screen key is different the HKCU key, which keeps track of whether you want to run in full screen mode.

    Like I said, I *think* this key might have solved my issue, but I was going back and forth between 3-4 versions of PDVD and messing with all sorts of reg keys, so I'm not 100% certain. Anyway, it might be worth a shot... Make sure to export backups of your PDVD keys from regedit first.
     
  6. YaniD

    YaniD Well-Known Member

    The windowboxing with ATI and high resolutions wasn't anything to do with PowerDVD IIRC, but was a result of internal limiting to assist with complex post-processing. I think the workaround was to change a particular resolution setting in the registry to about 2.5million. You should be able to find more information on AVS Forum in the HTPC subforum, under the ATI 2x00 thread.

    I only mention it, because the effects are similar to what I experience with PowerDVD 3319a: as if a parameter is not set high enough, so downscaling occurs.

    Even correcting this registry setting for ATI may have no effect on PowerDVD 3319a. I don't run ATI now, so can't really comment on ATI/PowerDVD interaction.

    If you are still experiencing windowboxing with ATI and PowerDVD 3319a after fixing the registry, then the only options are to go higher or lower than 3319a, but they have their own issues. I think I even had issues with versions between 2911 and 3319a, but YMMV.

    As I said, 3516 and 2911 don't have the windowboxing issue on my particular setup.
     
  7. thedatman

    thedatman Well-Known Member

    reg key HKLM\Software\Cyberlink\PowerDVD\UI_FullScreenResolution and possibly UI_InitSmooth having some influence over this behavior. Note: he HKLM full screen key is different the HKCU key, which keeps track of whether you want to run in full screen mode.


    I'm interested in trying this but I need more info on how to do it
     
  8. JimSa

    JimSa Well-Known Member

    Start Menu Run regedit
    Expand to HKEY_LOCAL_MACHINE\Software\Cyberlink\PowerDVD
    Right click on on PowerDVD and export to save backup
    select a file location, type filename, and click OK
    In the right hand pane double click on UI_FullScreenResolution
    Set to 0, click OK
    Run PDVD to see if it makes a difference.
    If the value was already 0, set to 1 to see if it makes a difference.
    Similarly you can mess with the initsmooth key

    You can set it back the orginal value the same way. If you mess things up under PDVD double click the exported file you saved earlier to restore that portion of your registry.

    I know this had an affect for me, but it was a while ago when I was messing with this sutff. YMMV
     
  9. YaniD

    YaniD Well-Known Member

    You're a champ: with 3319a and UI_FullScreenResolution=0 I get windowboxing, but if I set it to 1, I get full screen width presentation.

    Only problem is that changing the setting to 1 causes the transition from windowed to full screen or vice versa to become slow: but I'm prepared to live with that for full screen width with 3319a.

    I tried changing UI_InitSmooth, but it didn't appear to have any effect, so it's back to the default.

    UPDATE: This method doesn't actually work in the way expected; starting off with a 1920x1440p72 desktop and windowed PowerDVD, all is as it should be, but when the PowerDVD window is switched to fullscreen, the desktop is now changed to 1600x1200p60; when changed back to windowed display, the desktop is returned to its original resolution and refresh.

    So, this UI_FullScreenResolution=1 method is not a satisfactory solution for me: I really need it to fit the material to the desktop, not the desktop to the material. Back to the drawing board for 3319a.
     
    Last edited: Mar 16, 2008
  10. thedatman

    thedatman Well-Known Member

    Thanks JimSa I'll give it a try tomorrow. I'm in the middle of a rip. I'll post if it works.
     
  11. JimSa

    JimSa Well-Known Member

    Aah. It's starting to come back to me. I ran into similar behavior but it wasn't really a problem. My display is normally 2560x1600 (1.6). It seemed that PDVD wanted to get to a reasonable resolution/aspect, but wasn't sure how to do it... It ended up setting the the display to 1920x1200 (keeping 1.6). Even though I would have preferred that it flip to 1920x1080 to go full screen, 1920x1200 was satisfactory. I ended up with a slight letterbox affect, which was a heck of a lot better than a four sided window box, and the resolution was still > HD resolution.

    I think this solution worked for me only because my resolution was so high to start with. Since I only have 1-2 BD+ titles that I've already watched and not planning to watch again soon, I've since ended up moving 3370. Something to consider... (keeping fingers crossed for the crack)

    One other possibility is to use one of those video utilities that gamers use (I'm blanking on the names) that switch resolution based on application/exe name during application startup. I'm guessing that if your resolution is in 1920x1080 that you don't get the window box because it's a res that PDVD wouldn't think it needs to change... Just a thought.
     
  12. andy o

    andy o Well-Known Member

    The fix for windowboxing with ATI HD 2000 cards is here

    You'll have to add VForceMaxResSize in the registry key for your ATI card, not PowerDVD's. You can find where the key is in CCC, in the information tab. Then restart your PC.
     
  13. thedatman

    thedatman Well-Known Member

    well my system has no UI_FullScreenResolution key. the bottom line is the black bars are just a little bigger than they should be and it works.

    I think I'm going to leave it alone. Nero Showtime and windvd7 work perfect. So the problem is clearly with 3319a.