Windows XP SP3 won't install with the GameWatch service running in the background...

Discussion in 'GameJackal' started by Entity, May 7, 2008.

  1. Entity

    Entity Well-Known Member

    ...and I can't get the bl**dy thing to turn off either. :bang:

    Has anyone managed to install XP SP3 without uninstalling GJ first?

    And if so, please tell me how! :bowdown:
     
  2. Webslinger

    Webslinger Retired Moderator

    I'm not sure what Gamewatch is. Are you sure that has anything to do with Game Jackal?

    I didn't have Game Jackal running and installed SP3 with ease on two computers yesterday.
     
  3. evlncrn8

    evlncrn8 Well-Known Member

    i may be totally wrong, but i think gamewatch was some plugin / part of game jackal enterprise at one time...

    edit: did some googling and found this.... im not posting the source, as it was quite dubious.. and no, i didn't download it...

    "1) The Game Jackal client application
    2) The Game Jackal service (optional)
    3) The Game Jackal EE plug-in
    4) The Game Watch plug-in
    5) The Game Jackal Manager (GJ Manager)
    Components 1 to 4 are collectively known as the client components (all these are automatically installed with the client EE installer), with the GJ manager known as the server component."

    so i guess its something to do with enterprise version, perhaps the older maplom one..
     
    Last edited: May 7, 2008
  4. mad_fr34k

    mad_fr34k Well-Known Member

    yeah guess it was a plugin, this is in the change logs

    Release v2.8.17.485 - release
    - Minor changes to support the new Game Watch plugin.


    ...the powers of google search!
     
    Last edited: May 7, 2008
  5. Webslinger

    Webslinger Retired Moderator

    So, I guess uninstall the plugin, and then try a SP3 update.
     
  6. evlncrn8

    evlncrn8 Well-Known Member

    and plugin isnt quite the same as 'service' too, just to also point that out...
     
  7. Entity

    Entity Well-Known Member

    Turns out I had to uninstall gamejackal, manually turn off the gamewatch service (as the turn off batch file they installed did chuff all), go through the system registry deleting all keys the uninstall had left behind, delete all the files the uninstall had left behind and numerous reboots later, XP SP3 installed fine.

    Oh the joys of running a cybercafe!
     
  8. matthew

    matthew SlySoft Team Member

    Did you try simply stopping the service?
     
  9. Entity

    Entity Well-Known Member

    I tried stopping the service via the batch file (which did nothing)

    I tried going into services via the admin tools panel - did nothing.

    I uninstalled GJ and even after reboot the service was still there - still killed XP SP3

    So like I said I had to manually go through the registry and delete everything to get rid of it before the SP3 would install ok.

    Might be just me - computers don't tend to like me much :(
     
  10. matthew

    matthew SlySoft Team Member

    Ok... I was a bit confused when I read your original post. I thought you were talking about the GJ service application.

    Game Watch is a plugin that monitors the apps being launched. This plugin should shutdown when either GJ is shutdown or the it is shutdown via the start menu.

    I will do some tests and get back to you.
     
  11. Entity

    Entity Well-Known Member

    The problem is though, due to the gamejackalserv.exe running in processes, if you click on EXIT GAMEJACKAL on the menu from the icon in the system tray, it immediately reloads its'self. The only way of exiting the prog permanently is by killing the other task first.
     
  12. Entity

    Entity Well-Known Member

    Oh, I suppose I should mention to all you non-slysoft guys reading any of this, I am using the Enterprise Edition of GJ in a cybercafe environment. If you are using the PRO version, you shouldn't have to worry about a thing.

    Maybe I should edit the subjectline?
     
  13. mad_fr34k

    mad_fr34k Well-Known Member


    Do you know that you can delete a service through the command line?

    Click start, then run type in CMD

    a black window opens up

    type in "sc delete" without the quotes it give an explanation of what it does just incase you dont trust me :d

    for this to work you need to know the actual service name, not the name that is displaed strait away in services, find the service that you need, double click on it or right click and properties.

    On the new window that opens, on the general tab it says "Service Name: ****"

    then it says "Display Name: ****"

    notedown the service name exactly how it is written.

    now go back to your command window / reopen it if you closed it and type

    "sc delete *****" replace the stars with the service name exactly!

    for example if i was to remove the Volume Shadow Copy Service i woud type in

    "sc delete VSS" (without quotes) it would then delete it!

    hope this might help!
     
  14. Entity

    Entity Well-Known Member

    That's great. Thanks.
     
  15. matthew

    matthew SlySoft Team Member

    Ok. There seems to be a number of problems here.
    1) First you need to stop the service. This is important otherwise the core application will continue to reload.
    2) Step 1 should have shutdown the application... if not you can terminate the task "GameJackal.exe".
    3) Finally, to be sure Game Watch is shutdown. Use the option from the start menu to shutdown GW.