Windows 10 Creator's Update messed up ReClock

Discussion in 'ReClock' started by MonarchX, Apr 10, 2017.

  1. andy o

    andy o Well-Known Member

    I think people who are seeing this "fixed" when switching to 24Hz instead of 23Hz in their graphics card are just experiencing a happy coincidence. ReClock reads the display refresh as 24.000, so it adapts the media speed for that refresh. But the graphics card will most likely not be refreshing at exactly 24.000, so the real fix for now it's just to use windowed mode.
     
  2. Thomas Wilms

    Thomas Wilms New Member

    Ok, what do I have to do under 1703 to make it work again? I only use Reclock and MPC-HC.
     
  3. andy o

    andy o Well-Known Member

    The problem discussed in this thread has to do with madVR's fullscreen exclusive mode. The fix for that is to switch to windowed mode and clear timings database in ReClock. What problem are you having?
     
  4. andy o

    andy o Well-Known Member

    @James do you think it could be possible/feasible to add an option to input manually the refresh rate of the display? That would be an acceptable workaround for most people, if ReClock can't detect the refresh in the new Windows 10 version, which seems to have messed up a bunch of exclusive mode stuff, not only madVR/ReClock but games as well.
     
  5. Thomas Wilms

    Thomas Wilms New Member

    Four week ago I updated my Win10 to 1703. From that point on Reclock didnĀ“t work with MPC-HC anymore (red-green blinking icon, syncing a 23.976fps movie to 25fps). I downgraded to 1607 and everything was ok again. Can someone confirm that Reclock with MPC-HC is working under 1703?
     
  6. Syst3mSh0ck

    Syst3mSh0ck New Member

    Try installing PowerStrip 3.9 to see if ReClock reads the video hardware refresh rate data correctly. It seems that Microsoft deprecated or broke the current API being used in Windows 10 Creators Update.
     
  7. el Filou

    el Filou Well-Known Member

    Finally updated to Creators Update and ReClock 1.9.0.6 works fine.
    I'm using madVR in Windowed mode with D3D11 presentation and it's perfect (GeForce 1050 Ti, driver 385.41).
     
  8. hadar

    hadar Well-Known Member

    Btw fullscreen exclusive mode with ReClock is working again in redstone 3.
     
  9. karoloydi

    karoloydi Active Member

    I have similar problem. It started after a failed Windows Creators update. Every time I was restarting it would ask me to update but it would never update. I noticed at around that time that reclock could not lock on the correct refresh rate and was dropping a lot of frames. I then went to windows update and managed to update to Windows creators update. I update Nvidia drivers as well but did not fix it.
    This is the solution I found:
    I disabled the VBA script that I had to automatically change the refresh rate. I then cleaned up video clock timings database. Then I selected the correct refresh rate manually (instead of automatically through a vba script). I had 0 dropped frames after that. Before I had one every 5 seconds.
    I then changed back to vba again and the problem came back again. When it is dropping frames it is detecting the refresh rate as 24hz instead of 23.976.
    I think it was AnyDVD automatic refresh rate switch that is causing it.

    Edit: I tried with marVR as well. Exactly the same thing. It starts as 23.976 after I clean up the timings database. The first movie I play after clean up is not that bad. Then every time I open a new movie the refresh rate gets higher and higher until it reaches 24.00. Then it stabilises there. But it skips so many frames it is unwatchable.
    I think the problem happens on the first few seconds when the refresh rate changes. Maybe reclock can start calculating at a later point to fix that.

    Let me know if I have an isolated problem or you all have similar problem.
     
    Last edited: Oct 13, 2017