Windows 10 anyDVD ejecting optical media

Discussion in 'AnyDVD HD (DVD issues)' started by 3illy, Sep 24, 2015.

  1. 3illy

    3illy New Member

    Hi there, I just upgraded to windows 10 from windows 7. I tried using my optical drive for the first time since the upgrade this evening. I inserted a blank dvd to back up some data and the drive kept ejecting the discs; explorer opens with a dialog "Insert a Disc" with a link beneath "Help me choose a disc". I found that after closing/disabling anyDVD, the aforementioned behavior resolved and I was able to make my backups.

    Windows 10 pro
    INtel i7 950@3.07ghz
    6gig ram

    Optical drive is an LG BluRay DVD burner model WH10LS30

    anyDVD version is 7.6.4.0

    Thanks for your help.
     
  2. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    Anydvd doesn't burn nor automatically (r)eject discs. Your problem is with your blanks/burner/burn software. What are using for brand and burn software?

    Verstuurd vanaf mijn Nexus 7 met Tapatalk
     
  3. Clams

    Clams Well-Known Member

    How do you know it was an upgrade?
    Nothing worth having is free.......
    -W
     
  4. 3illy

    3illy New Member

    I am just using windows explorer to write files to DVD or CD. I know anyDVD does not burn discs. I've been using it for 5 years now. What it does do, is attempt to scan any media inserted into the optical drive; hence this post. I never had a problem with my blanks, burner prior to windows 10 upgrade.
     
  5. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    You still need to say which brand of blanks you're using. But upgrading your OS doesn't break burning unless M$ screwed up their engine. That said, the windows burn engine never really was good. However just because the discs work previously doesn't mean that will keep working.

    Manufacturers shift production around constantly and quality for blanks can change from 1 batch to another.

    Verstuurd vanaf mijn Nexus 5 met Tapatalk
     
  6. 3illy

    3illy New Member

    I think you missed the fundamental statement in my original post. When I disable AnyDVD, it works. The media is fine.
     
  7. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    Pretty doubtful, probably a coincidence. Anydvd doesn't affect burning behavior. I have it running non-stop and neither CloneBD, CloneDVD nor IMGBurn get affected.

    So unless you post what brand and type you're using, I'm afraid we're at a standstill.

    Verstuurd vanaf mijn Nexus 7 met Tapatalk
     
  8. Clams

    Clams Well-Known Member

    You're absolutely right. A repeatable "coincidence" is no longer a coincidence.
    It sounds like a device driver conflict in Windows 10 with AnyDVD and something else.
    First - Try uninstalling and re-installing AnyDVD entirely.
    Failing that, you'll have to post up a logfile as per the "PLEASE READ" before you post" thread at the top.
    -W
     
  9. 3illy

    3illy New Member

    Clams, Chevron, Thanks for your attention in this matter. However, it seems to have resolved itself after my latest barrage of windows updates. :censored:
    FM.
     
  10. taft

    taft Active Member

    I have windows 8.1. When i got the invitation to upgrade to windows 10, i did some research first. I read windows 10 will not play dvds, even tho i have a dvd player program. I decided to wait until a fix was done on windows 10 because i was afraid that would affect ripping and burning dvds also. I have had no problem with any ripping any disc and burning, except for Love and Mercy. This is the first of dozens of discs that will not rip correctly. So if you are having problems with Anydvd and 10, i throw this out there for consideration -- that 10 will not yet play, as far as i know, discs.
     
  11. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    you read wrong. Windows 10 will read DVD's just fine, what Microsoft said was is that W10 will NOT read DVD's natively. They've removed the DVD player component from windows, you now need to manually install it from the windows store (paid, lousy app) or use your own third party solution. Not having a software player has absolutely nothing to do with either ripping nor burning.

    Install a software player in win10, and it'll play DVD's just fine.
     
  12. taft

    taft Active Member

    I worded that strangely. I said: "This is the first of dozens of discs that will not rip correctly." I meant: Dozens of discs have succeeded, except for Love and Mercy. That's the first one that will not rip entirely. Tried 2 different undamaged discs.
     
  13. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    what does that have to do with this

    or even the subject of this topic "ejecting discs".

    If you have ripping/decryption problems, you need to create YOUR OWN TOPIC and provide the ANYDVD LOGFILE as per instructions here:

    https://forum.slysoft.com/threads/please-read-this-before-you-post.52659/

    without that, we can't help you.
     
  14. Lance Summers

    Lance Summers New Member

    I have the same problem but since AnyDVD is not ripping or reading a dvd at the moment, no log file from it.
    1) I put in a DVD into ANYDVD on a fresh boot, goes in fine,
    2) I use DVDShrink to read the DVD into the computer. Goes fine.
    3) I then take the DVD out and put in a blank. This USUALLY goes OK but sometimes it will eject "Insert disc".
    4) I use Nero to burn a DVD. Usually goes fine but once in awhile I get a coaster (1 out of 40 or so-That is OK for me).
    5) I take the freshly burned DVD out and test it.
    6) I put in another DVD (ex: Scrubs S7, D2). It will usually eject and keeps ejecting until I do one of the following:
    A) Terminate Nero and wait for about 20 seconds.
    B) Terminate AnyDVD (Once the DVD goes in and stays, I can restart AnyDVD and it is OK then).
    C) Reboot the computer. (The DVD will be sucked in during boot and stays in).

    So, I did the following to confirm:
    1) Uninstalled Nero. DVD would still occationally auto-eject. (Placed DVD in drive, stayed, ejected it, put in a different one and it auto-ejected).
    2) Reinstalled Nero (Did not start it). Uninstalled DVDFab. Placed DVD in, it stayed. DVDShrink Read the DVD OK.
    3) Put in a blank, it stayed. Used Nero 9 to burn that DVD. Ejected and tested it.
    4) Placed a Different DVD into drive. It Auto-Ejected. So uninstalled Nero AGAIN.
    5) Placed the same DVD into drive. It stayed in OK, Ejected it.
    6) Placed yet another DVD into the drive. It Auto-Ejected!!!
    7) So at this point the only thing currently installed that I use for DVD's is AnyDVD. I uninstalled it.
    8) Placed 8 consecutive, different DVD's (non-blank) in the drive and they all stayed.
    9) Re-installed AnyDVD.
    10) First two DVD's stayed in, Third & Fourth were Auto-Ejected, Fifth stayed in.
    11) Once they Auto-Eject. I can usually wait 20 seconds or so and then get them to stay in.
    12) Re-installed Nero 9
    13) Back to DVD to rip stays in, 1st Non-Blank will stay in. Rip it. Insert blank, usually stays in (not always). Burn & test. Non-blank DVD inserted to rip. Usually will not stay in and even waiting 20 seconds will not work.
    14) I HAVE to shut down Nero and wait just a bit to get the Fresh non-blank DVD to stay in the drive.

    Conclusion:

    There is a driver conflict with Windows 10 and AnyDVD.
    I went into system-:>Device Manager and removed the DVD drives and rebooted. Drives reinstalled automatically. Problem still there.

    The problem is sporatic when Nero is not active but when Nero has just used the Drive, the problem is repeatable more often than not (again, nothing is 100 percent of the time).

    This leads me to believe that one of the drivers that watches when a DVD is put in gets an error code right away that, in-turn, causes the auto-eject.

    This could even be due to Windows 10 taking out the native DVD support and leaving the control hanging, therefore dependent on the software (like AnyDVD) to control all error handling. I am sure that some of the error codes were handled by windows before and not AnyDVD.

    Any unhandled exception will be returned to the Windows OS and therefore generate the Popup.

    The error code Unknown as it does not appear on the Windows 10 Popup:
    "Insert disc"
    "Please insert a disc into drive E:."
    "Help me choose a disc"

    The Help was totally useless.

    I use Amazon DVD's, Philips and Maxells as my blanks. The what make of blank DVD does not matter with this problem.
    The DVD drive is an LG Blueray player, DVD burner 16X (though I always burn at 8X)

    Hope this helps the developers figure this out because it is getting annoying having to shut down Nero to increase my chance of getting the DVD to stay in the drive (1 in 4 chance that it will not with Nero shut down).

    lance...
     
    Last edited: Nov 19, 2015
  15. Loonier

    Loonier Guest

    Last edited by a moderator: Nov 19, 2015
  16. Lance Summers

    Lance Summers New Member

    OK, I have three snippets with the info you requested:

    Hope this helps and thanks for the response.
    Lance
     

    Attached Files:

  17. Loonier

    Loonier Guest

    In the Filter Driver Load Order tool you have to click on your optical drive on the left, and then copy the info to Clipboard.
     
  18. Lance Summers

    Lance Summers New Member

    OK, so let's try this again.

    Lance
     

    Attached Files:

  19. Lance Summers

    Lance Summers New Member

    OK, got an E-mail from Slysoft:

    ================================================================================================================
    Dear Lance Summers,

    Thank you for your e-mail.

    If you are referring to blank media, AnyDVD is not involved at all in the burning process. It stays inactive when a blank disc is inserted.

    Best regards,
    Chris Gonzales
    --
    SlySoft Forum
    http://forum.slysoft.com/
    ================================================================================================================

    So you can see, the moderator did not fully read this thread. The problem is when a NON-Blank DVD is inserted and AnyDVD kicks in.
    Which means the developers are not looking at the ERROR handling path of AnyDVD.

    My own analysis (as shown above) points to the fact that the DVD drive generates a Disk-Changed error when a NON-Blank is inserted
    that is no longer handled by Microsoft (with the removal of their DVD Player Support). Why this is an error I have no idea.
    This Disk-Changed error is therefore passed to any utility that is in the drive handling chain (In this case, only AnyDVD is listed:
    See Previous post). And since AnyDVD is not handling that error either, the drive reacts to the Disk-Changed error by ejecting the disk.

    Another posibility is that this is a problem with the particular DVD drive??? One that is generating the error to begin with.
    I will swap out the drive for an LG Blu-Ray drive to see if the same things happen.

    Or maybe one of the updates to windows 10 will solve this problem, I don't know but since the problem is sporatic (not 100% of the time),
    it is unlikely that my issue will be resolved any time soon.

    I will post my results with the DVD drive swap. Lance
     
  20. James

    James Redfox Development Team Staff Member

    Please post an AnyDVD logfile (with a disc in the drive).