WASAPI Exclusive device setting keeps getting reset to <Default Device>

Discussion in 'ReClock' started by Shibble, Sep 6, 2020.

  1. Shibble

    Shibble New Member

    Using ReClock 1.9.0.7.

    It seems like since I updated to Windows 10 build 2004, any time I restart my computer this setting inside ReClock Configuration gets reset. I need it set to my "NVIDIA High Definition Audio" device since that's where my AV receiver is.

    Is there a file somewhere where ReClock stores its settings that I can make read-only, or is there anything else I can do to make this setting stick through reboots?

    LwBbtM9u_o.png



    EDIT:

    I may have a solution. I've found that the ReClock settings are stored in the registry under the key HKEY_CURRENT_USER\SOFTWARE\ReClock\Config. So I can simply set up ReClock the way I want with the config utility, export the registry key, make a batch file with the line "REG IMPORT [exported reg file]", and finally place a shortcut to that batch file in my startup folder (which is a pain to access in Windows 10, but that's another story).
     

    Attached Files:

    Last edited: Sep 7, 2020