Vista64 - No DVD Drive Detected!

Discussion in 'AnyDVD HD (DVD issues)' started by Sierra, Jun 1, 2007.

  1. Sierra

    Sierra New Member

    This program worked great when I was using XP. but now after using Vista64 for several months, I tried to load the new version of AnyDVD.

    It failed to install properly and provided the following WARNING!

    No DVD Drive detected!
    Possible reasons:
    1. You dont have a DVD drive, buy one. (I have two DVD Drives)
    2. You haven't rebooted your system after AnyDVD has been installed. Please restart your computer. (I've done this several times when performing new installs to get this to work).
    3. Your external DVD drive isn't powered. (It's on...)
    4. Prople initialising the AnyDVD Driver.. Try this..( I tried this several times)

    I also truned off AVG and I don't have any firewall settings to get this to work.

    Please advise how I can detect my DVD and verify if the Driver is installed. Or how to get this to work using Vista 64.

    Sierra
     
  2. Danger

    Danger Well-Known Member

    Have had this problem several time with the x64 version, haven't had it at all with the x32 version of Vista Ultimate.

    This is the solution I had to use when I was using Vista Ult.x64 and the only one that worked for me:
    http://www.adobe.com/cfusion/knowledgebase/index.cfm?id=328585

    This should only be used as a last resort tho.
     
  3. Webslinger

    Webslinger Retired Moderator

  4. James

    James Redfox Development Team Staff Member

    Which version?
     
  5. Sierra

    Sierra New Member

    For me to get my drives back on line, I had to follow this process:
    http://support.microsoft.com/kb/929461/en-us

    The upper and lower were AnyDVD Products.

    Which version? Let me try the new one now because It's deleted from my machine.

    After doing a uninstall lets see what is left in the Regedit file.
    HKEY_CLASSES_ROOT\.AnyDVDHD
    HKEY_CLASSES_ROOT\Local Settings\Software\Microsoft\Windows\Shell
    HKEY_CLASSES_ROOT\Wow6432Node\.AnyDVDHD
    HKEY_CLASSES_ROOT\Wow6432Node\Local Settings\Software\Microsoft\Windows\Shell
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\ComDlg32\OpenSavePidlMRU\AnyDVD
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.AnyDVD
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\RecentDocs\.AnyDVD
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.AnyDVDHD
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Wow6432Node\.AnyDVDHD
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Classes\.AnyDVDHD
    and many more... hmmm... it never really gets removed.

    Now lets follow Webslinger process:

    Only having one account on this PC, by default I should be the ADMIN.

    Lets download and install the latest version. AnyDVD & AnyDVD HD 6.1.6.0
    Turned off AVG Firewall and shut the whole program off.
    Installing program
    Why does it take so long to install?
    Reboot.. No
    When I do this, this is grayed out. I wonder why? Is it due to a Vista64 or becase I didnt reboot.

    What the hell... they are installed

    Lets reboot and see what happens.

    Rebooted and now the trial software is installed without any warnings.
     
    Last edited: Jun 7, 2007