Video license could not be processed

Discussion in 'AnyStream' started by ZeroLimit, Oct 9, 2020.

  1. ZeroLimit

    ZeroLimit New Member

    getting this from Amazon just started today
     
  2. RedFox 1

    RedFox 1 Super Moderator

    Not happening to me. So I really cant help. Maybe if more people are affected we will see what it is.
     
  3. Kamala

    Kamala Well-Known Member

    might help if you would include anystream log along with your problems.
    else... none probably can help.
    coz... it's not happening to me either. :p
     
    Aeneas72 likes this.
  4. Tanuki

    Tanuki Member

    Update.
     
  5. Phican

    Phican Member

  6. infinata

    infinata New Member

    Good day, I am seeing the issue as well. I am trialing your software, downloaded it for the first time today, and have used it for only 3 downloads (ever) in this first day of usage via Netflix, upon the first try on Amazon I too receive this same error mentioned above. I have tried different resolutions which all result in the same error.

    upload_2020-10-17_17-35-31.png

    LOG:

    06:13:41.754 - [Debug] Download completed. Finalizing output.

    06:15:42.465 - [Debug] Download channels disposed

    06:15:57.153 - [Debug] Playlist URL: https://pop-iad-2.cf.dash.row.aiv-c...564-8540-4347-bf04-13aabf6be8f2_corrected.mpd

    06:15:59.549 - [Notice] Multiple audio languages.

    06:16:05.554 - [Notice] Media type: TV Show.

    06:16:05.556 - [Debug] Downloader object created with specs:

    06:16:05.556 - [Debug] TitleSpecs:

    06:16:05.556 - [Debug] Title vendor: Amazon

    06:16:05.556 - [Debug] Target File Path: C:/00_AnyStream/The Boys Season 01 Episode 02 - Cherry.mp4

    06:16:05.556 - [Debug] Video URL: https://pop-iad-2.cf.dash.row.aiv-c...0564-8540-4347-bf04-13aabf6be8f2_video_12.mp4

    06:16:05.557 - [Debug] Audio URL: https://pop-iad-2.cf.dash.row.aiv-c...564-8540-4347-bf04-13aabf6be8f2_audio_192.mp4

    06:16:05.557 - [Debug] Subtitles:

    06:16:05.557 - [Debug] 1456 :

    06:16:05.557 - [Debug] Url : https://dmqdd6hw24ucf.cloudfront.ne...95/d7b8176a-b593-4a87-8599-4b963ba5c7c8.ttml2

    06:16:05.557 - [Debug] languageDescription : English [CC]

    06:16:05.557 - [Debug] languageName : en-us

    06:16:05.558 - [Debug] Aux info:

    06:16:05.558 - [Debug] httpHeader_Origin : https://www.amazon.com

    06:16:05.558 - [Debug] httpHeader_Referer : https://www.amazon.com/gp/video/detail/B0875L45GK/ref=atv_dp_season_select_s1

    06:16:05.558 - [Debug] httpHeader_X-Amz-Url-Set-Id : 18552-1f4d9013-de87-4b55-880d-1bb070ffefaf

    06:16:05.558 - [Debug] urlParam_amznDtid : AOAGZA014O5RE

    06:16:06.386 - [Error] Error updating view progress: {"message":{"statusCode":"ERROR","timestamp":1602970467,"body":{"code":"CDP.InvalidRequest","message":"Invalid request 2020-10-17T21:34:27.136Z 3bee8152-ce2a-4828-a606-6e81f919ddd4. See service log"}},"signature":"NotAvailable"}

    06:16:22.785 - [Notice] Download process was aborted.

    06:16:22.788 - [Debug] Download channels disposed
     

    Attached Files:

  7. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    Next to the download limit, there's one other trigger I've seen cause this. Before you click 'download' on an actual episode, does the episode summary list show any episode that's not on the actual season page? (As in showing S02e01 for example, on the summary list of season 1!)

    Other than that click menu - create logfile. The debug log is 'less useful'.

    Sent from my Pixel 3 XL using Tapatalk
     
  8. Prospere

    Prospere RedFox Development Team

    Make sure your region is set correctly.
     
  9. infinata

    infinata New Member

    --
    Yes, I noticed that an episode for the following season was listed first, which I found odd but did not attribute to this being a cause, Log already attached to my original post.
    upload_2020-10-17_19-28-23.png
    P.S., thank you for the quick response!
     
  10. infinata

    infinata New Member

    ---
    I'm running in the US, and settings are set for US as well, thanks for the suggestion!

    upload_2020-10-17_19-31-49.png
     
  11. Prospere

    Prospere RedFox Development Team

    This may happen when a link/button is clicked on Amazon page prior to it having been fully loaded.
     
    karaokeamerica likes this.
  12. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    It does, but it's not the only trigger! See my post above (#7) and confirmation (#9 episode S02E04 is shown above S01E01).

    For some reason AnyStream on the Amazon side, sometimes shows episodes at the top on the playlist summary from a different season above the ones from the season page it's on. This WILL trigger the same error (sometimes multiple times in a row)! The only fix is to jump between seasons or restart until only the correct ones are listed in the summary episode list.

    Just hadn't had the time to report this odd behavior.

    Sent from my Pixel 3 XL using Tapatalk
     
  13. testiles

    testiles Well-Known Member

    I've seen this too, but haven't gotten an error generated from it yet.

    I thought it was odd too and was wondering where that episode came from as it was definitely not part of the Season the list was for.


    T
     
  14. infinata

    infinata New Member

    Based on the comments I tried by closing down the app; reopened and proceeded to Amazon for the same show, when the show is shown on the web browser it defaults to season two, I select season 1, select the download button and it showed a different episode from season 2 in the list for season 1 download list this time around.
    With the app still open, I selected season 2, then used the Apps back button to get back to season one without clicking on any links in the website. At this point I clicked on the download button and was presented the proper list of season 1 without any rouge episodes from other seasons. The download for the episode proceeded as expected without any errors.

    IMHO, this may be a link issue that "Prospere" had mentioned and is the reason why I used the back button as apposed to clicking back to season 1 in the drop down list within the website. I have not tried to reproduce and test further at this point. Will update with further findings during my trial.

    Thanks for the help all!
     
  15. Prospere

    Prospere RedFox Development Team

    @infinata This is exactly the issue I was referring to. It is known but since it was not seen very often it was assigned a lower priority than other stuff. It will be taken care of soon.
     
    Aeneas72 and whatever_gong82 like this.
  16. BiTs2000

    BiTs2000 Member

    Getting it from Netflix
     
  17. BiTs2000

    BiTs2000 Member

    That is what mine is saying. Uninstalled and used the driver that was given in the for forums. Still doesn't work.
     
    Last edited by a moderator: Oct 20, 2020
  18. Prospere

    Prospere RedFox Development Team

    Please, attach the astlog file, don't copy and paste stuff.
     
    Aeneas72 likes this.
  19. zero269

    zero269 Well-Known Member

    So, I'm seeing my first "Video license could not be processed" error message that would not resolve after restarting the program.
    I had just started on Season 2 for Knight Rider and that's when it happened.
    I noticed a Season 1 episode at the top for Season 2 if that matters.
    I went to File > Create log file... after clicking OK on the error message and attached the log file.
    I've moved on to Season 3 for now... :D
     

    Attached Files:

  20. Prospere

    Prospere RedFox Development Team

    Thanks for the log!