Unable to get embedded subtitles to play (Netflix)

Discussion in 'AnyStream' started by critterlovr, Oct 12, 2020.

Tags:
  1. critterlovr

    critterlovr Member

    Hey folks, I'm unsure if this is something I'm doing wrong or not.

    When I chose my show to download (The Witcher, Ep 1), I selected "Store subtitles as embedded".

    When I load this episode to iTunes, and I choose either Subtitles: Auto (Recommended), or Subtitles: English, it does not show the subtitles on the actual episode.

    Help please? I'm currently on the trial version, if that makes a difference. Thank you!
     
  2. Mirai

    Mirai Active Member


    Trial Version should not have with that to do. I can test by if I get same problem if more get the same problem that are a bugg in ANYStream
     
  3. Prospere

    Prospere RedFox Development Team

    Or iTunes may have limited or no support for the given subtitle format.

    @critterlovr Have you tested it with other players? VLC, for instance, or MPC?
     
  4. critterlovr

    critterlovr Member

    @Prospere - no I have not. I'm not overly technical on this stuff, but I am happy to try to download one of those and see.

    If it matters:
    I did try playing it in Windows Media Player, and it also did not have the subtitles.
    When I tried Windows Movies & TV, the Subtitles menu gave me an option to "Choose subtitle file". If I click it, it then allows me the option to upload from a location on my drive.

    In a nutshell, it doesn't feel like the Embedded Subtitles is working as it should. Unfortunately, I'm one who needs Subtitles on as much as possible due to a slight hearing problem.
     
  5. critterlovr

    critterlovr Member

    @Prospere - VLC does show the Subtitles, which is great! However, it doesn't solve my ultimate problem as we stream all our movies through AppleTV (iTunes).
    When I use AnyDVD to rip movies, I'm able to embed the Subtitles into those which appear perfectly in iTunes. Is this perhaps a bug in AnyStream?
     
  6. Sledgehamma

    Sledgehamma Member

    Playback via iTunes on the ATV is extremely limited. I’d suggest using a third party app for this like Infuse (highly recommended) or MrMc (Kodi) or Plex.
    If you can, also post a mediainfo (mediaarea.net/en/MediaInfo) so we can see if it’s really a bug or an iTunes problem (I assume the latter).
     
  7. critterlovr

    critterlovr Member

    @Sledgehamma - I will look at Infuse, thank you. Does Infuse typically work through AppleTV, or is it completely separate? I haven't looked at it yet...maybe my question will be easily answered once I do.

    I "think" I ran the mediainfo correctly (I left everything default and opened the video in question). Is this what you're looking for?

    upload_2020-10-12_8-59-28.png
     
  8. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    At the bottom you'll see "First text stream", that's your subtitle track so it is very much added. The problem is with the playback software.
     
  9. critterlovr

    critterlovr Member

    @Ch3vr0n - great thanks for confirming that.

    Does anyone happen to know if I need only the Infuse software, or do I also need the aTV Flash as well to do be able to stream movies through Apple? I'm ok with getting both of them if needed, just don't want to be buying more than I need is all. :)
     
  10. Sledgehamma

    Sledgehamma Member

    Just download the infuse app and you are good to go :)
     
  11. critterlovr

    critterlovr Member

    Thank you to everyone! You've all been awesome and gentle with this techno-noob.
     
  12. albino

    albino Active Member

    If you're using AnyStream with embedded MP4 subtitles you could try using the external subtitles option and then muxing them into an MKV with MKVToolNix, that should work with your device.
     
  13. Prospere

    Prospere RedFox Development Team

    @critterlovr I wouldn't say it is a "bug", rather lack of a feature. There are several formats of storing embedded subtitles. The method we are using appears to be problematic for the software you mentioned. We are aware of this fact and addition of other methods is on the list.
     
    Aeneas72 likes this.