UHD Untertitel Probleme

Discussion in 'CloneBD (de)' started by kufo, Apr 8, 2018.

  1. kufo

    kufo Well-Known Member

    @Reto Bei fast allen bearbeiteten UHDs habe ich Probleme mit den Untertiteln. Im CBD Vorschau Player kann ich die behaltenen UT ein und aus schalten. Im Disc Menü auf dem Player geht das nicht. Bei manchen Filmen reicht es eine ABGEWÄHLTE UT Sprache zu wählen, bei anderen muss ich auf Deutsche UT wählen um sie abzuschalten. Teilweise sehr nervig. Das Problem besteht sowohl auf der X Box One S als auch auf einem Panasonic Standalone Player ( Bei einem Bekannten getestet ) Zuletzt hatte ich das bei Planet der Affen - Survival. Log Datei angehängt
    Was bedeutet eingebrannte UT, wenn die Option nicht in CBD verfügbar ist? Wenn ich UT auswähle, dann nicht um sie permanent zu sehen, sondern um sie bei Bedarf einzublenedn. Hat das Problem sonst keiner???
    Film wurde auf BD-DL Größe geschrumpft. Könnt ihr euch das mal ansehen?
    Danke vorab.
    kufo
     

    Attached Files:

    D300 likes this.
  2. birgitt2404

    birgitt2404 Well-Known Member

    Hab das ja auch berichtet wegen forced Untertitel. Dies sind erst nach dem Einschalten der UT am Player UB900 sichtbar. Was ja ohne gehen müsste. Es muss doch einfach sein für die Entwickeler, das zu beheben,mit einem Haken für Untertitel permanent sichtbar zu setzten.
     
    kufo likes this.
  3. Klausser

    Klausser Well-Known Member

     
  4. kufo

    kufo Well-Known Member

    @Reto Ergänzung zu #1: Die zu bearbeitende ISO wurde mit AnyDVD 8.2.3.1 erstellt.
     
  5. birgitt2404

    birgitt2404 Well-Known Member

    Aber Clonebd heißt doch so. D.h ich will geclonte Blu-ray disc. Dann muss die Disc auch funktionieren.
     
  6. kufo

    kufo Well-Known Member

    @birgitt2404
    Naja nicht wirklich. Clone wäre 1:1 - Wir schrumpfen ja. Grundsätzlich hast du aber recht.
     
  7. Reto

    Reto Elaborate Bytes AG

    Ich kann das nicht reproduzieren. Kannst du bitte alle Titel nennen, mit denen das passiert, evtl. können wir dann versuchen, die Situation 1:1 nachzustellen.


    Das ist eine völlig andere Sache, um forced subtitles geht es hier ganz offenbar nicht.
    Wo ist der thread, in dem du von Problemen mit forced subtitles berichtest, ich kann nichts finden?

    Bei 1:1 Kopien bin ich mir recht sicher, dass alles funktioniert, wie im Original.
    Ihr macht aber hauptsächlich "partial copies", was ein heftiger Eingriff in die Strukturen bedeutet und die komplette Streamsteuerung wird von CloneBD neu erzeugt.
     
  8. kufo

    kufo Well-Known Member

    @Reto
    Bei 1:1 Kopien bin ich mir recht sicher, dass alles funktioniert, wie im Original.
    Ihr macht aber hauptsächlich "partial copies", was ein heftiger Eingriff in die Strukturen bedeutet und die komplette Streamsteuerung wird von CloneBD neu erzeugt.

    Das ist auch meine stille Vermutung gewesen.
    Probleme mit UT hatte ich zuletzt bei Barry Seal (Americam Made), Mord im Orient Express und ET. Mir ist dabei folgendes aufgefallen: Wenn ich Untertitel per klick auf den Haken anwähle ( Siehe Bild ) UT eingeschaltet.jpg erscheint ja neben der Sprache das kleine Bildschirmsysmbol. Wähle ich die UT per klick auf den Haken ab und lass das kleine Sybol aktiv, bleiben die UT. Ich lass dem Mord im Orientexpress gerade noch mal laufen.
    Problematisch wird es wenn die UT mehrfach vorhanden sind, wie bei Apollo 13 ( Siehe #30 https://forum.redfox.bz/threads/vorschaufelder-bleiben-schwarz.74872/page-2#post-486708 )
    Um es noch eimal auf den Punkt zu bringen: Es gelingt mir aktuell nicht die NORMALEN UT zu behalten um sie bei Bedarf einzublenden, da sie permanent erscheinen.
    Kannst du mir das mit den eingebrannten UT erklären? Einige erwähnen das hier im Forum, aber wie die zustande kommen versteh ich nicht.

    Danke vorab,
    kufo
     
  9. D300

    D300 Well-Known Member

    aber auch dazu wird CloneBD gekauft und verwendet.
    Das Ergebnis sollte Lauffähig sein !!!!
     
    kufo likes this.
  10. kufo

    kufo Well-Known Member

    Danke @ D300
    Es bringt mir nichts wenn im CBD Vorschau Player die UT ausschaltbar sind, aber auf der Disc nicht. Ich kann den Fehler erst auf der gebrannten Scheibe sehen. Es sollte auf der Disc so klappen wie in der Vorschau.
     
  11. kufo

    kufo Well-Known Member

    @Reto
    Macht das einen Unterschied wenn ich in CBD anstatt auf den Button PLAYER SCHLIEßEN UND ZURÜCK, einfach direkt auf AUSWAHL klicke? Ist das eine Fehlerquelle?
     
  12. Reto

    Reto Elaborate Bytes AG

    Es gibt wirklich keinen Grund, so zu brüllen ;)

    im übrigen denke ich, dass das Ergebnis lauffähig ist.
    Wir reden über kleine Ungereimtheiten mit Untertiteln, die wir anhand von - konstruktiven - Beiträgen zum Problem beheben wollen.

    Das halte ich für sehr unwahrscheinlich, dass das "Bildschirmsymbol" einen Einfluss hat. Über dieses Symbol wird ausschließlich gesteuert, welcher audio/subtitle track im preview player im Moment angezeigt wird.
    Es hat keinerlei Einfluss in irgendeiner Form auf die spätere Konvertierung.

    Ich habe jetzt mit diversen discs getestet, ich kann keinerlei Abweichung von den erwarteten Ergebnissen feststellen (die genannten discs habe ich allerdings nicht zur Verfügung).

    Von was für einer Konvertierung reden wir? MKV? MP4? Disc copy?

    Ich versuche einmal die verschiedenen Möglichkeiten zusammenzufassen, um Ordnung in die Sache zu bringen.

    1. "MKV mit permanenten Untertiteln" oder MP4
      Das MP4 Format unterstützt keine auswählbaren Untertitel (lediglich Textformat) und diese spezielle Variante von MKV ebenfalls nicht. Hier kann nur ein Untertitel "fest ins Video eingebrannt werden", d.h. der Untertitel wird Teil des Videos selbst.
      Auf der Auswahlseite kann je titel nur ein Untertitel gewählt werden (oder keiner).
      Im Previewplayer ebenfalls.

    2. "MKV mit wählbaren Untertiteln" oder Disc copy (vollständig oder teilweise)
      Diese Formate unterstützen mehrere Untertitel, die vom player hinzugewählt werden können.
      Entsprechend können mehrere Haken gesetzt werden, sowohl auf der Auswahlseite, als auch im preview player.
      Damit wird zunächst nur festgelegt, welche Untertitel im Container abgelegt werden.
      Auf der "Ziel"-Seite können dann noch die "Vorgabesprachen" gewählt werden, das ist die Audiospur, die beim Start des Films automatisch aktiv ist und auch der Untertitel, der voreingestellt sein soll (beim Untertitel ist dementsprechend auch "keine" möglich).

      Zur Laufzeit: im Falle von MKV können die Untertitel/Audiosprachen nur über das entsprechende Playermenü ausgewählt werden.
      Im Falle einer disc copy baut CloneBD ein Popup-Menü ein, das über die Fernbedienung des players wie gewohnt geöffnet werden kann und über das dann die entsprechenden Sprachen gewählt werden können.
    Nein, das macht keinen Unterschied.

    Ich sehe noch nicht genau, wie das Problem aussieht - wie gesagt kann ich es beim besten Willen nicht reproduzieren.
    Vielleicht hilft eine Reihe von Screenshots, auf denen man eine entsprechende Ungereimtheit erkennen kann (plus dazu ein CloneBD log file - es darf auch von einem abgebrochenen Vorgang sein, die Einstellungen sollten weitgehend erkennbar sein).
     
  13. D300

    D300 Well-Known Member

    Neh @Reto Brüllen ist anders:);)
    und man bekommt ja auch mit, dass Ihr euch Mühe gebt
    das ganze noch mit dem Riesenvorteil das Fragen und Antworten
    auf Deutsch gegeben werden können.(y)
     
  14. kufo

    kufo Well-Known Member

    @Reto
    Erst einmal Danke für die schnelle Antwort und Hilfestellung !
    Wie bereits am Anfang des Thread erwähnt mache ich immer komplette Backups mit ausgewählten Tonspuren. Ich setze im Auswahlmenü oben links den Haken ALLE AUSWÄHLEN ( Alle Filmsequenzen) und lege dann im Vorschauplayer während des Hauptfilms die Tonspuren und UT fest. Im Obermenü sind ja nicht alle Tonspuren und UT aufgelistet. Warum das bei einigen Filmen mit den UT nicht richtig funktioniert ist mir ein Rätsel.
    Was ich dabei frage: Warum erscheinen die UT ohne das sie ausgewählt würden und warum lassen sie sich nicht richtig ausblenden? Werde später von zuhause ein Log File senden
    Wie sollen die Screenshots aussehen? Denkst du an eine bebilderte Schilderung meiner Vorgehensweise?
     
    Last edited: Apr 10, 2018
  15. kufo

    kufo Well-Known Member

    @Reto
    Hier das Log File zu Barry Seal ( American Made ). Die UT erscheinen hier trotz Abwahl im Disc Menü und lassen sich nur ausblenden, wenn man explicit auf UT Deutsch klickt. Vielleicht findet ihr da ja was...
     

    Attached Files:

  16. Reto

    Reto Elaborate Bytes AG

    Der Film hat, wenn ich mich recht erinnere, diverse Szenen mit spanischer Sprache, in denen forced subtitles enthalten sind.
    Diese Scheibe sieht mir aus, als würde sie nicht tatsächliche forced subtitles verwenden, sondern explizit komplette subtitle spuren dafür vorhalten (offenbar der 5. für englisch und der 6. für deutsch).
    Der BD-J code wird - wenn im Menü subtitles deaktiviert werden - idR einen dieser "pseudo-forced" subtitles aktivieren (je nach authorer der mit der voreingestellten Sprache des players oder einen anderen).
    Aus Sicht des players ist das ein ganz normaler Untertitel, der weiß nicht, dass dieser die Aufgabe eines "forced" subs hat.
    Wenn dieser fehlt, stellt der player meist den ersten Untertitel ein, den er findet.
    Genau das dürfte hier passieren.

    Das grundsätzliche Problem - und das kann CloneBD nicht ändern - ist dass die BD-J menus ein ausgewachsenes Java-Programm sind mit all seiner Komplexität. Was dieses Programm im Inneren denkt, kann man von außen schwer beeinflussen.
    Wenn man dem Programm "unterm Hintern" die Daten verändert, dann darf man sich nicht wundern, wenn unerwartetes passiert - die Programmierer des BD-J codes haben natürlich keine Vorkehrungen für den Fall getroffen, dass Untertitel nicht da sind, die bei der Herstellung noch da waren.

    Lässt man z.B. den englischen Ton weg und stellt im Menü auf englisch (der Menüpunkt ist ja noch da), dann kommt entweder die erstbeste Sprache oder evtl. auch gar keine. Je nachdem, was programmiert wurde.
    Auch hier darf man sich nicht wundern, wenn man einer Fliege die Flügel ausreißt, dass sie nicht mit den Beinen flattert und wegfliegt. Das hatte der Hersteller der Fliege einfach nicht eingeplant.

    Ich empfehle generell: Untertitel drin lassen, wenn man eine 1:1 Kopie mit originalem Menü will.
    Man spart beim entfernen eines Untertitels etwa ein tausendstel (!) an Speicher ein (bei einer UHD eher weniger), die sind so lächerlich klein, dass es einfach den Ärger nicht wert ist.

    Bei Audio lohnt es sich dagegen.

    Wenn man nicht das Originalmenü verwendet, kann es Sinn machen von 25 Untertiteln 23 zu entfernen, damit die Untertitelauswahl übersichtlich bleibt.
    In diesem Fall aber ergibt es überhaupt keinen Sinn.
     
  17. D300

    D300 Well-Known Member

    wenn ich an BluRay denke, dann kommt mir immer wieder der Alte Ts-Muxer in den Sinn, da ist es doch möglich, den Hauptfilm, nur mit den Sprachen und den UT die man will, als ISO zu erstellen..
    als Ergebnis bekomme ich den Hauptfilm, OHNE IRGENDEIN MENÜ den man auf BD Brennen kann UND DAS DING
    LÄUFT !
    Geht das nicht auch bei UHD ?
     
    Last edited: Apr 10, 2018
  18. kufo

    kufo Well-Known Member

    @Reto
    Vielen Dank für deine ausführliche Antwort (y)
    Das hilft mir sehr gut weiter.
    Wenn ich dich richtig verstanden habe, soll ich also alle UT drin lassen, damit Java daran nicht rumwerkeln muss?
    Das Java Problem war mir bislang so nicht bekannt .:sick:
     
  19. Pete

    Pete Forum Admin Staff Member

    Natürlich geht das - CloneBD -> Partial copy -> Originalmenü NICHT beibehalten.
    Das funktioniert problemlos.

    Aber ich verstehe den Wunsch mancher, die gerne das Originalmenü beibehalten wollten.
    (Und bitte weniger Ausrufezeichen und Fragezeichen, das kommt sehr aggressiv rüber).

    Ich würde damit rechnen, dass es dann glatter läuft, ja.
    Dass das Java dran rumwerkelt ist weniger das Problem, als dass Java dem player sagt, er solle einen Untertitel einschalten, der nicht (mehr) existiert.
     
  20. kufo

    kufo Well-Known Member

    @Pete
    Auch dir vielen Dank für die technische Hilfestellung! (y)
    Also könnte ein Untertitel an einer falschen Position im Menü liegen, wenn es schlecht läuft? Ich meine vertauschte Position im Vergleich zum Discmenü - Also keine UT im Menü gewählt, aber an dieser Stelle ist jetzt z. B. Deutsche UT rein programmiert?
    Das erklärt sofort das Problem. :rolleyes:
    Werde jetzt alle UT drin lassen, denn der Platzgewinn ist wirklich minimal :)
    Was ich aber immer noch nicht verstehe, Ist was manche mit EINGEBRANNTEN Untertiteln meinen... Ich will die UT behalten und nach Bedarf einschalten. Wer will denn permanent Untertitel im Bild haben :cool:
     
    Last edited: Apr 10, 2018