UHD slow rip, glitches in video

Discussion in 'AnyDVD HD (Blu-ray issues)' started by llowrey, Feb 11, 2018.

  1. llowrey

    llowrey Member

    I'm trying to rip "Star Trek Beyond" (UHD) to iso and so far each attempt has been VERY slow (~1-3MB/s) and each iso has been slightly different. No errors have been reported during the rips. When I play back the video, either the m2ts or an mkv made from the m2ts, I get glitches in the video, but each iso has them at different times.

    MakeMKV rips it just fine; full speed and no glitches in the video.

    AnyDVD: 8.2.2.2
    Drive: HL-DT-ST BD-REWH16NS40 1.02

    I have ripped 15 UHDs so far without issue so it seems there's something specific about this disc that's a problem. The disc did have some fingerprints on it but I thoroughly cleaned it and the results were no different.

    The sparse option is unchecked.

    I just started a rip to a protected image. It's slightly faster (4MB/s) but still far slower than normal. I'll report back if the protected image is error-free.

    Is there anything I can do to collect useful information to help debug this case?
     
  2. Aeneas72

    Aeneas72 Well-Known Member

    How about a logfile?
     
  3. James

    James Redfox Development Team Staff Member

    Your disc and / or drive is dirty and / or defective.
    When creating an iso much more is read. Compare it to creating an mkv with CloneBD (free for this purpose) from the original disc.
     
  4. James

    James Redfox Development Team Staff Member

    Thank you, but not needed.
     
  5. llowrey

    llowrey Member

    CloneBD is now running but VERY slowly. It reports between 5-10fps and a 7 hour total estimated time. This is without transcoding (video and audio in pass-through mode).

    The same disc and drive works with MakeMKV at full normal speed and without errors.

    It's entirely possible that the drive is having a hard time reading this disc but clearly MakeMKV is doing something different which results in a full-speed copy with no errors.
     
  6. James

    James Redfox Development Team Staff Member

    Interesting. What happens, if you run MakeMKV while AnyDVD is active? If you copy the largest .m2ts file with Windows explorer (with and without AnyVDD)?
     
  7. llowrey

    llowrey Member

    TL;DR - My drive needs to read a good disc before it can read the "bad" disc.

    Additional testing showed garbage performance (and errors) from everything, including MakeMKV. I put in a good disc and ripped it for a few minutes to confirm that the drive was still working correctly and it ripped at full speed. I put the bad disc back in and it ripped at full speed with no errors with everything (including AnyDVD). So, chalk this up to a firmware errata.
     
  8. llowrey

    llowrey Member

    I've also noticed that discs that a lot of UHD iso rips differ. I am now ripping to ISO multiple times and comparing SHA-1 hashes of the isos. Most of the time two rips are identical but often the 2nd one is different so I have to rip a third or fourth time to get two with the same hash. No errors are ever reported by AnyDVD.
     
  9. JohnHWman

    JohnHWman Active Member

    Interesting...

    I've also ripped some UHD discs to MKV using Clone BD 1.1.9.0 (untouched Video stream and untouched 2 audio tracks) and also noticed that generated MKV file sizes differ after three different ripping process of the same disc through CloneBD (all three ripping process showed no errors in CloneBD).
    FYI, all the three MKV files stutter on my Zapitty 4K HDR Duo player ...
    I will give a try with MakeMKV to see.

    John
     
  10. ehharley1

    ehharley1 Member

    On the two discs I’ve done, Jigsaw and Life, the first one, Jigsaw worked good, although multiple times, while ripping iso with anydvd, the estimated time remaining went to 0:00:00 but the rip speed remained at ~10mb/s. The completed rip played perfect from my nas using Shield tv and plex.
    The second one I’m having rip to image troubles with anydvd. First try 3% hangs up remaining time 0:00:00 rip speed 0mb/s. Cleaned disc.
    Second try same thing at 16%. Cleaned disc and trying again. Has anyone else seen this? The disc looks clean.



    Sent from my iPhone using Tapatalk
     
  11. Hackerjac

    Hackerjac Well-Known Member

    Yes i have seen this alot of times, UHD disk are very sensitive
    What i have done and it have worked besides 1-2 times, is when AnyDVD comes up with that it can read the disk, i just let it rest 10-20 min, don't close the anydvd msg screen, after that period of time i take out the disk, clean it again, and reload it, then i keep tapping retry untill it reads again
    this have worked on my Asus BC12D2HT drive
     
  12. ehharley1

    ehharley1 Member

    Thanks for the reply.
    I have a LGBE16NU50
    I’ll be diligent to wipe them off even if they look clean, I guess. I’ll keep your suggestions in mind too. Thanks


    Sent from my iPhone using Tapatalk
     
  13. ehharley1

    ehharley1 Member

    I Cleaned disc with Mother’s Plastic Polish, my tried and true goto, and trying again....
    That fixed the problem.
    ISO done! These thing are Really Finicky?
    The disc looked completely clean on the first attempt.


    Sent from my iPhone using Tapatalk
     
  14. The House

    The House Active Member

    I would not have thought of using something like that. I have been unable to backup my copy of Guardians Of The Galaxy 2 due to minor scratches on a NEW disk. Even Thor Ragnarok had to be carefully cleaned to work. Will have to get some because as you said, they are really finicky.
     
  15. ehharley1

    ehharley1 Member

    I’ve been backing up discs for 10+ years and been using mothers plastic polish for discs with read issues almost as long. It’s fine enough that it buffs not scratches.
    My conclusions, it can’t hurt, and it may help.
    Just make sure you lay your disc on something soft when polishing. I use a magazine most of the time.


    Sent from my iPhone using Tapatalk