UHD BackUp wie und womit

Discussion in 'Allgemeiner Chat' started by DaveO88, Jan 13, 2018.

  1. xellex

    xellex Well-Known Member

    @DaveO88
    Wie genau machst du das mit CBD bei mir kommt wenn ich es abspiele Fehlermeldung „Wiedegabeliste fehlt“

    @TheSound
    Kannst du mir bitte das über PM schicken ;)
     
  2. DaveO88

    DaveO88 Moderator DE

    @xellex so geht das ohne Probleme (Video ist in h265)
     

    Attached Files:

    xellex and kufo like this.
  3. TheSound

    TheSound Member

    Hier der Inhalt der Batch Datei:

    cd /D %~dp0
    pause
    copy /b 1.m2ts+2.m2ts+3.m2ts+4.m2ts+5.m2ts final.m2ts
    pause

    Die Stücke in der richtigen Reihenfolge von 1.m2ts usw benennen, in den selben Ordner wie die batch kopieren und die batch starten. Ergebnis ist dann das zusammengefügte final.m2ts
     
    xellex likes this.
  4. xellex

    xellex Well-Known Member

    Ich habe das gerade getestet, die Datei erzeugt eine große m2ts Datei. Was mir aber aufgefallen ist das ich kein Ton habe und anstelle von DTSHD zeigt es mit AC3 obwohl die einzelen m2ts DTSHD anzeigen. Die länge ist auch nicht korrekt, wie läuft das bei dir? Kannst du mir bitte sagen warum die final Datei so bei mir aussieht?
     
  5. TheSound

    TheSound Member

    Ich habe das mit uhd bisher einmal versucht, das ging anstandslos...
     
  6. DaveO88

    DaveO88 Moderator DE

    ich kann nur vermuten , wenn im Original eine DTSHD Spur vorlag und am Ende nur noch AC3 dann kann ja nur sein da in den Audiooptionen die Konvertieroption eingeschaltet war anstatt das Audio beizubehalten .

    cbda.JPG

    Was die länge betrifft kann es auch am Film liegen wenn sich zB. mehrere Versionen sich auf der Disc befinden wie auch in meinen Beispiel der Directors Cut und die Kinofassung welche dann eben unterschiedliche längen haben je nach dem welche MPLS gewählt wurde .

    mpls.JPG

    Aber wie gesagt das sind jetzt nur die naheliegensten Vermutungen da ich nicht an Deinem Rechner sitze und weis was genau getan wurde
     
  7. xellex

    xellex Well-Known Member

    Also die einzelne m2ts sind alle korrekt und haben die richtige Tonspur ohne Komprimierung, die Beatch Datei startet den vorgang aber das Ergebnis anstelle DTSHD habe ich AC3 und die Filmlänge passt nicht, die Beatch Datei verändert das ganze. Bin leider mit dem Ergebnis nicht zufrieden.

    Werde jetzt mit der ISO probieren.
     
  8. fornit

    fornit Member

    Hi,

    ich mache es etwas anders und nehme ffmpeg in Verbindung mit der Option "concat", hatte aber auch schon das Problem mit den Audio-Spuren.

    Es ging dann, indem ich die Audio-Spuren mit dem Zusammenfügen konvertiert habe.

    Hier mal ein Beispiel, wie ich es bei der Blu-Ray Equalizer gemacht habe.

    Die besteht aus den Dateien 00002.mts, 00003.mts, 00004.mts, 00005.mts, 00006.mts, 00007.mts, 00008.mts, 00009.mts, 00010.mts und 00011.mts.

    Damit das Ganze funktioniert, braucht es eine txt-Datei, die ich equalizer.txt genannt habe, und in der die einzelnen Dateien wie folgt aufgeführt sind:
    file 00002.m2ts
    file 00003.m2ts
    file 00004.m2ts
    file 00005.m2ts
    file 00006.m2ts
    file 00007.m2ts
    file 00008.m2ts
    file 00009.m2ts
    file 00010.m2ts
    file 00011.m2ts

    Dann habe ich die Video-Teile zusammengesetzt:
    ffmpeg -f concat -i equalizer.txt -map 0:v:0 -c:v copy -an -y equalizer_video.m2ts

    Interessiert haben mich nur die deutsche und die englische Tonspur, daher habe ich die beiden mitb den folgenden Befehlen zusammengefügt:
    ffmpeg -f concat -i equalizer.txt -map 0:a:0 -c:a aac -b:a 192k -ac 2 -vn -y equalizer_audio_en.m2ts
    ffmpeg -f concat -i equalizer.txt -map 0:a:1 -c:a aac -b:a 192k -ac 2 -vn -y equalizer_audio_de.m2ts

    Und schließlich das Ganze zusammengemuxt (deutsche Audiospur vor der englischen):
    ffmpeg -i equalizer_video.m2ts -i equalizer_audio_de.m2ts -i equalizer_audio_en.m2ts -map 0:v:0 -map 1:a:0 -map 2:a:0 -c:v copy -c:a copy -y equalizer.m2ts

    Wenn du mit ffmpeg etwas vertraut bist, kannst du es ja mal damit probieren. Hat bei mir mit mehreren Blu-Rays geklappt.

    Gruß
    fornit
     
  9. DaveO88

    DaveO88 Moderator DE

    Naja bei einer BD nimmt man immer noch den guten alten TsMuxer welcher eben bei einer UHD Disc leider nicht mehr wie gewohnt funktioniert

    Daher dann eben CBD
     
  10. fornit

    fornit Member

    Ja, viele Wege führen nach Rom. Bei den UHD Discs ist es halt wichtig, dass hinterher die HDR-Meta-Infos noch drinstehen.

    Sollte aber bei ffmpeg so sein. Habe auf jeden Fall mal den Inhalt einer UHD Disc in verschiedene Container umgepackt, und da war das kein Problem.
     
  11. DaveO88

    DaveO88 Moderator DE

    Bei cbd bleiben HDR Metadaten auch erhalten nur bei DolbyVision gibt's noch Schwierigkeiten
     
    kufo likes this.
  12. fornit

    fornit Member

    Das Interessante an ffmpeg ist auch mehr, dass man den Inhalt der UHD Discs in puncto Dateigröße deutlich kleiner bekommen kann, wobei sich die HDR-Eigenschaften erhalten lassen und der Qualitätsunterschied praktisch nicht sichtbar wird. Ist aber zugegebenermaßen dann mehr etwas für Leute, die sich auskennen und keine Angst vor der CLI haben.
     
  13. xellex

    xellex Well-Known Member

    Hab es mit iso probiert und es funktioniert soweit, was ich aber bei den Tests festgestellt habe ist das ich den Cut zwischen den Streams wahrnehme.

    @DaveO88
    Ist das bei dir auch so? Wie sind deine Erfahrungen?
    Was meinst du beim CBD gibt es noch Schwierigkeiten mit DolbyVision?
     
  14. DaveO88

    DaveO88 Moderator DE

    Kurzum - Nein
    Statisches HDR ist hier kein Problem
    DolbyVision also Dynamisches HDR macht halt noch Schwierigkeiten deshalb gibt es die Abwahl Option
     
  15. marban

    marban Active Member

    Welche DV Probleme gibt es denn? Bei mir scheint alles zu gehen.
     
  16. TheSound

    TheSound Member

    Hallo zusammen, wollte mal ein info update einholen... Sind uhd friendly laufwerke immer noch nötig?
     
  17. DaveO88

    DaveO88 Moderator DE