Trouble with 3D conversion

Discussion in 'CloneBD' started by Rocket Box, Mar 30, 2018.

  1. Rocket Box

    Rocket Box New Member

    I'm trying to convert a BD 3D rip (Lemurs of Madagascar) to 3D SBS with CloneBD. However, when I start the conversion the software seems to get stuck. The file is generated on the hard drive but even after 7 hours (attached screen shot) it is still 0 in size and there does not seem to be any progress. I am currently using the beta that was recently released but also tried the previous release. Steps were:

    1. Decode and rip the BD disc with MakeMKV
    2. In CloneBD, chose Open Folder and selected the BD disc folder on the hard drive
    3. Selected File Convert in Copy Mode and set MKV Container and Selectable Subtitles
    4. Selected Episode #1 which had a "3D" overlay on the track
    5. Set Video to h.264 and Audio to original, and 3D format to Side by side - left/right then started it.

    Any suggestions as to what I might be doing wrong?

    TIA.


    clonebd.png
     
  2. kufo

    kufo Well-Known Member

    @Rocket Box
    What about the usage of other applications by 100%? ? You get a Folder with the film in 3D, but see no Progress -right? I can only imagaine a mistake in diaplaying the progress by CloneBD. I would post the log file, cause it´s automaticaly produced.
    (Introduced in 1.1.9.4 and you can find it in your destination folder) Perhaps Reto or Pete can take a look at this.
     
  3. SLKabaker

    SLKabaker Well-Known Member

    WHen you say that you open the "BD Folder" on the Hard Drive, did you "Rip Video Disc to Harddisk..."? There are Virtual Files on 3D Blu-rays that are lost unless you make an ISO Image of the 3D Blu-ray and thus it will not work. UDF 2.50 and later support Virtual Files; FAT32, NTFS, HFS, etc. do not support these kind of files.
     
  4. kufo

    kufo Well-Known Member

    @SLKabaker
    Your´re right with this! I missed the the meanig of the line :
    If does so, there´s no ISO output possible, because this programm cann´t create ISO for output. The virtual files I hadn´t in my mind.
    @Rocket Box
    Did you ever use AnyDVD? This should solve your creating problem
    Try the latest AnyDVD Version as a test and create an ISO file from the disc by right clicking on the fox icon. Download the latest graphic card drivers.
    anydvd iso.jpg
     
  5. SLKabaker

    SLKabaker Well-Known Member

    @Rocket Box & @kufo

    I have not used MakeMKV. Seeing as it makes MKV files, can't it make a 3D MKV? Or can MakeMKV create ISO Images? If not, then AnyDVD HD is the best option for decoding your Blu-ray 3D disc and, either, creating an ISO Image with AnyDVD HD and then use CloneBD or converting to a 3D MKV directly from the disc with CloneBD.

    There is a, slightly, more complicated way with using DVDFab Virtual Drive (creating a mini-iso that rebuilds the virtual files), creating a full ISO with IMGBurn and then creating the MKV with CloneBD.
     
  6. goncal

    goncal Well-Known Member

    MakeMKV can make a full folder backup.
    The virtual pointers would be lost but the backup should be approximately double in size, as virtual files are copied as real files
     
  7. kufo

    kufo Well-Known Member

    @goncal For the case , you want onlx main movie, that will work. I my opinion making an iso file with AnyDVD is the best solution. If you want to make a full backup with 3D working, you´ll have to take a third party product like BD Rebuilder.
    Important is, that the clpi info files for 3D are kept intact. Otherwise 3D won´t work!
    @Rocket Box
    Did you try the encode with a mounted ISO, made by AnyDVD? Did you get the same error/mistake here?
     
  8. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    Bdrb is only 'required' at the moment for full disc backup. CloneBD can make 3D mkv's just fine, which is what this topic is about.

    Sent from my Nexus 7 with Tapatalk
     
  9. goncal

    goncal Well-Known Member

    My post was meant for SLKabaker, who said that you can't back up a 3D disc to folder.
    And you can compress the full disc, from a folder structure, but the output should be ISO
    Back on topic, this is about MKV SBS
     
  10. SLKabaker

    SLKabaker Well-Known Member

    When the Virtual Files are converted to real files, it still doesn't work! I have worked with 3D Blu-rays extensively. Which is why I gave a second option, beyond using an ISO created with AnyDVD HD. Creating a mini-iso with DVDFab Virtual Drive (which is a free program), creates a pseudo ISO Image (which is tiny and points to the BD Folder) and rebuilds the virtual files. Load the mini-iso in DVDFab Virtual Drive and then create a real ISO with IMGBurn or you could have CloneBD read it directly. I have done this several times. It is more steps but a fairly easy process.

    Converting Virtual Files to real files changes the file structure and the way the data is meant to be read. 3D is way more delicate than standard Blu-ray. There is a reason why those files are virtual and is the same reason why CloneBD can't make Blu-ray 3D Copies (only 3D MKVs).
     
  11. goncal

    goncal Well-Known Member

    This getting off topic but...
    BD_RB works on folder structures
     
  12. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    So does CloneBD. The only difference is that CloneBD currently cannot backup 3d disc to disc and brdb can.

    Sent from my Nexus 6P with Tapatalk
     
  13. Pete

    Pete Forum Admin Staff Member

    Sorry, late answer, holidaytime....
    OK...
    What you are trying to do, should be easy, but as @kufo mentioned (good catch), it says "other applications 100%".
    Some application seems to be using up your CPU completely and leaving nothing for CloneBD.

    My guess is that this application (you'll have to identify through task manager) is running at a lower-than-normal priority, so you won't notice it in normal situations (most other applications run at normal priority and will take precedence over this hungry bugger).
    But since CloneBD can use a lot of CPU itself, it shows the same courtesy and runs with lower priority - meaning it will only use up all CPU that is left over by other applications, which in this case is: none.

    You can either identify that bugger and stop it or use task manager to raise CloneBD's priority, then it should get going again.
    The way I see it, this has nothing to do with 3D at all.
     
    whatever_gong82 and kufo like this.