Transcoder Error (log files attached)

Discussion in 'CloneBD' started by Pyanfar, Oct 26, 2018.

  1. Pyanfar

    Pyanfar Member

    Hi folks:

    This is Windows 10 64-bit with the latest CloneBD, just installed after installing AnyDVD HD. I upgraded my video cards and now I'm getting a transcoder error, so just need some help. Latest drivers are all set up, here's the hardware config:

    Alienware Area-51 ALX:
    Intel Core i7 980X Xtreme Edition processor
    3 x 3GB G. Skill Trident RAM (triple channel)
    Samsung Pro Series 850 SSD (512 GB) for OS
    Writing to Western Digital Caviar Black 1TB 7200RPM drive
    2 x nVidia Gefore 1080 GTX (8GB RAM ROG STRIC OC edition), SLI enabled

    Log Files attached.

    I was trying to rip discs from Outlander Season 2, and verified that they can rip on another machine. Questions and suggestions welcome.

    Thanks in advance!
     

    Attached Files:

    Last edited: Oct 26, 2018
  2. Lukas

    Lukas Well-Known Member

    logfile upload directly below post :)
     
    whatever_gong82 and Pyanfar like this.
  3. Pyanfar

    Pyanfar Member

    Updated! Thank you Lukas - that's what I get for using a Remote Window - totally missed that button :) Uploaded now.
     
    whatever_gong82 likes this.
  4. Lukas

    Lukas Well-Known Member

    now it's probably @Pete on developers
     
    Pyanfar likes this.
  5. Pyanfar

    Pyanfar Member

    Awesome. I'm fairly nerdy, so I can probably try just about anything Pete and/or his team come up with. And I'm patient...I look forward to figuring this one out. :)
     
  6. Pete

    Pete Forum Admin Staff Member

    OK, that is very unusual. nVidia normally works super-stable with CloneBD.

    You say you can "rip on another machine" - first we need to get to some common ground with the terms.
    "Ripping" = bypassing protection + copying (= not CloneBD's job), so I assume, you actually mean transcoding?
    Also: that other machine, does it have an nVidia card and did you use nVidia acceleration for the process?
    And: on the machine that is having trouble, I'm assuming it works as well, when you disable hw acceleration in CloneBD's settings?

    Also: did you try other discs with the same setup?

    A thing you might want to try, is temporarily remove one of the two cards, just to rule out, that some element is getting confused over the two cards.
    CloneBD correctly detects both cards and, since they are identical, chooses the first one.
    Then something strange happens - the transcoding engine times out, no reason given.
     
    Pyanfar likes this.
  7. Pyanfar

    Pyanfar Member

    Sorry, I don't know the lingo - what I meant by "ripping" is that, "On another machine that has AnyDVD and CloneBD, I can put a Blu-Ray disc in and, using the same settings, create a .MKV file that works just fine on my home media server." :)

    Here's the whole story:
    - The "other machine" had these dual 1080s in it and I was using it as described above.
    - I upgraded the "other machine" to a pair of 2080 GTXes, then put the 1080s in the machine that I'm asking for help with here.
    - The machine I'm asking for help with here was my "old" desktop that I used to use CloneBD on and it worked fine. At the time I had a pair of GeForce 680 GTXes.

    tl;dr: 1080s worked fine in another machine, not in this one. This machine worked fine with 680s, but not with 1080s.

    I agree - nVidia's transcoder works fantastically with CloneBD, so I was surprised things went weird like this.

    1) On the machine that is having trouble, it does appear to work when I disable hardware acceleration in CloneBD's settings.
    1) I did try other discs in the series, and I also did try the discs that failed here on the "other machine" and it worked just fine.
    2) I will try an entirely different title, that I know I have already been able to transcode on the "other machine", and see if it too fails on this one.
    3) I will also try one card, just to rule out any possible confusion, as you suggest. :)

    It may take me a little bit to get to this, but I'll reply as soon as I can try these things. Thanks!
     
  8. Pyanfar

    Pyanfar Member

    - Okay, I had a couple of ideas in addition to these suggestions. Here's what I've got so far:

    - I wondered if the 1080 series' NVidia Transcoder might not be supported in a 1st-gen Intel Core processor. So I removed the 1080s and reverted to the 680s.
    - Clean driver install, then remove CloneBD and reinstall (reboot between each of these steps)

    - Tried a different title, same thing.
    - Tried a different disc in the series, same thing.
    - Tried a disc from the next Season's box set, and attached is that error log.

    Each time, it looks like the following:
    - preview screen stays black
    - NVidia meters (green bars) fill to 100%
    - after a few seconds' pause, the CPU Idle meter goes from 99% to 91%, then the other meters (CloneBD, Other Progams) go up to 8% and 1%
    - less than 2 seconds later, the fail


    Take a look at the attached error log, let me know what you think. Meanwhile, I'll try removing a card and running on one card.

    I can also try doing a video capture of the process with the GeForce Experience, but I don't know if that would interfere with what CloneBD is trying to do.
     

    Attached Files:

  9. Pyanfar

    Pyanfar Member

    Thanks for your patience! I disabled SLI, removed a card, and the single-card solution is now working - I just transcoded two discs with no problems.

    So now...

    1) How do we get it working again with two 680s in SLI?

    2) Is there some way I can give CloneBD more CPU? It tends to just use about 5% of the CPU and I don't know if that would help balance out all the work the NVidia components are doing. When I process a disc on this machine, I'm not doing anything else, so I don't need resources.

    This hardware was perfectly happy to transcode (with two 680s) in late 2016, so...would there be something about earlier versions of CloneBD that would make a difference? Anything changed about nVidia Transcoding in the last year or two? I'm completely open to suggestions or speculation. :)

    Thanks!
     
  10. Pyanfar

    Pyanfar Member

    Is this possibly a bugfix that could be applied in an update?

    No familiarity with your code, but some suggestions:

    - if the program looks for nVidia hardware and reads the 0th object returned in the read operation and stops, does what the program reads conflict with how the OS addresses SLI hardware?
    Example: Card 1 appears as Device ID A, Card 2 appears as Device ID B, but enabling SLI creates a virtualized device ID C that the OS knows to look for but the program doesn't.

    - could the program simply use 1 card and ignore the other? Meaning, it scans for nVidia hardware, then stops on the 0th entity returned in the array of device IDs returned from the scan and sends instructions to that. Whether nVidia load-shares the transcode to both pieces of hardware is nVidia's problem...

    Total spitballing from a position of patchwork knowledge...but if there's anything I can test, since this machine isn't critical for me and I know it worked in the past with these two cards in SLI, I'm willing to test anything you like. You could send me a build and I'd install it and try it out for you.
     
  11. Pete

    Pete Forum Admin Staff Member

    CloneBD actually scans through all available adapters, finds two identical ones and automatically chooses the first (since they are identical).
    SLI is technically entirely unrelated to this - SLI only applies to DirectX. NVENC is not covered by SLI nor does it deal with DirectX.
    Also, CloneBD does not talk to the OS, it addresses the nVidia framework directly.

    That's exactly what it does. There is nothing else it could do, as there is no way to somehow utilize two distinct cards simultaneously for processing the same video.

    In fact, CloneBD does everything exactly the same way it would be doing it, if only one adapter were installed.
    In both cases it's using "device id 0" as if it were the only one.

    So to me it's either a bug in the nVidia drivers, that somehow triggers, when two cards are installed (I tried two different cards without SLI, that was no problem).
    Or one of your cards is problematic (in case the one you removed was "device id 0" in the two-card configuration, after removing it, the other one was used and worked better somehow).

    Elby could add some crude selection (registry value determining the desired card id).
     
  12. Pyanfar

    Pyanfar Member

    Thanks Pete! This is really helpful to know. A lot of things I never knew in your post. :)

    I have a goofball pet theory that I'll test then...what if I try swapping the cards so that it chooses the other one as the 'first'? I may give that a try.

    I figure I could also just make it a point to disable SLI and see if it still works too.

    I'll let you know how this goes, I just might not be able to get to it in the next day or so. If this isn't a common issue, I suspect it may not be worth writing a fix for (after all, CloneBD *did* work marvelously on this hardware, and it *does* work marvelously on my new machine too.)

    I'll keep you updated here. I'm also open to any suggestions if you have any.
     
  13. Pyanfar

    Pyanfar Member

    So...switching video cards didn't appear to make a difference. I'm trying to come up with a workaround that doesn't involve me yanking one video card. This isn't a huge priority, but I am curious about how to solve the problem (and willing to try beta versions if that might help).
     
  14. Pyanfar

    Pyanfar Member

    I have a workaround idea - I'll let you know how it goes. I can pick the app in the nVidia Control Panel and disable SLI just for CloneBD. I just can't get to this right away, but I'll post back here after I try it.
     
  15. Pyanfar

    Pyanfar Member

    Hey everybody! I'd call this SOLVED. :)

    I learned some stuff - if anyone reading this every runs into this problem, you can disable SLI *just* for CloneBD: go into the nVidia Control Panel, click "Manage 3D Settings", then go to the "Program Settings" tab in that window. You'll be able to find CloneBD in the list or add it, and then there's a feature halfway down, "SLI Rendering Mode" - choose Single GPU and you should be good to go.

    That said, I did go ahead and do a complete reinstall of Windows 10 using their "Refresh" option, wiping the C:\ drive and installing Win 10 from the ground up.

    So far, CloneBD is working just fine with SLI enabled on my 680 GTXes.

    Thanks everyone for the help and suggestions!
     
  16. Pete

    Pete Forum Admin Staff Member

    Well, thank you a bunch for that very valuable feedback.
    It would still be interesting to find out what actually caused this.
    Anyway - thanks for all the effort you put into this.
     
    whatever_gong82 likes this.
  17. Pyanfar

    Pyanfar Member

    You're very welcome Pete! I'm sorry we didn't uncover a particular 'smoking gun'. My daughter had also been using Adobe's Creative Cloud on that machine for video editing. There's always a possibility that some Adobe-specific dll, codec, whatever, goofed things up (oh my lord has she run afoul of bugs in the thing).
    So...when she comes home for the holidays, I'll try reinstalling Creative Cloud. If that gums up CloneBD, then I'll know for sure...and I'll open up another thread here we can use to investigate further.

    Thanks again for making such a fantastic program! So delightful to be able to just fire up Plex and watch all my movies anywhere I go. CloneBD (and AnyDVD HD) is a huge part of that :)
     
    whatever_gong82 likes this.