Tool Compatibility with server 2019

Discussion in 'AnyStream' started by amazonlove, Sep 25, 2020.

  1. amazonlove

    amazonlove Member

    i have bought license even i tried trail installation on server 2019 it just runs in background not work on windows server 2019 , kindly push a fix , nice work carry on
    3b1ea052b29dc87231fdedec3fe1d383.png
     
  2. Kai Cheeda

    Kai Cheeda Member

    I'm assuming you're using a Remote Desktop? I ran into this problem too, the problem is with Amazon. The software uses QTWebEngine to work with Amazon, and that requires OpenGL, and that freaks out with Remote Desktop. If your server has a GPU, one thing you can do is install the drivers for the GPU, and then open gpedit.msc. In the tree menu on the left, navigate to Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Remote Session Environment, and open the Remote Session Environment folder (not the subfolder within it). Then finally enable 'Use hardware graphics adapters for all Remote Desktop Services', and restart the Server. I found this to work for me.
     
    albino likes this.
  3. albino

    albino Active Member

    Thank you for that. I'm also unable to run it in RDP, and since downloading at the recommended 1x takes a long time, I thought it would convenient to remote into my PC from my laptop while watching TV, but no luck. I had the same experience as the OP where it's running invisibly in the background and I'm unable to get to it even with alt+tab.
     
  4. amazonlove

    amazonlove Member

    i know it uses qtweb engine but other same soft based on qtwebengine works fine its issue with any stream
     
  5. Prospere

    Prospere RedFox Development Team

    That may be a Qt version problem too. QtWebEngine is not just a single version library.

    It's quite hard to find a solution not having a log file.
     
  6. amazonlove

    amazonlove Member

    will get you the log in few minutes

    btw i tried with windows server 2016,2019, win 10 on dedicated server as well as virtual machine same error persist
     
  7. Prospere

    Prospere RedFox Development Team

    Thanks! That may really help.
     
  8. amazonlove

    amazonlove Member

    check out the dump of log on server 2019 , will add windows 10 vm log too
     

    Attached Files:

  9. Prospere

    Prospere RedFox Development Team

    The problem appears to be related exactly to OpenGL (as Kai Cheeda said)
     
  10. amazonlove

    amazonlove Member

    what is fix then
     
  11. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    Who knows. Now that they have a logfile, they can determine how to fix the problem, if it's even possible to it themselves. As Prospere said, it's a problem in OpenGL. That's not something they develop. That is a third party engine.
     
  12. Prospere

    Prospere RedFox Development Team

    Unfortunately, AnyStream has no control over this. OpenGL is a part of Qt library.
    Have you actually tried Kai Cheeda's suggestion?
     
  13. amazonlove

    amazonlove Member

    it does not work not even any stream works on any virtual machine
     
  14. Prospere

    Prospere RedFox Development Team

    When you say virtual machine, is it still over RDP? Or do you mean that you can't run trial version on VM?
     
  15. amazonlove

    amazonlove Member

    99 % here are using on windows rdp server this tool u made only works on windows 10 + home pc only also there are other grab tools using open gpl version qt web engine they work fine ,
     
  16. James

    James Redfox Development Team Staff Member

    AnyStream is designed to work on a private "home" PC.
     
    blank and Aeneas72 like this.
  17. radiah

    radiah Member

    I'm using Windows Server 2019 Standard, Verion 1809 Build 17763.1490. Anystream works just fine on this machine with Amazon. I don't use Netflix, so I can't say anything about that.