This program cannot run without the original CD in the drive error


New Member
Thread Starter
Apr 5, 2022
I download a game called Casper: Mystery in the Castle and I got it from I have tried to play it but then, when I pressed launcher.exe, an error appeared. It says that "This program cannot run without the original CD in the drive". I looked at My Abadonware website and it says that it has copy protection and can not be installed from the mounted disc image. It also says I have to physically burn the disc image on CD. I burn it using ImgBurn and I tried on a Windows 7 laptop (it has 32 bits and I think it only works on 32 bits Windows OSs, not 64) and yet, it still happens. Also, in the english folder, it doesn't work unless if you have burned the ISO file. It worked at first but then, that error appeared again. And it also appears the "Windows cannot access the specified device, path, or file. You may not have the appropriate permission to access the item" when I press setup.exe

Can someone know what's the problem?
Last edited:
Game jackal would fix that but software is long gone. Alcohol 120 would to if it's even still around. You need what is called a NoCD patch but those are not legal. Since this is Abadonware and you can't buy it anymore, that should be fair use, presuming you are doing this for educational research ;)