Discussion in 'Issues and Bugs' started by pepegotme, Aug 25, 2015.

  1. pepegotme

    pepegotme Well-Known Member

    "Convert into a File Mode," Ver, Windows 7, 64 bit OS
    Movie: Woman in Gold"
    When I get the selection menu and choose subtitle English, I get the subtitles for english and german.
    I only need english subtitles when german is spoken. However, I get them both for english and german.
    I do not need english subtitles over spoken english, only when german is spoken.
    The summary screen shows me what is selected but, I cannot change it. BD Rebuilder does the same but,
    you can select the audio that you want. That is what is missing here-unable to select audio
    file and deselect others. See attachments.

    Create Disc Folder or ISO Mode:
    English subtitles not displayed when german is spoken
    Sorry for double post

    Attached Files:

    Last edited: Aug 25, 2015
  2. Pete

    Pete Forum Admin Staff Member

    Not sure I follow. That disc appears to have English and Spanish languages, no German.
    On your summary page, I can see that one video, two audio and one subtitle stream is selected.
    The two audio streams are likely both English, as that is what you've selected.
    Definitely only one subtitle, though, can't be English AND German.

    There is this floating button on the right side, the one that tracks your mouse. Click on it, then you can fine tune your selection(s) for the respective title.

    Also, while very rare, it still does happen, that the authorers mislable the streams with incorrect language flags. I've only seen that once so far, though.
  3. pepegotme

    pepegotme Well-Known Member

    I only want english subtitles when they speak german so I can understand them. I do not need english over english which is what I am getting. When they speak german, I get the needed english subtitles but, it continues over english speech.

    As for a floating button, that is the settings button you are referring to?
    Last edited: Aug 26, 2015
  4. Adbear

    Adbear Well-Known Member

    If you look at the bottom right of your second picture you can see the 'settings' option just peeking out. If you move the mouse pointer over the first title that settings option will move up to be on the right of the first title. You will then be able to choose which audio and subtitle tracks you wish to keep as there is clearly more than 1 English subtitle track on this movie.
    Alternatively you could hit the 'Play' button that shows up when you hover the mouse pointer over the first title and then choose from in there which subtitle you want to keep
  5. pepegotme

    pepegotme Well-Known Member

    I selected and deselected various combinations of audio but, the english titles for spoken german were never there. That was the only fault. It might be worth noting that BD Rebuilder had the same problem. Checking individual files gave no result. This program is definely improving. Now, it is functional.
  6. Ch3vr0n

    Ch3vr0n Translator NL

    The thing is with these forced subtitles that the bd authors often embed these into the normal English subtitles without properly flagging them as forced. That makes it very hard next to impossible to find out which ones are forced. The standard does allow for the forced ones to be in a separate track, but that method isn't frequently used.

    Verstuurd vanaf mijn Nexus 7 met Tapatalk
  7. Adbear

    Adbear Well-Known Member

    Audio and subtitles are different selections, so if you did only check and uncheck combinations of audio then you won't have chosen different subtitles. Also just ticking and unticking them won't show you which ones is actually playing at that time in CloneBD's preview player. It's the icon to the right of the audio or subtitle that tells you which one is playing at that time.
    The picture is an example of what I mean
    CloneBD selection.jpg
    My copy has 3 English subtitle tracks and on mine the second English subtitle track is the German only one.
  8. Adbear

    Adbear Well-Known Member

    Actually I've found it to be the opposite. Having been converting a lot of my films to MKV I've found just about all of the ones that have a foreign language section have a separate subtitle track for the foreign language only
    Last edited: Aug 27, 2015
  9. pepegotme

    pepegotme Well-Known Member

  10. pepegotme

    pepegotme Well-Known Member

    I tried Audio and Subtitles combinations, as changing Audio only would limit subtitles possibilities. Still, no subtitles when german is spoken. I don't fault CloneBD as the problem exists with BD Rebuilder too. They did something different so that only the original disc gives the english subtitles when german is spoken and copies do not. The english subtitles for german should have been imbeded on the main track but, they were not obviously.
    Last edited: Aug 27, 2015
  11. Adbear

    Adbear Well-Known Member

    My copy works fine with either CloneBD or BD rebuilder.
    It makes no sense that changing audio tracks would have any effect on which subtitle tracks you can choose as they are independent streams in the video file and have no bearing on each other
    What region is your copy from?
  12. gereral1

    gereral1 Well-Known Member

    I have detailed videos on how to entract the stubbern forced subtitles out of the main subtitle if you cannot figure this out. I always use the manual way to extract forced subtitles if they are in the original subtitle flagged as forced or as a separate subtitle. What I do is extract the forced only out of the main to get English appear in sections where other languages are spoken. I'm sure there are many more ways out there but this is mine. Goto third party products ultimate htpc thread to find the videos.
  13. pepegotme

    pepegotme Well-Known Member

    Region 1, USA
  14. ddjmagic

    ddjmagic Well-Known Member

    What available subtitle options do you see when clicking the floating 'settings' option that appears? (screenshot may help)
  15. Adbear

    Adbear Well-Known Member

    On mine I have the following
    woman in gold.jpg

    If I choose the second English subtitle track it only has the foreign language parts
  16. ddjmagic

    ddjmagic Well-Known Member

    From the first screenshot posted it looks like it should be the same on the OP's disc too.

    pepegotme - Does your subtitle selection list look like Adbear's screenshot?
    If so, have you tried unchecking everything except the second English subtitle track as Adbear suggested?
    If not, what are the available selections?