Subtitles - continued

Discussion in 'Issues and Bugs' started by pepegotme, Sep 1, 2015.

  1. pepegotme

    pepegotme Well-Known Member

    Movie: Woman in Gold

    Mode: Create Disc or Folder or ISO/Partial Copy/ Main title selected, only with DTS Audio and second English subtitle. Results Preview plays perfectly with only English subtitles when German is spoken. Now, when you complete the process, the english subtitles are no longer present as they were in the preview.
    The other mode: make MKV produces a perfect product with only English subtitles only when German is spoken with identical settings. Go figure!
    I find the best mode is making a file MKV,MP4 as MPEG-2 Stream does not function.
    I would like to see DVD and m2ts added to the above list. To me, they are more useful
     

    Attached Files:

    Last edited: Sep 1, 2015
  2. Adbear

    Adbear Well-Known Member

    What are you using to play back the partial copy? In PowerDVD I have to turn the subtitles on as it appears to lose the forced subtitle flag

    Also at the moment MKV subtitles are hardcoded into the video which is why they show up. Separate subtitle tracks haven't been implemented.
    MP4 subtitles are also hardcoded into the video stream.
     
    Last edited: Sep 1, 2015
  3. pepegotme

    pepegotme Well-Known Member

    I am using VLC and Splash. The su.btitle should be hardcoded into the video file but, apparently not. Why does the preview get it right and the final product wrong? It should work on any good player of which the two I mentioned are. There is a problem here. I seems that going the MKV route yields much better results and is the way to go.
     
  4. Adbear

    Adbear Well-Known Member

    If you are making a Blu-ray output then the subtitles won't be hard-coded into the video stream as it's supposed to be a separate stream just like it is on the original disc. Only thing it's not doing is setting the forced flag so the subtitle stream plays automatically.

    VLC is not a good player for Blu-ray as it often picks up on the wrong play-list and doesn't support menu's properly.
    As to Splash, never heard of it before, but having looked it up there appears to have been no updates for around 2 years with people complaining about things like no chapter support in MKV's
     
    Last edited: Sep 1, 2015
  5. pepegotme

    pepegotme Well-Known Member

     
  6. pepegotme

    pepegotme Well-Known Member

    Are you alluding to a player problem? The player is not setting the flag for the subtitles?
     
  7. Adbear

    Adbear Well-Known Member

    Normally the subtitle stream would have a 'forced' flag on it so proper Blu-ray playback software such as PowerDVD would automatically play that subtitle stream, but when CloneBD remakes the Blu-ray it's removing that forced flag so you have to turn on subtitles in your playback software so it plays it.
     
  8. ddjmagic

    ddjmagic Well-Known Member

    Sometimes the subtitles aren't flagged as forced to start with.
    The menu is used by "proper" players to determine what to playback (so it's never an issue)

    Maybe CloneBD could have an option to mark a subtitle track as forced or default.

    If I remember correctly 'rotty dog' created a tool to flag a track as forced on a movie only folder or ISO.

    Edit: Tool is here.
     
  9. Adbear

    Adbear Well-Known Member

    Well with this film I would expect the second subtitle track to have a forced flag as it only contains the foreign language parts.

    It would be good to have the option to set a subtitle stream as forced
     
  10. ddjmagic

    ddjmagic Well-Known Member

    From my experience most separate 'foreign only' tracks don't have the flag - The menu/code tells PowerDVD what subtitle to use.
     
  11. Adbear

    Adbear Well-Known Member

    In my experience it's the other way round, and on this film the foreign audio subtitle tracks have forced flags for each subtitle on the foreign language track
     
  12. ddjmagic

    ddjmagic Well-Known Member

    In that case CloneBD should be keeping the forced track flag, perhaps a bug or an oversight :)

    The last disc I remember having a separate English 'foreign only' subtitle track was Taken 3 and it was not flagged as forced.
    Only way around it was to manually mark the track as forced (If I remember right, the first two movies were the same too)
     
  13. ddjmagic

    ddjmagic Well-Known Member

    Actually forget that. I just checked and it was flagged as forced :oops::D
     
  14. ddjmagic

    ddjmagic Well-Known Member

    I just tried Taken 3 movie only in CloneBD (uncompressed) with the 2nd English subtitle track selected (foreign parts only) and it played fine in PowerDVD/TMT - Subtitles were automatically shown correctly during the foreign only parts without being manually selected.

    Could be something about the disc in question that causes a problem or maybe re-encoding the audio/video causes the issue :confused:
     
  15. Pete

    Pete Forum Admin Staff Member

    With MP4, there's nothing that can be done about it, but for MKVs, as far as I know, that's currently second or third on the todo list.
    There have been technical problems with "dynamic subtitles", which need to be overcome first.

    Presently they're working on speeding up things (faster encoding).
     
  16. Adbear

    Adbear Well-Known Member

    I was just pointing out that that's the reason why those file types have the subtitles showing.

    Any chance of adding to the list an option to flag a subtitle stream as forced on the Blu-ray side?
     
  17. Pete

    Pete Forum Admin Staff Member

    Sure - I saw that on the list as well, so it will get added sooner or later.
     
  18. pepegotme

    pepegotme Well-Known Member

    Where do you get this information from, as to what is in the loop?
     
  19. Adbear

    Adbear Well-Known Member

    Pete is Admin so he has access to things that are going on behind the scenes
     
  20. ddjmagic

    ddjmagic Well-Known Member

    I managed to try the disc in question myself (Woman in Gold US).
    I demuxed the 'foreign only' subtitle track (2nd English track) and can confirm it does not contain any forced flags.

    So on this particular disc CloneBD isn't removing the forced flag as it isn't there to start with.
    Only options are to manually mark the track as forced/default with other software (until CloneBD has this option), manually choose the track in the player or keep the original menus.

    I tried around 10 other similar discs - Those that have tracks that did contain a forced flag are passed through fine with CloneBD and play automatically in a player that can handle them.