Sub-title Issue

Discussion in 'AnyDVD HD (Blu-ray issues)' started by Flasher, May 28, 2014.

  1. Flasher

    Flasher New Member

    When I play the original BD and it comes to a scene where someone speaks other than English, a subtitle appears in English. When I play a copy of the same BD, and when it comes to that same part in the movie, no subtitle appears. I can switch to "display subtitles", but now every conversation has English subtitles, which is really annoying. I am extracting the original BD to disk, then burning it to a BD-DL with ImgBurn. Is there a setting I am missing in AnyDVD before extracting the files to disk?
     
  2. Adbear

    Adbear Well-Known Member

    AnyDVD doesn't touch the subtitles. If you have the original disc in the drive and have AnyDVD running in the background can you play it in the computer and do the subtitles show up then?
     
  3. Flasher

    Flasher New Member

    Yes, the original plays with the correct subtitling when playing through the computer. The problem only happens when I put the burned BD in my Samsung set top player.
     
  4. Adbear

    Adbear Well-Known Member

    Well if the original plays fine in the PC with ANyDVD HD running in the background then there's no reason the copy shouldn't work unless you've processed it through something. Did you rip it as an ISO then burn the ISO?
     
  5. rotty dog

    rotty dog Well-Known Member

    Question 1. Have you copied whole disk or Movie Only.

    Question 2. How many English Subtitles are available on the original movie

    Question 3. How many English subtitles are available on your copy
     
  6. Flasher

    Flasher New Member


    1. I copied the whole disk by copying the files to the hard drive (not ISO).
    2. There appear to be 2 English subtitles (English & English SDH).
    3. There are the same 2 English subtitles on my copy.

    Like I said both original and burned copy play perfectly on the PC, it's only the burned copy on the Samsung set top that doesn't display the subtitles right at the part where the actors speak French (20 minutes into the movie where Matt Damon is on the dock and 2 men walk up and begin to speak French.) The movie I'm referring to is The Monuments Men.

    I almost think there's something wrong with the Samsung player, expect the original plays just fine.
     
  7. wowszer

    wowszer Well-Known Member

    Subtitles can be a sob to navigate, as 1 disc has only 1 language subtitle, another has 2 or more, then there are 3rd language subtitles. handled somewhat differently. And a lot depends on your program you are using to make up a backup, and their settings. And there are variations to a movie, depending on area. Answers to questions like that, require all those variables be posted, and waiting for an answer from someone with the same particular backup requirements as you. Or experimenting on your end. And still, sometimes you wont get everything.
    +
     
  8. Adbear

    Adbear Well-Known Member

    Seems strange that it works on the PC and not on the Samsung. That would imply that the Samsung is having an issue with it.
    Although I can't see how any of the settings would cause this effect, what are your settings in the Blu-ray section of AnyDVD?
    What brand of disc are you using?
    Have you tried ripping as an ISO and then burning the ISO to disc using Imgburn?
     
  9. Recycle

    Recycle Well-Known Member

    Also with this where is the log file? That would be the thing we need before knowing if there is any problem related to Anydvd? Without thought that the OP can say anything.
     
  10. Jeff R 1

    Jeff R 1 Well-Known Member

    The OP said "I copied the whole disk by copying the files to the hard drive (not ISO)".

    Flasher; You need to create an ISO not a bunch of files of the disc.

    I have this disc and my back-up have forced sub titles in XBMC and Arcsoft TMT6, and if I were to burn those ISO files to a disc, I am quite sure it would play with forced sub-titles on my stand-alone Sony.

    Select "Create Image Files From Disc" in Imgburn or the "Rip To Image" function in AnyDVD HD.
     
    Last edited: May 29, 2014
  11. Flasher

    Flasher New Member


    Thank you. I will try creating an ISO. Can you give me any advice on the correct settings? "Keep Protection"?? Create add'l dvd file? Create Image File as a sparse file??
     
  12. Jeff R 1

    Jeff R 1 Well-Known Member

    There default settings are "un-ticked" so leave them as such.
    There is no explanation to them _ if you right click on them nothing comes up and there is none in the "Help file, but it doesn't matter, just leave them un-ticked.
    Obviously if you ticked the one "Keep Protection" you would not be able to play the burned disc in any computer player or any stand-alone.
    The other two, I ma not really sure, you can do a forum search and I am sure you would find a thread that would tell you.

    I've always used Imgburn to create my Blu-ray ISO's so I am not familiar with the ISO function built into AnyDVD HD, but I am quite sure that if you create an ISO of the movie, the forced sub-titles will work.

    I just did a quick search for Sparse File and I found this.

    https://forum.slysoft.com/showthrea...ripped-as-sparse-files&highlight=Sparse+Files

    You can do the other one, but again, just leave them un-ticked.

    Here's another one:

    https://forum.slysoft.com/showthrea...image-as-a-sparse-file&highlight=Sparse+Files
     
    Last edited: May 29, 2014
  13. Electricjohn

    Electricjohn Member

    Help, I am having the same problem except my recorded Blu-ray movies are not showing English subtitles over foreign languages when I try to play them directly from my hard drive, unless I turn on the full subtitles. It happens when I view the movies directly from my HDD. This just started ~2 months ago and just now it is doing it with a new copy of The Godfather 1. I use K-lite Codec Pack w/Media Player Classic. Everything is updated with the latest version.
     
  14. Ch3vr0n

    Ch3vr0n Translator NL & Mod

    AnyDVD has no control over which subtitles are or aren't shown. It only rips 1:1 or not all or decrypts. Whatever your problem is, it's not an AnyDVD one but down to your playback codec software.

    Most decent players have their own codecs and don't need stuff like that k-lite, that's Windows XP dated stuff.

    Oh and your do know the last post in this topic was 3.5 years ago right?

    Sent from my Nexus 6P with Tapatalk
     
  15. Electricjohn

    Electricjohn Member

    Yes I saw the date. This sub was what came up when I searched my problem, and it worked. Thank you. My subtitle problem is weird because it just started doing it. I'll check with Media Player Classic & try an earlier version and, you are right I've been using K-Lite since XP out of habit.

    2017 Digital Storm Slade