[SOLVED] Please help: what am I supposed to do first??

Discussion in 'AnyStream' started by dsperber, Nov 1, 2020.

  1. dsperber

    dsperber Member

    I want to download a 2-episode series from Amazon Prime, which I've now purchased (and canceled and re-purchased three times already because I don't know what to do next). I'm signed into my Amazon account, I've closed and re-opened Anystream, but I can't seem to make anything happen other than to download the TRAILER (which is probably free). The individual two episodes themselves don't see to be playable or downloadable.

    I've purchased the series, and it's shows as available for download or play (I suppose). Anystream only shows Downloadables (1) which results in the trailer being downloaded. But the two episodes themselves seem unobtainable. What do I do to get them??

    Here is the main purchase result:

    xMQHMP.jpg

    And here are the theoretically available episodes and trailer:

    l9vFQU.jpg

    So what do I do next?? How do I initiate and perform the download of each of the two episodes??

    Do I have to push the "download" button at the right of each episode's offering? I've tried that but nothing happens. I've also tried simply pushing the PLAY button but that results in an error message:

    IzAPFL.jpg

    I suppose I would have to use Firefox or Edge or Chrome to actually PLAY the episodes, and that Anystream can't actually be used to PLAY. Presumably it can only DOWNLOAD.

    So, please give me a few instructions. What do I do first, second, etc., in order to retrieve the two episodes I've purchased?
     
  2. Ch3vr0n

    Ch3vr0n Translator NL

    you're clicking on the wrong button. You're probably clicking on the arrow icon on the left or the blue circular play button. You need the "Downloadables" button up top. Which is why the text is in green ;)
     
  3. dsperber

    dsperber Member

    I made reference to that "Downloadables (1)" button in green. It only shows (1), and when I push that button it downloads the trailer. So far, so good.

    But my plea for help regards the two real episodes. Those are what I really want to download. And if I push the arrow icon on the left or the blue circular play button I get the error message shown above.

    And if I push the "download" button (to the far right of each individual episode row as well as the trailer), nothing happens. There is no change to the "Downloadables (1)" green button content, nor does anything actually start downloading from Amazon itself.

    Hence my plea for help. How does one use Anystream?? What am I supposed to do, in order to retrieve these two episodes which presumably are actually available within a Firefox Window for PLAYING or DOWNLOADING. If either or both of these functions is supposed to be why I bought Anystream, I need some help and instruction on exactly what I'm now supposed to do, to accomplish the objective.

    Is Anystream only usable for FREE content with Amazon? Can it not be used to download for-pay content as well, which I've truly paid for and can actually PLAY/DOWNLOAD using Firefox?
     
    Last edited: Nov 1, 2020
  4. Ch3vr0n

    Ch3vr0n Translator NL

    That's normal behavior. AnyStream's built-in browser doesn't have the DRM those buttons require. Which is why you need to use the "Downloadables" button up top.

    Not meaning to be sarcastic here, but one use the downloadables button up top. That's the only correct download button. You do NOT click on any other play/download button. This is confusing yes, that's being worked on / considered to hide those buttons from the built-in browser.

    No, it works for paid content too. However the paid content must be purchased and made available to your account PRIOR to launching anystream.
     
  5. dsperber

    dsperber Member

    This is what I was really looking for. This is the "secret sauce".

    Not knowing this requirement I had simply treated Anystream as a browser (it sure looks like one), and signed into Amazon and made my purchase... all within Anystream. And the only thing that showed up in "Downloadables (1)" was the free trailer. And nothing else I tried made any difference, with the downloadbbles button always showing (1).

    But now that you have actually answered my "plea for help" and given me the missing instruction... that the purchase must be made outside of Anystream, before launching Anystream... now I've got "Downloadables (4)". It wasn't that I couldn't understand or intuit the purpose of the downloadables green button. It was the fact that I didn't know the purchase must be made before launching Anystream, and that if you went ahead and made the purchase within Anystream that was doomed to failure.

    That is what I needed to be told. Perhaps there might be some FAQ or opening README or instruction when installing, that tells me this very basic but very crucial fact. Had I know that in advance I never would have stumbled around continuing to do the wrong thing. I had no idea I couldn't make the purchase within Anystream, because it all went perfectly as far as Amazon was concerned.

    Anyway, I'm now over this initial newbie 1st-usage hurdle. I didn't have to push anything on the detail lines of the Amazon GUI, no PLAY nor DOWNLOAD. Once the "Downloadables (4)" green button populated properly I simply had to use the Anystream GUI to initiate the desired downloads. Obviously this is intuitive, and easy to drive.

    I've now also changed the default setting for DOWNLOADS to put it on the partition I really want it on, and upped the download speed to be "unlimited". I don't expect to be really be doing much of this and once I initiated the download and things settled down it seems to be downloading at about 50Mbps, which is fine. Far from superspeed, will take some time, but clearly better than 1x realtime. Just fine, however long it takes. Most important is that I will have the two downloaded episodes, which was the objective.

    Again, thanks for providing the crucial tip about how and when to make a purchase, before launching Anystream to do the download for that purchase.

    Case closed.
     
  6. Ch3vr0n

    Ch3vr0n Translator NL

    AnyStream does use a built-in browser (especially for the amazon side) based on chromium. However it's not a full-featured standalone one like Firefox or Chrome. Which is why that DRM message pops up when you click the wrong icons :). I'm not entirely sure if the purchase must be made OUTSIDE of anystream.

    What i said was it must be made available PRIOR to launching anystream. Which means that if you purchase from within AnyStream, it doesn't know the content is made available to you on that page. You could try making a purchase, navigating to a different title available to you, then navigating back to the one that wasn't available. There's a good chance it will now be available to you as anystream reloads the page.

    You could also try a purchase from within anystream, then simply restart anystream and access the title again. There's a good chance that will work too.

    As to the speed. The "unlimited" one on the amazon side is far slower than "unlimited" on the netflix side. This is due to having to implement support differently.

    Glad i could be of assistance!
     
  7. The Roadie

    The Roadie Member

    This is the behavior I use and it works well.
     
  8. dsperber

    dsperber Member

    Thanks for this tip. More convenient to just use AnyStream for all related activities, subject to a small technique trick like this to make it possible.

    I haven't yet tried the Netflix interface, but suspect I will pretty soon.

    This newly available ability sent me on another tangent, and resulted in acquiring another piece of software. I had been using a very capable free software product named multiAVCHD which has been available (and abandoned by the author) for many years. I had used it to produce authored BluRay discs of copy-freely MPEG-2 content clips edited from TS (from DVHS VCR recordings) and WTV (from Windows Media Center). I like having discs for permanent storage for content that plays for hours.

    Well, turns out multiAVCHD is incapable of dealing with modern MPEG-4 compression in MP4 wrappers (e.g. for 1920x1080p BD-compliant content), which is what is what Amazon delivered through AnyStream. I have no interest in transcoding and losing "original quality" and so looked around for an alternative to multiAVCHD. I already was using DVDFab 6 as my disc player on my PC, and they have a BluRay Creator product (DVDFab 12) which does just what I want. It doesn't have the complete flexible authoring functionality as multiAVCDHD does (or at least if it does I haven't yet learned how to use it), but it works perfectly and quickly (with no transcoding and recompression unless you ask for it to reduce output file size, but reproducing original quality output video if desired as I do). The menu, such as it is, really just provides basic navigation through main titles (e.g. the two episodes of the program I purchased on Amazon), just without lower-level chapter/scene functionality. Not a problem for this type of content, which is not disc-based.

    So between AnyStream and DVDFab 12, I'm set to deal with MPEG-4, which is the way of the world now.
     
  9. Ch3vr0n

    Ch3vr0n Translator NL

    If you want to create your own discs, you don't need that over expensive piece of bloatware called DVDCrap. Vso software's "ConvertXtoDVD" or "ConvertXtoHD" is all you need. If you want to make changes to the mp4 there's MP4BOX or MakeMKV(GUI) which handle the mp4's AnyStream creates just fine.

    Sent from my Pixel 3 XL using Tapatalk
     
    whatever_gong82 likes this.
  10. dsperber

    dsperber Member

    Well, I've now spent the past 2 hours trying to get VSO Software's ConvertXtoHD to do the very same thing I instantly accomplished with DVDFab 12 the first time. The VSO product is certainly more capable and I would be glad to make use of it to do more sophisticated authoring (if I wanted to), but in this case I'm simply trying to produce a single output BluRay from the two MP4 files downloaded from Amazon by AnyStream. That's it, except that I want it to be "fast copy" with no transcoding and re-compression. Just combine the two titles, and put out the 1080p 24fps BluRay with a simple main menu that shows the two titles. Same as I did with DVDFab 12.

    Took me a while to try and figure out what settings I needed to just do a "raw copy" and inhibit the transcoding that used 100% CPU, and eventually seemed to have figured out the right combination of otherwise non-inuitively expressed English options. They're French I believe, and the English in the product is less than clear. Anyway, apparently I eventually guessed right on all the things I had set and the 2-file simultaneous conversion ran at excellent speed, doing a "raw copy".

    Until it crapped out. Doesn't work. Some kind of memory management issue.

    Program craps out after 33% converting the first file, pausing that conversion because of "running low on memory". The second conversion continues up to about 35% and then it too stops, and the program then quits with a sound advising "we have a problem", and suggesting to look at the log. The log provides a good deal of detail, but does not provide anything I can make use of to figure out what might be wrong or going on.

    I then went to their site and downloaded the latest beta (2 versions newer than the "latest" available for normal download), but it made no difference.

    I'm going to post a "please help this newbie" article on their Forum, similar to what I did here on this forum. I must have set something wrong which is resulting in this program failure of "insufficient memory", but I'm just a USER not a DEVELOPER. I shouldn't be able to cause this result.

    I will persist to see if I can overcome this initial obstacle, because it's likely the product is a nice replacement for multiAVCHD and clearly supports MPEG-4 which I need. And I will buy it if I can get it to complete for me. But for now I'm dead-in-the-water and exhausted.
     
  11. dsperber

    dsperber Member

    Just thought I'd add a postscript to this thread of mine, regarding my ongoing attempts to find a suitable BluRay authoring product that can create playable formats (BluRay folder, ISO, burned disc) from the MP4 MPEG-4 streams provided through Anystream. I've learned much during this past month, and believe it or not have still not found any BluRay authoring product that actually does what I want. Even more frustrating, a number of these products don't even "work successfully" to produce the outputs their writeups promise.

    Again, my objective is simple: I'm looking for a BluRay authoring product that can produce nothing fancy. Just maybe a simple main menu that allows me to directly play the one or more individual titles I'd like to put on a single BluRay disc. And the input titles are the MP4 MPEG-4 streams obtained through AnyStream, which would typically be 1920x1080p video with EAC-3 DD 5.1 audio (or worst case DD2.0 or PCM 2.0 audio). I want the product to produce 100% original source quality for both audio and video, i.e. REMUX-ONLY MODE. All that needs to be done is a re-wrapping, from input MP4 form to output M2TS form (for BluRay). No re-encoding of either audio or video, but pure "direct copy" and re-wrapping.

    (1) Turns out DVDFab 12 BluRay Creator does NOT actually provide a REMUX-ONLY mode. Although it offers an option named VIDEO QUALITY with a choice of "original source", that actually is not implemented as a "direct copy". In fact even if you choose 'original source" you will get re-encoding!! Runs fast (using both CPU and GPU/CUDA, which may simply speak to the quality of the output) but is still absolutely NOT "ORIGINAL SOURCE". Very misleading and dishonest in my opinion.

    (2) Turns out VSO Software's ConvertXtoHD product current official version 3.0.0.69 (and latest official beta 3.0.0.73) purports to offer a REMUX-ONLY MODE in fact has a major defect, which is a "memory leak". So while it may be able to complete with a very small single input file, it absolutely cannot complete with one or more normal size input files. It simply consumes all of memory and finally crashes.

    (3) VSO released a 3.0.0.74 beta of CXtoHD which actually DID FIX THE MEMORY LEAK when running in REMUX-ONLY MODE. So it was now possible to run the program to successful completion, but only if just one single input file was used. If two or more input files were specified the program crashed when running in REMUX-ONLY MODE. Some progress, but not much.

    (4) Making matters even worse, even when successfully converting only one input file in REMUX-ONLY MODE the 3.0.0.74 beta of CXtoHD was further defective in that there was NO AUDIBLE AUDIO in the output. Research discovered that it was failing to properly populate PID x1100 (for describing audio) in the output 00000.M2TS file, which prevented the imbedded EAC-3 DD5.1 audio from being played. Experimentation discovered that if REMUX-ONLY MODE was specified just for the video while "forced re-encoding of audio to EAC-3" was specified, well now the PID x1100 information WAS CORRECTLY POPULATED. It's not clear if the original input EAC-3 audio was actually re-encoded to output EAC-3 audio since it was already in the correct format. But whatever the story the fact is that PID x1100 information was now populated correctly and there WAS AUDIBLE AUDIO in the ouput.

    (5) I've also experimented with free trials of several other BluRay authoring products (retaining individual titles and offering main menu supporting navigation), but none of them offer REMUX-ONLY MODE. These products include Xilisoft, Leawo, AVCHDCoder, Wondershare, and none of them do what I require when testing them with the simple 2-input file MP4 trial.

    (6) I'm still researching, looking for another product.

    (7) VSO has been provided with all my research results, and has been able to duplicate ALL of my unsuccessful results when attempting REMUX-ONLY MODE. They have duplicated the "crash" when using two or more input MP4 files. They have duplicated the "no audible audio (because of missing PID x1100 data)" when using only one input MP4 file. And they have duplicated the "audio audio produced" if simply forcing "create EAC-3 output audio". Hopefully they will solve the crash, and figure out why they overlooked building PID x1100 data, and the next beta 3.0.0.75 may well work successfully.

    Frustrating.
     
  12. bufasimun

    bufasimun New Member

    Have you tried tsMuxeR? This little program is freeware and works wonders.
     
  13. dsperber

    dsperber Member

    Turns out my inability to get multiAVCHD to work with MP4/MPEG-4 videos was my own problem. I had unwittingly failed to also install the prerequisite 3rd-party software products on the particular "new" machine I was working on. Once I noticed that, and completed the simple installs of AVISynth, FFDSHOW and Haali Matroska Splitter, I was home free! Sure enough now multiAVCHD worked perfectly for me.

    And because I was familiar with how to use multiAVCHD to create a beautifully authored BDMV supporting remux-only for applicable formats (of which these new MP4/MPEG-4 H.264 1920x1080p videos were (including with DD5.1 audio), I was now able to easily produce BluRay discs with multiple navigable titles (if I wanted), multiple navigable chapters within each title (if I wanted), and my own selection of text/thumbnails for titles and chapters.

    So in the end I was back to multiAVCHD where I'd actually started!!! All my efforts to get other software products to work to my liking... and none of them actually worked as I wanted, if they even worked at all!.. none of that searching was really necessary at all. All "trial" products offering remux-only failed (AVCHDCoder and VSO ConvertXtoHD), or wouldn't accept these MP4 files I wanted to use for remux-only (TMPGEnc Author Works 6). And the one product which actually "worked" (DVDFab 12 BluRay Creator) didn't support remux-only as I thought it did, but instead always re-encoded everything.

    Yes, I did attempt to use tsMuxeR, but this was quite inadequate and non-intuitive and complex.

    multiAVCHD is really the way to go. So that's where I'm back to.
     
  14. bufasimun

    bufasimun New Member

    OK, glad you could solve this and thanks for the info!